Jump to content

Can boot into INTEL osx installer on AMD box fine but once I patch the iso for AMD support w PPF, it is no longer bootable. How to inject AMD kernel?

11 posts in this topic

Recommended Posts

Hey all,

I have a pretty general question that is applicable to any build really and Im not looking for specific hardware specifics or anything other answers that I could find by scowering the forums and trying different things and going off on my own. I have tried really hard and Im almost there. Heres my deal: putting osx on my old toshiba laptop. Its an AMD 64 processer. I've had success with kalyway 10.4.10 and JaS 10.8 (Please, before you say only "thats too old a version for support", hear me out. I cant get with a newer version because only the older ones are compatible with older hardware such as this). So, I can succesfully boot from the "Kalyway 10.4.10 (IntelSSE3 + V1.1_AMD&SSE2_Patch+fixes)" stock ISO (that is, the one meant for Intel architecture, without patching the PPF for supposed AMD support). The disk boots perfectly and even recognizes the internal drives which is a godsend as the bios is stripped down and leaves no tinkering for stuff like ACPI. I install it fine and everything and obviously get a kernel panic when it reboots, as, it wasnt meant for AMD arch. But when I patch the .iso with the ppf that is supposed to enable amd support thanks to the new darwin kernal version 8.8.1, it wont boot into the installer, the screen just pauses at "darwin kernal version 8.8.1" and doesnt get through. Ive tried everything (yes, I did google darwin kernal version 8.8.1 and its a known panic that, nobody really knows how to fix apperently). So how should I go about getting the kernel that works onto either the already installed system or the install disk itself? I have 2 ideas:


1) figure out how to patch the kernel to an AMD one, AFTER installing it like how I did (I believe you can patch the kernel through the terminal via the install disk, and Ive found threads but it is so daunting, it doesnt seem easy to even track down the kernels themselves, let alone track down the commands to patch the acting kernel)




2) take the working parts of the Intel install disk (that is, everything but the kernel, basically, and "move it over" to the pathed AMD iso). This way seems like it would be easier. I have the disk that boots perfectly and recognizes everything harware wise but audio (no biggie) and wifi (again, no biggie. At least I can get in the installer and run it). It seems like theres something messing up the ability to boot it when I patch it. How would I go about making a hybrid of the two disks? I read the guide on injecting drivers from kexts and what not and its pretty crazy. Just looking for some thoughts on if this is even possible. I dont wanna try any more distros as I've gotten 6 in the past few days and Im not trying to get on anyones bad sides or anything. Just curious if anyone has any ideas.


TL;DR: Its possible to boot from an INTEL version installer but when I patch it through PPF-O-Matic with the supposed AMD kernel, it is no longer bootable. How can I take the kernel that I need and put it into the instalation disk that works, or vice versa?



Link to comment
Share on other sites

Do you have a working Mac installation that you can work from?


An install DVD has two basic sections…the section that boots the DVD so that it can perform the installation and the section that actually performs the installation. The section that actually performs the installation is a series of installation packages stored in the folder /System/Installation/Packages. So the plan would be to delete the Packages folder from the bootable Intel iso and replace it with the Packages folder from the non-bootable AMD iso. That way you could boot the DVD but you would be installing the packages from the AMD DVD.


The modifications are easy and quick if you have an existing Mac or Hack to work from.

  • Like 1
Link to comment
Share on other sites

rlf, thank you for getting back to me. Yessir, I got a new MBP to work from (running lion), and I have a windows 7 box as well. Im not short on resources. I did come across that packages directory and I hoped this would be easy/possible. So I'm just to copy over the packages dir from the amd disc onto the intel one, right? The problem now that I have is that I've just realized that the patched version of the iso (patched with the included amd ppf) is not readable in OSX, even though on the toshiba it boots up to and freezes when it gets to the famous "darwin kernel: version 8.8.1 ...." So now, my life is harder. When I attempt to mount the patched iso, it gives me the "no file system to mount" error. I have patched the iso in both windows and osx many times and I'm guessing something may be majorly up with the ppf file or something? Another though is that I have JaS 10.4.8 and it will boot as well but it doesnt recognize my internal drives like the kaly distro does. I installed JaS successfully on a thumb drive last night and have been working all day to get around the "waiting for root device". I figure Im so close with the kaly distro. Not even on an old alienware laptop was I lucky enough to recognize the internal drives. I figure Im so close with that distro. So, should I maybe try what you recomend, with copying over the package dir from the JaS distro? I know, its getting sketchy injecting stuff from 10.4.8 to a 10.4.10 disk. Man. They never make it easy. Thanks for your help man. Ive been at it for 48 hours straight here. Theres gotta be a simple way here. I may try redownloading the kaly distro but as these can only be found via torrents, Im not looking forward to getting a bunch of nasty letters. Ive been chalking up many distros as of late.


Yeah and I tried repairing the patched image and what not. No dice. The dvd is not recognized in OSX but it is when it boots off the toshiba (to some extent). Weird.


Oh yeah, one more quick question: When and if I am able to copy the amd packages folder over from the kaly distro or even the JaS one, do I have to change the permisions or bless anything? Just curious. It seems like it shouldnt be as easy as just drag and dropping but this is my first time with this route.

Link to comment
Share on other sites

There has to be something wrong with your PPF patching, because I patched the iso with the PPF and was easily able to mount the resulting iso. The answer may be so simple as to properly apply the PPF to the iso.

Link to comment
Share on other sites

Thats what Im thinking too as it seems to be corrupting the iso. Using the included PPF-O-MATIC (ver 4.4.2 in OSX & ver 3 in windows) that was included with the distro: Torrent Removed Do you use another PPF patching solution? All Im doing is clicking apply. Guessing the ppf file is jacked (even though it tells me the patch was successful). Im gonna try finding another copy of it and will also see about copying over the 10.4.10 packages to the JaS distro (this probably wont work Im guessing and it may even copy over the intel kernel, still...) Thanks again.

Link to comment
Share on other sites

Just slow down and let me guide you, OK?



First, let's apply the PPF.


Put these on your Desktop

- The ApplyPPF program

- a COPY of the Kalyway Intel iso

- a COPY of the AMD PPF


We are going to use Terminal but we won't be using a lot of typing. Instead, we'll be dragging and dropping a lot. So do NOT press <Enter> until told to do so.


Open Terminal

- Drag and drop the ApplyPPF program into the Terminal window

- Type: a

- Press: <space>

- Drag and drop the Intel iso into the Terminal window

- Drag and drop the AMD PPF into the Terminal window

- Press <Enter>


When the patching is done, rename the patched iso to Patched.iso



  • Like 1
Link to comment
Share on other sites

You sir are a saint and a scholar but alas...


MBP:~ Maestro$ /Users/Maestro/Desktop/ApplyPPF a /Users/Maestro/Desktop/Kalyway\ 10.4.10.Intel\ SSE3\ Only.iso /Users/Maestro/Desktop/Kalyway\ 10.4.10_V1.1.ppf ApplyPPF v3.0 by =Icarus/Paradox Mac OS (Universal Binary)= Nov 8 2006

Patchfile is a PPF3.0 patch. Patch Information:

Description :

File_id.diz : not available

Patching ... successful.

MBP:~ Maestro$


I did it word for word what you said and the new iso now comes up with the same filesystem error and is unable to mount. Im guessing its the ppf which sucks because Im having issues finding a different copy of it. I found a newer kalyway distro 10.5.2 but its probably too new for this machine. Thanks for giving me this alternative method to patching. Not sure if you got any other ideas or ways to go about it but I really appreciate your help. This has been killing me.


just noticed the naming scheme going on here...im gonna rename the original to something simple like osx.iso and try it that way. maybe something got messed up because theres spaces in the name. Trying it right now.


...nope. Didnt help renaming it 'kalyway.iso'. Plum outta ideas.

Link to comment
Share on other sites

Well, while we work out the PPF problem, let me post the meat of the swap process:




OK, now we'll switch out the Packages folder.


Put the Kalyway Intel iso in the center of your Desktop.


Put the Patched.iso on the left side of your Desktop.


Open Terminal

- Type: sudo hdiutil attach -readwrite

- Press: <space>

- Drag and drop the Kalyway Intel iso into the Terminal window

- Press: <Enter>


On the right side of your Desktop, you will see an icon named "Kalyway 10.4.10.Intel SSE3"


Double-click the icon to open "Kalyway 10.4.10.Intel SSE3" Double-click System folder and then Installation folder


You should now have a window labelled Installation.


Drag the folder Packages to the Trash. Empty the Trash.


On the left side of your Desktop, double-click the Patched.iso.


Notice on the right side of the Desktop there is a 2nd icon named "Kalyway 10.4.10.Intel SSE3"


Double-click this 2nd icon. Double-click System folder and then Installation folder


You now have a 2nd window labelled Installation


Drag the Packages folder from the Installation window for the 2nd icon and drop it into the Installation window for the 1st icon.


Wait for the copy to take place.


On the right hand side of the Desktop, drag one of the icons named "Kalyway 10.4.10.Intel SSE3" to the Trash.


On the right hand side of the Desktop, drag the other icon named "Kalyway 10.4.10.Intel SSE3" to the Trash


You should be left with your modified iso sitting in the middle of the Desktop and the Patched.iso sitting on the left side of the Desktop. You want to keep the modified iso sitting in the middle of the Desktop and burn it to a DVD.

  • Like 1
Link to comment
Share on other sites

RLF: I can't thank you enough! I havent slept this weekend because this has been plauging. OSX file structure and filesystem errors, I'm still novice at. The installer came up and has all the amd options nessisary and is installing now! I'd buy you a beer if it was possible. A very large beer. Thanks again. I know what its like, when poeple troll for answers without putting in any work or gaining knowlege from the experience and that was not my intention. Thanks for teaching me and helping me out. I am in your debt. Be good.


PS: I'd be a fool if I didnt ask; what exactly is the sudo hdiutil attach -readwrite command? sudo is superuser, I get that but the hdiutil attach? Im guessing it just allowes one to mount a file that may be corrupt or have filesystem errors? Just trying to learn as much as possible but dont feel obligated to do more than youve already done. Thanks again. I really need to start reading some unix books...


buoo: appologies. I didnt mean to do that. Not tyring to get the community in trouble.

Link to comment
Share on other sites


  • Create New...