Jump to content

Input audio devices

6 posts in this topic

Recommended Posts

I've got 10.6.8 installed and running fine on my AMD PC, specs as follows:

  • ASRock 970 Extreme3 rev.2 mobo
  • AMD Phenom II X4 960T @ 4Ghz
  • 8GB Kingston HyperX Genesis DDR3
  • AMD Radeon HD 6850 (PowerColor)

My mobo is listed as having a Realtek ALC892. I'm using the latest version of VoodooHDA.


The problem I'm having is that every time I boot, the "Pink Rear" audio input is turned up, resulting in lots of static noise. It goes away if you mute that input, but having to go into Audio MIDI Setup on every boot just to do that is a bit irritating.


I'm wondering if there's some kind of script or something that can be run at boot to mute this input, instead of having to go through Audio MIDI Setup every time I boot. Perhaps even completely remove the input from OS X? I'm never going to use that rear mic input.


Thanks in advance,



Link to comment
Share on other sites

  • 2 weeks later...

Can anybody shed any light onto this? It's still really bugging me - the 'pink rear' input is always turned up when I boot, and the hiss is unbearable!


http://bit.ly/Lo9AE7 I tried using this tutorial to get my ALC892 working using other kexts. Unfortunately this didn't work at all (no audio devices listed) so I'm guessing I need to use VoodooHDA and try to get around this input issue.

Link to comment
Share on other sites

Okay, so in my quest to fix the hissing noise once and for all, I've managed to break my sound completely (oops!). I uninstalled VoodooHDA and tried using ALC892 kexts with HDAenabler and AppleHDA 10.6.2 rollback. For some reason this didn't work at all, I'm not sure why as I am using the ALC892.


I tried searching for DSDT patches for my system, but I can't find any DSDT patches for AMD boards anywhere, maybe I'm missing something? Anyway, I tried removing the ALC892 kext and installing VoodooHDA again, so I at least have sound. Unfortunately, VoodooHDA won't work any more either. It does give me 'sound', but it's very distorted and broken-sounding, and reducing the sample rate does not fix it.


So now I have no sound at all... can anyone help?

Link to comment
Share on other sites

Still can't get sound to work - really need help! I've tried ALL versions of VoodooHDA, none of which give proper sound! They just give a terrible distorted noise which can be 'altered' and slightly improved by reducing the sample rate, but even at 44100Hz the sound is still atrocious, especially when viewing YouTube videos.


I'm really lost now, when I first got this Hackintosh working, sound was fine with VoodooHDA 2.7.3, only the Pink Rear problem, but now even installing VoodooHDA 2.7.3 again does not work! I'm really lost and would appreciate any help to try to get my sound working again!


EDIT: Using VoodooHDA 2.7.2/2.7.3, setting the sample rate 44100Hz makes sound almost bearable in iTunes, it only breaks up once every 5 seconds or so, still unlistenable though. Other apps are still completely terrible.

Link to comment
Share on other sites

Okay, so I tried one more iteration of VoodooHDA, 2.6.1 I believe. Upon rebooting, I couldn't boot at all, all kinds of rubbish all over the screen in verbose mode. Eventually it just booted again, but took 15 minutes from BIOS. Then, sound worked just as before, with Pink Rear issue. Excellent! I don't know what happened, or why it worked, but after all I've been through I'm just glad it works again. The Pink Rear issue isn't so bad compared to the situations I've been in the past few days!


If anyone can come up with a solution for the Pink Rear issue, though, I'd much appreciate it!

Link to comment
Share on other sites

  • 1 year later...

yes i just discovered that turning off pink rear fixes the static for me !

i'm on voodooHDA 2.7.2 the default one on the snow leopard 10.6.3 installation disc, that the nawcom mod CD automatically selected.


i was just putting up with it before because it was quite quiet static compared to the music i was playing

perrhaps if we plug a microphone into the pink rear ? i'll try it one day

mine seems to stay off even after reboot


another thing - only just realised this thread is dated 012 and not 013

Link to comment
Share on other sites


  • Create New...