Jump to content

[Asus M4A77] ''Still waiting for root device''


4 posts in this topic

Recommended Posts

Hey all.


So I installed 10.7.4 on my HDD through a Macbook 2009, installed Chameleon and the AMD kernel. Everything seems to load pretty quickly, but booting verbose shows that it gets stuck @ ''still waiting for root device''.


Not sure if it has anything to do with it, but at boot it also tells me that it failed to load the AppleFilesystemDriver.


Things I tried:

- Sata mode is set to AHCI in BIOS.

- Tried PCIRootUID=0, UseKernelCache=No, GraphicsEnabler=No. Though might have missed the golden combination!



What to do? Thanks in advance,


Robin :)


EDIT: Hardware:

AMD Phenom II X4 955BE


6gb DDR2


Link to comment
Share on other sites

Hi there,

I have the same problem with my HP Probook 4530s when i updated to 10.74, i never had i problem with it at all before when installing osx 10.7-->10.73.

Dunno what to do mate i wish i can help you and help my self.

Link to comment
Share on other sites

I figured out why it wasn't working for me. The kernel simply wouldn't work with 10.7.4, stick with 10.7.3. Also don't forget to install FakeSMC.


10.7.3 worked for me. ;)

Im on 10.73 after i tried to install 10.74 i got to restore from backup,.

Link to comment
Share on other sites


  • Create New...