Jump to content

Installing iATKOS L2 on an Asus F50SF-x1a


5 posts in this topic

Recommended Posts



I'm currently trying to install Lion on my now dormant Asus F50SF, and am not really sure what I am doing. I suppose I should first start off with the specs of the machine:


CPU: Intel Core 2 Duo T6500


SiS M671DX



Audio: Onboard Audio

LAN: Onboard


I'm trying to turn this machine into my first hackintosh, but I have absolutely no clue how to do this. I have gone ahead and downloaded the iATKOS L2 DMG, and have tried flashing it to a Flash Drive using the dd command on my Ubuntu machine, but when I try to plug the flash drive into my laptop and boot it with chameleon, the computer simply restarts. I have no access to any device running Mac OS X, and I would really like to get this working. Any suggestions or help?

Link to comment
Share on other sites

Just a brief update: I can now get it to boot (slightly) from a burnt iATKOS L2 DVD. The problem is now, my machine hangs at "Still waiting for Root Device". I try to go into BIOS to change any of the AHCI settings, but there doesn't seem to be a way to do that on this laptop.

Link to comment
Share on other sites

I don't want to be a downer, but the SiS M671DX chipset is a major problem. Generally it is an Intel or Nvidia nForce chipset. I don't think you'll get OSX to boot the SiS chipset.


Do a Google: SiS M671DX insanelymac


You won't find anyone who successfully boot with the chipset.

Link to comment
Share on other sites

  • 2 years later...

+1 Not gonna happen

I have the Asus N90SC with SiS M671DX  chipset and i have a Yosemite USB boot stick, MacPwn, and it boots, but i cannot make it so ir recognize my harddisk. No ahci in bios.

I tried Mulibeast: 3rd party SATA and Intel Generic AHCI Sata and i tried several other IoAtaFamilt.kext drivers

No succes so far, but i have a bootable installer 


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Boot Banner</key>
<key>Graphics Mode</key>
<key>Instant Menu</key>
<key>Kernel Flags</key>
<key>Legacy Logo</key>
Link to comment
Share on other sites


  • Create New...