Jump to content
InsanelyMac Forum
p.H

Notebook 16bit color depth & ATY_Init related stuffs

Recommended Posts

Hi, guys.

First of all, some basic info about my hack

Dell Inspirion 14R  N4010
CPU:       I3-380M
GFX:       ATI-HD5650M
MB:        DELL
Chipset:  Intel HM57

Here, I want to get more details about Notebook 16 bit output in its screen

Below is the source code for 5650M in Chameleon

{ 0x68C1, 0x033E1025, CHIP_FAMILY_REDWOOD, "ATI Mobility Radeon HD 5650",   kNull  },
{ 0x68C1, 0x9071104D, CHIP_FAMILY_REDWOOD, "ATI Mobility Radeon HD 5650",   kEulemur },

 

Just as it is, I can simply enable full QE/CI and resolution with a simple "GraphicsEnabler=Yes"

But it's 16bit output in my notebook's screen

Others say when you use the extern display, it's 32 bit output.

 

In order to solve this problem, I tried my best to search on the web

Luckily, I found a solution, and it works beautifully in my hack ----- ATY_Init.kext

 

ATY_Init.kext.zip

 

Something related to ATY

First, there are many models in ATY_Init 's info.plist

post-973514-0-00683800-1336524200_thumb.png

You should try to make a decision based on your graphics card

I'm currently using the ATI Radeon 4600 Series model

post-973514-0-52220500-1336524326_thumb.png

And, I've been trying to find the reason why ATY was able to make it 32bit output in my notebook's screen

That seems to be the reason

Here's a link :

https://code.google.com/p/aty-hd/source/browse/trunk/ATY_String.h?spec=svn2&r=2

 

I'm curious about more arguements in ATY-Init

But I can no longer try to figure it out myself

So I'm here seeking for help

Best regards ~

Share this post


Link to post
Share on other sites
Advertisement

I've been trying to find the reason why ATY was able to make it 32bit output in my notebook's screen

 

I think the reason is OSX doesn't get correct EDID you put in -717 file.

 

I have same problem as you. My solution is keep original -717 file (without add EDID) and add your EDID in Ati_init.kext > Info.plis.

This hack worked perfectly with Ati 5650m on my laptop.

 

post-1310830-0-30840100-1395237850_thumb.jpg

ATY_Init.kext.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×