Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

24 posts in this topic

Recommended Posts

Hello

 

I have found something weird with the backlight function, well it's works fine, but the max brightness level isn't enough (about 80 or 90%)

 

When the Mac wakes from sleep, the Brightness becomes higher than before (100%)

 

In IOReg, i watched the "AppleBacklightDisplay", his property "IOPowerManagement" has 2 values before the standby : (CurrentPowerState & MaxPowerState)

post-822381-0-40539600-1335929023_thumb.jpg

 

After the Wake, the property "IOPowerManagement" has 3 values : (CurrentPowerState, DevicePowerState & MaxPowerState)

post-822381-0-86457900-1335929115_thumb.jpg

 

The Mac is under Ac Power not Battery, my DSDT is Patched.

 

Any Ideas ??

 

Thank you.

Share this post


Link to post
Share on other sites

Very interesting, sure many people have the same report. And another example, when I put the display to sleep, or goes automatically to sleep (only the LID screen device) and wake up, it show three values. Not before. BUT maybe is normal? should be the expected behavior in a genuine macbook pro or Air with the HD 3000 GPU? Therefore, I think we need to compare IOREGS, before sleep and after wake, from the MBP8,1 and/or MBA4,2 of course running Lion.

Share this post


Link to post
Share on other sites

Mine is 8,1 Smbios definition.

 

I Found another weird thing !!

 

When i keep my mac only on AC adapter (i remove the battery) and i (re)boot, once i'm on desktop, going to system preferences --> Energy saver. i can see that the tab is on Battery !!! and as mentioned the display sleep is in 2min, to verify that, i do nothing and about 2min the display sleep comes. When i plug the battery,the tab change to AC Adapter !!! :| (Normally is the contrary should be happen)

 

I think that something wrong in my DSDT :worried_anim:

 

If you keep the Ac & Battery and u close the clamshell, after wake, it becomes normal, and the backlight is higher.

Share this post


Link to post
Share on other sites

hi tux fire-have a question: how did you work wireless 1701? Can u help me with DSDT I have the same laptop but have I3 cpu. Ty

Share this post


Link to post
Share on other sites

I found another weird thing, always battery removed, i put the mac only on AC Power, once on desktop, i check the system properties, the mac show me that the actual source of power is the battery !!!

 

that explain why i don't have the normal backlight, because after the standby, the backlight become normal and the mac show me this time the actual source power is AC power.

 

Do you think that the problem is Battery Kexts or from DSDT ?

Share this post


Link to post
Share on other sites

Ya I got the same problem on my hp pavillion dv 6 quad core i7 . my backlight display is slightly lower than fully supportes , but when i sleep and get it to wake up the display brightness is complete as in dual booted windows

 

can someome help

Share this post


Link to post
Share on other sites

the problem is that the mac when boot, doesn't check the power statue, and automatically set it to battery. i think it's a DSDT problem but where ?

Share this post


Link to post
Share on other sites

maybe, i have removed my battery kext, now the mac shows me that the actual power source is the AC Power but i have always a low brightness.

Share this post


Link to post
Share on other sites

did u try talking in irc channels or on tonymac . i was so happy to have qe/ci and gr8 1920 x 1080 resolution but then the backlight problem ,yuhhhhhhhhhhhhh

come on someone find a solution

 

if i remember right the backlight is alrite on boot screen so probably its with dsdt which i have patches as hp DV6T GENERIC from olarila

Share this post


Link to post
Share on other sites

i have hp pavillion dv6 quad core with i7 2670 . i can only run it with chameleon , some problem which i could never solve is to get it woking with chimera .

 

there are so many posts on hd 3000 that say to install chimera because it suppirts intel hd 3000 natively and works without any dsdt or kext edits .

 

have u tried installing chimera .

 

belive me i am 24 hours into getting our problem solved out

Share this post


Link to post
Share on other sites

ya i think confirmed the source now

without using snb framebuffer kext the backlight is 100%

 

when it loads we have the problem

 

so we require modified kext or some other solution i dont think its the dsdt

Share this post


Link to post
Share on other sites

don't worry i use the latest chimera v1.9.2, and i have a native support for my HD3000 (except the pool error in the console)

 

For the SNB frame buffer, if i delete it, i can't boot correctly, it show me just SNB Framebuffer did not show up, kext unload and the screen still here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×