Jump to content

MSI Board g41m-p34. desperate for a fix

13 posts in this topic

Recommended Posts


I did a google discussion search and only found 1 result for this mainboard.


EDIT: The ModCD is my only way into my OSX installation. The install went through but I am unable to boot into the HDD without ModCD.


One odd thing is that you cannot choose ACHI option it only has IDE under the bios.


I have been able to boot the machine using Nawcom's CD and I tried ###### as well but the latter hangs at the "Apple Power Management" kext and never goes past it.


The nawcom's CD works without any customizations but I haven't been able to get the right kexts from ######. I don't want to jump to Lion as I haven't been able to start without the nawcom CD.


I am trying to install Snow Leopard onto this computer:


Motherboard: MSI G41M-P34

Graphics: Nvidia GeForce GT430

Processor: Intel 775 (Core 2 Duo 1.86)

Networking: Atheros Fast Networking Controller

Sound: ASUS Xonar DG


The post I did find suggested I turn off Legacy USB support but my mouse and keyboard do not work if I do that. There is no information about this board in the OSX86 community so any help from you guys would be great.

How do I get this config to boot without a disk? I tried qoopz, fakesmc and mach kernel..




Link to comment
Share on other sites

Maybe I'm totally not understanding, but this is how it works.


You boot Nawcom's ModCD. Then you insert a Retail Snow Leopard DVD and boot it. The ModCD helps you do this and you then install Snow Leopard. Once you install Snow Leopard, you don't have a boot loader so you first boot the ModCD and select your fresh installation on your hard drive. Once you boot into your fresh Snow Leopard installation, you install a boot loader so you no longer need the ModCD. Then you can boot directly. After that, if certain components don't work, you add appropriate kexts to fix what doesn't work.


Which parts of this process have you completed? I gather you have booted the ModCD successfully. Have you attempted to boot the retail Snow Leopard DVD?

Link to comment
Share on other sites

Actually, after installing Snow, you do have a boot loader. That's the whole magic about the ModCD - you don't need any extra boot loader or drivers. That's probably why [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is screwing you over; there is already drivers in place.


Make sure you have the latest version of the ModCD; it is very different from the initial version.


For a more detailed guide, I have a link in my signature.

Link to comment
Share on other sites

All right I'll explain the modcd part..


I installed using ModCD and went through it succesfully. I was able to boot using ModCD even after messing up with beast.


Like I said I was able to boot into OSX post-install and even install the updates but my only path into osx has been the modcd. I tried Chameloen is there anything I am getting wrong here?


I installed


SATA kext





Is that all I need? Do Qoopz and FakeSMC conflict each other?

Link to comment
Share on other sites

Qoopz and FakeSMC are completely different items.


What exactly happens when you try to boot without ModCD?


Also, is your hard drive one of those new fangled "green" drives with reduced power?

Link to comment
Share on other sites

Yes, we need to know what happens w/out ModCD.


All kexts are installed! No extras are needed! If you can boot with the ModCD, don't install any extra drivers; only install the boot loader.


I would personally use the legacy kernel (should be already installed) rather than Qoopz. Obviously legacy kernel has been working thus far.

Link to comment
Share on other sites

I might have jumped the shark on installing the updates too early.

Now both the CD and non-CD methods freeze at "PCI configuration begin"


Prior to this everything was working fine except for the low resolution graphics.


What can I do now? Scrap the update and start over with the retail disk?

Link to comment
Share on other sites

I would do a clean install, without [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] afterwards. Rather, try this: after installing, if you really can't boot from the HDD right away (which you should be able to), install the package I linked in post #6. Once done, open Terminal and type:


sudo mv /Extra/com.apple.boot.plist /Extra/org.chameleon.boot.plist


Enter your password, reboot, and you should be good to go. :) It always worked for me in the rarity I couldn't boot right away.

Link to comment
Share on other sites

Before the PCI issues I did do a full reinstall without [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].

Is this PCI issue tied to the bootloader and not a bad installation?

Link to comment
Share on other sites

To fix [PCI Configuration Begin], type:




If that doesn't work, try:




If that doesn't work, try:


npci=0x2000 PCIRoot=1


If that doesn't' work, try:


npci=0x3000 PCIRoot=1


One of those will fix it. Whichever one works, add it under Kernel Flags in com.apple.boot.plist or org.chameleon.boot.plist

Link to comment
Share on other sites


  • Create New...