Jump to content

Hackintosh worked... but now it won't


johnnyspliff
 Share

5 posts in this topic

Recommended Posts

So, I've had my hackintosh for 2 or 3 months now, and everything was going smooth. The build, the install of Lion, DSDT and kexts, everything.

I turned it on yesterday, and it won't boot. The Chimera bootloader comes up, but when I select "hackintosh" (the name of my partition), the grey apple screen comes up for a split second, and then the computer restarts.

 

I've tried booting using ###### and rboot cds, but to no avail. It won't boot in safe mode either.

I've tried numerous boot flags, such as -f, -F, -x, -v, busratio, archtype and PCIRootUID=0 (This is the only boot flag I needed to boot successfully previous to this, although I needed it set as PCIRootUID=1).

When I try verbose mode, the writing comes up too quickly to make sense of anything. It dosn't hang... it just restarts.

 

I used the boot flag to make the system wait (I can't remember what it was, but it brought up the same text as before with a "press any key to continue" message after it.)

when I press any key, the system restarts. What follows is the entire text that verbose mode gives me:

 

Loading Darwin 10.7

Loading kernel mach_kernel

ACPI: [hd(0,2)/Extra/DSDT.aml] 17555 bytes.

Using PCI-Root-UID value: 1

Patched DMI Table

Found SMBIOS System Information Table 1

Customizing SystemID with: 00000000-0000-0000-0000-1c6f65cc3906

efi_inject_get_devprop_string NULL trying stringdata

ACPI: [hd(0,2)/Extra/DSDT.aml] 17555 bytes.

FADT: Restart Fix applied !

Patched ACPI version 1 DSDT

Starting Darwin x86_64

 

And then it restarts. I don't know what happened, although there is the possibility that a software update was performed by accident. But I'm not sure.

 

As for the build itself, I'm using hardware recommended on tonymac:

 

Intel i7-2600k Processor

GIGABYTE GA-Z68X-UD3P-B3 Motherboard

GIGABYTE GV-R687OC-1GD (powered by Radeon HD 6870) Graphics Card

OCZ Agility3 120GB SATA-600 Solid State Hard Drive

8GB Corsair Vengeance DDR3 1600MHz RAM

 

I changed my BIOS settings accordingly and installed using ###### and OSX 10.7.0

I applied a custom DSDT file which I also got off tonymac, and downloaded the 10.7.2 update from the apple website. This was two or three months ago and everything has been working fine since then.

 

Anybody have any ideas what went wrong? Or more importantly, how to fix the problem?

I'll do a reinstall if it comes to it, but if it happens again, I'll be none the wiser as to how to fix the problem.

Link to comment
Share on other sites

 Share

×
×
  • Create New...