Jump to content

Launchctl load makes me boot?


1 post in this topic

Recommended Posts

Hey guys!


I have a really bizarre situation. I installed iAtkos L2 on an MBR disk and am able to boot to it from the RBootLE boot loader.


However when I booted for the first time, my machine said that to go through with the install I would have to plug in a mouse. So I came up with a fix for myself...


I booted into SingleUser mode and copied from a usb a DSDT.aml along with com.apple.DirectoryServices.plist and com.apple.DirectoryServicesLocal.plist. Then I ran:


launchctl load /S/L/LaunchDaemons/com.apple.opendirectoryd.plist


in order to run passwd so I could change the password for the root user. I then touched /var/db/.AppleSetupDone to trick the machine into thinking the setup was done.


Finally I was able to log in. But when I rebooted, it got stuck at "Waiting for DSMOS...". Just for the heck of it I tried booting into SingleUser mode and it still froze after entering "exit". I tried a lot of different boot flags and I finally figured out a trick that worked. I did


launchctl load /S/L/LaunchDaemons/com.apple.opendirectoryd.plist


Can somebody please tell my why I can boot into my machine only when I type that into single user mode? I'm starting to think that I should have bought a cheap mouse just to get through the string... but that would be too reasonable :D.

Link to comment
Share on other sites


  • Create New...