Jump to content

[Aiuto] P5Q-E 10.8 - iCloud,AppStore,Ethernet


9 posts in this topic

Recommended Posts

Salve a tutti..

Ho un hackintos 10.7.3 perfettamente funzionante con iCloud, AppStore, Messages e piena risoluzione per la mia vga (HD4890).

Così ho deciso di installare e provare Mountain Lion..

Non ci sono voluti molti smanettamenti e ho perfettamente funzionante la risoluzione e la wifi...

Ora il problema è questo: non mi riconosce la Ethernet..

Ho copiato la cartella Extra da Lion con il kext AttansicL1Ethernet ma niente..

Ho confrontato le S/L/E e ho notato che differivano per lo stesso kext, ma ancora niente.

Ho installato Chameleon r1860 che dovrebbe contenere i fix per iCloud e AppStore ma ancora niente..

Ho confrontato l'org.Chameleon.boot.plist e reso identico.. ancora nulla..

Ho installato l'smbios.plist corrispondente al mio sistema MacPro 3,1 ma ancora nulla...

Cosa posso fare?

 

La mia scheda madre è la P5Q-E Asus.

Spero possiate aiutarmi..

Non e' che la devi solo aggiungere da preferenze sistema/network?

Se avvii con -v versi la fine del boot, la leggi la periferica?

Io con la p5q pro che ha la stessa LAN non ho problemi con 10.8

Certo, io l'ho copiato in E/E

 

Provo immediatamente..

 

Niente... riparto da capo.. devo aver creato caos di kext.. anche perché ho notato ora che mi è sparito l'audio che mi riconosceva automaticamente..

 

Edit: hai PCIRoot=1 nel boot loader o non hai specificato?

Esattamente, è proprio quella.

Non hai bisogno di alcun driver, si tratta solo di cambiare un ID dentro questo file

 

/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/Info.plist

 

Trascina IONetworkingFamily.kext sul desktop, tasto destro, mostra contenuto, apri l'info.plist in questione e fai questa modifica:

 

Da così:

 

 

Yukon-88E8053

CFBundleIdentifier

com.apple.iokit.AppleYukon2

EnableLowPwr

1

IOClass

yukon2osx

IOPCIPrimaryMatch

0x436211ab

IOProviderClass

IOPCIDevice

MACNumber

1

Model

Yukon Gigabit Adapter 88E8053 Singleport Copper SA

 

a così:

 

 

Yukon-88E8056

CFBundleIdentifier

com.apple.iokit.AppleYukon2

EnableLowPwr

1

IOClass

yukon2osx

IOPCIPrimaryMatch

0x436411ab

IOProviderClass

IOPCIDevice

MACNumber

1

Model

Yukon Gigabit Adapter 88E8056 Singleport Copper SA

 

quindi non devi fare altro che cambiare 3 numeri.

 

Salvi, installi IONetworkingFamily.kext in S/L/E e riavvii.

Grazie a tutti dells risposte.. Ho risolto installando il kext AppleYukon che fa tutto automaticamente e va alla grande.. Consigliato dal moderatore della sezione internazionale.. Risolto anche con l'audio che funziona in 5.1.. Solo un po' di noie per le cuffie dell'attacco frontale..

  • 8 years later...
×
×
  • Create New...