Jump to content
Sign in to follow this  
Followers 0
hiptomac

SATA drive not seen from Installation Menu

4 posts in this topic

Recommended Posts

Hi I hope you all can help me out. I am new to building Hackintoshes and I have a Dell Optiplex 745 (that I see other people have successfully built). I can boot from an [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd. My Snow Leopard image is loaded on an 8 GB thumb drive. I can select from 3 devices [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], Snow Leopard or a Windows formatted disk that shows up as NTFS (40 GB SATA drive). I then boot off the Snow leopard device and come to the Installer screen but there is no disk to select for the installation. When I run Disk Utility there are no drives detected (except the thumb drive). What am I missing?

 

The computer I used to create the Snow Leopard image is an iMac G5 running OS X 10.5.8. I tried copying the IOATAFamily.kext and IOAHCIBlockStorageInjector.kext to the thumb drive in the /S/L/E folder but with no success.

 

Any help will be greatly appreciated.

Share this post


Link to post
Share on other sites
Advertisement

Please I really want to get this working. I know there has to be some people out there who have some ideas as to what to try. If you need me to provide more information then please ask.

 

Thank you.

Share this post


Link to post
Share on other sites

I have resolved this issue thanks to the information posted by client00 in http://www.insanelymac.com/forum/index.php?showforum=226 which states you need to use the 2.5.1 version of the IOATAFamily.KEXT in order to get SATA support. The default version that comes on the 10.6 image is 2.5.0.

 

Thank you client00 for your posts on the Dell Optiplex 745. I will next attempt to install 10.7 on this machine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By mrziko
      hello 
       
       
      i have a virtual image for OS X Mountain Lion on vmware i download the dmg file and use myhack but i get this error 
       
       
      before this i download iAtkos ml2 and install it but no internet no sound no anything
       
      i have  external hard drive now i need to restore the OS X Mountain Lion on it any help 
    • By mrziko
      السلام عليكم ورحمة الله وبركاته 
       
      يارب الجميع بخير 
       
      انا حملت نسخه iATKOS ml2 
       
      وعندى هارد لاب توب وانا على ويندوز 7 حملت النسخه الفيرشوال وشغلتها من على VMWARE 
       
      وحرقت النسخه الايتكوس على جزء من الهارد بمساحه 20 جيجا 
      وبوت وكله تمام 
       
      وسطبت النسخه 
       
      دلوقتى عندى مشكله 
       
      لما النسخه بتعمل ريستارت بعد التسطيب بيقولى اختار اللغه واعدادات لوحة المفاتيح كده وبيقولى اختار ازاى هتوصل بالنت 
       
      كل لما اجى اختار الاعدادات بتاعت الانترنت بيرجع لاول خطول بتاعت اختيار الدوله مش عارف ليه 
       
      المهم لما بعمله this computer does not connected to internet 
       
      بيكمل وبيخش على النسخة 
       
      المشكله مافيش صوت شغال مفيش انترنت ومش عارف اعمل ايه 
       
      دى امكانيات الجهاز
       

       

       
       
      اتمنى مساعدتكم وجزاكم الله خيرا
×