Jump to content

Problem with Admin user after installation


1 post in this topic

Recommended Posts


I've installed a retail lion taken from AppStore via usb made with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Installation was fine but the first problem occurred in welcome screen were i was asked to connect keyboard (i've only a ps2 keyboard here)

so I've found a ps2 lion kext, I've boot with a Snow Leo dvd, I've add this kext to /S/L/E and i've edit /S/L/CoreServices/Setup Assistant.app/info.plist, to remove keyboard check and i was able to proceed user configuration...but after entering all the information it return back to the top of the wizard for creating the user, I tried again by creating a second user but it started again .... I tried creating a file .AppleSetupDone in / var / db and I finally got to the login screen with my 2 users


I've logged in with a username and I i found the main problem... these 2 users have limited accounts and do not have administrative privileges, so I can not get to touch any settings because when it ask for passw every passwd i try aren't correct (the passw are correct because I can login)



trying to cast any terminal command with sudo told me that the user isn't in the sudoers file, then I've rebooted with the install CD and I have added this two users to the file as ALL NOPASSWORD

now I can run sudo but I have not solved anything.


My idea was to login as root and try to change users in system preferences buth the problem is that the command

"sudo passwd root" didn't find any root user!



any ideas?

sorry for my english :D



Link to comment
Share on other sites


  • Create New...