Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Mac freezes after installing rEFIt when “executing fsck_hfs”

2 posts in this topic

Recommended Posts

I have a Macbook 5.1, with OS X Lion and Boot Camp installed.


rEFIt was installed and booted Ubuntu fine. After booting to the Mac partition, it freezes after "executing fsck_hfs" (seen in verbose mode). I need to force reboot and the Mac boots normally.


Disk Utility found somes minor errors in the disk. These errors and the freeze appear every time I reinstall rEFIt.


I'm unable to boot to the rEFIt menu again, even though I've run both /efi/refit/enable.sh and the rEFIt installer.


This issue has been verified by several others in the rEFIt bugtracker.

Share this post

Link to post
Share on other sites

Isn't it supposed to be sudo /efi/refit/enable-always.sh ? Maybe they both work, I don't know. I didn't have any freezing issues, but I know after using that command, it booted into refit immediately (meaning I didn't even have to boot 2-3 times like you normally do installing refit for the first time).

Also, if it's freezing at fsck, have you tried running fsck in single user mode?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By zafirofx
      Hi everyone. I installed MacOS High Sierra on my computer 3 months ago, in January. After a long way to get the computer fully working now I'm facing a new problem: imagine I'm working or doing something in my computer and it suddenly freezes and I have to restart it.  There's no reason why the computer restarts by itself...
      Here I also attach my Clover EFI folder in case you need it (it doesn't allow me to attach it so here i give you the link: https://mega.nz/#!92xCiLDZ!WY1F55ZvuP-9WW369EP9KY-3hNLt5sWUgJDxPrbgpPM .
      Thank you in advance.
    • By niaou73
      I've done a dual boot on my mac book pro (late 2013 I think) and to access it I need Refit. It worked well but today I tried to re-install it and it doesn't work.
      I put the the refi folder in the root level of my mac. Then I did the command 
      cd /efi/refit then the 
      ./enable.sh in the Terminal. but it responded me 
      Can't delete /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/bless.8vwY/CF413253-A4C5-3892-991E-F5E65DA3305E/System/Library/CoreServices/.disk_label: Operation not permitted Could not write scale 1 bitmap label file Couldn't write label file "/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/bless.8vwY/CF413253-A4C5-3892-991E-F5E65DA3305E/System/Library/CoreServices/.disk_label"Couldn't bless the APFS preboot volume for volume mounted at /: Operation not permitted And when I reboot the computer it restart normally.
      If someone can help me...
      Thank you !
      P.S. The english isn't my language so perhaps is there some language errors. Please don't mind them.
    • By ruki250
      Since I installed High Sierra, the system hangs for about 5 seconds. This problem drive me crazy! I can't understand how fix it. How to solve it?
      Thanks in advance.
    • By fotobear
      Hello, everyone.

      I have an older Hackintosh. Running Yosemite. It was doing very well for me for quite some time until earlier this year.

      A few minutes after startup, and it crashes.

      I have tried the following:

      I removed all software that was set to launch on startup, including ProTec6.
      I have tried launching in safe mode.
      I have tried disconnecting the cables.
      I have tried disabling Ethernet in BIOS.

      That last option worked, and I then ran EtreCheck, and only saw that Sophos components were hanging around. (I must have removed Sophos at some point in the past.)

      No other significant errors were found, but I was unable to update EtreCheck without an Internet connection. Nor can I install Sophos anew without that connection. Connecting to the Internet will freeze the whole system a few minutes after starting.

      I suspect it might have been the VPN software I installed shortly before this craziness started. It was paid software (although I can't remember which right now), but I can't find any of its components among the running processes.

      I'm at my wits end...

      Any help will be gratefully acknowledged and acted on.
      Motherboard: Z97X-UD3H-BK
      CPU: Intel Core i7-4790K

    • By randor48
      Hello there,

      I just finished my Hackintosh with a clean High Sierra install. So far everything seems to be right, got even sleep through patched dsdt working. Only big issue is that videos (HTML5 on Safari(Youtube HD), iTunes trailer) causes System freeze. So it seems to be DRM related. I inject through Clover shiki and whatevergreen with lilu but this won't help at all. My mouse keep working but nothing else only power button shutdown helps.

      I just read about this problem from Intel graphics but I'm using an AMD graphics and have iGPU deactivated in BIOS.

      Anyone else have this problem or have a solution for that? In Sierra I had not any problems like this so it seems related to that.

      Thanks in advance 
  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies