Jump to content

Athlon 64 3200+, Biostar K8NHA Grand, Rad. X800 PRO, Netgear WG311...


4 posts in this topic

Recommended Posts

Okay, I'm a total newbie to OS X and it took a bit of work, and some help from this great forum, but I have my computer running OS X 10.4.6 JaS and its doing everything I need it to.


Motherboard issues

SATA doesn't work. USB works great no patching, same with onboard sound (AC 97).

I didn't test OnBoard LAN on the K8NHA Grand, so I can't help anyone looking for that info.



Install Native Via VMWare

Anyway, I installed a native copy on a separate HDD via VMWare through this tutorial:



b0 Error - Marking my HFS partition as active

After that, I rebooted and received a "b0" error in both Native and VMWare modes and this was because I needed to mark my partition as active. To overcome this I booted to DVD (or Image of DVD via Alcohol 120% in Win XP) and typed the following commands (via osx8 wiki):


(# indicates shell prompt)


# -v -s

(wait for the shell to load)

# fdisk -e /dev/rdisk0

# print

(a list of partitions will be displayed)

# flag n

(n = the partition you want to make active, usually 1)


Then reboot


Radeon X800 PRO Installation


My original install was JaS 10.4.6. Biostar K8NHA Grand, Radeon X800 Pro AGP.


- Replaced all ATI kexts in /System/Library/Extensions/ from the ones on the 10.4.6 CD via Pacifist.

- Replaces OpenGL.framework in /System/Library/Frameworks/ from the folder on the 10.4.6 CD

- Installed Callisto b006 and updated ATIRadeon9700GA.plugin

- Installed AGPGart2.0 Universal into /System/Library/Extensions/ (found on this site in a zip).


Deleted /System/Library/Extensions.mkext and /System/Library/Extensions.kextcache.


Ran 'kextcache -k /System/Library/Kextcache/' in terminal.


That did it for me! I can't attribute all the help to any specific ppl because this was something I have been trying over a week and have by now forgotten the posts that made the biggest differences in my progress, so thanks to everyone who contributed!!!


Note: THE INSTALLATION WOULD NOT WORK IF I USED THE KOVERG PATCH! It wasn't just that I didn't need it, it simply wouldn't work. It may have had something to do with the fact that my device ID already existed in the ATIRadeon9700.kext/Info.plist


Netgear WG311 (aka WG311v1) Installation

Finally, I ran into the problem of the WG311...well, this was the biggest pain in the butt. Took me days to get it working. Here is what I did to fix that.


Download OS X Update 10.4.5

Extract /System/Library/Extensions/80211Family.kext from the download and put it into the exact came folder, from root of course.


Then, when that's done, Tools -> Utilities -> Disk Utility -> Repair Permissions


THEN (This is what I was missing)


Terminal ->


sudo -s


chmod -R 755 io80211family.kext

chown -R root:wheel io80211family.kext


Then restart and use iStumbler and voila!


edit: It appears that iStumbler is not necessary and that airport can be configured as long as WPA/WEP are not active (iStumbler doesn't allow it either). However, this involves one last step. In /Library/Preferences/SystemConfiguration/Networkinterfaces.plist if you change en0 to en1 and 0 to 1 it will enable airport to use the card.




Hope that helps someone avoid all of the hassle I went through...I've got big bags under my eyes and a huge organic chemistry test to study for that I have needlessly missed days of study for from my geeking out on my hackintosh install :)

Edited by TNCEKM
Link to comment
Share on other sites

  • 1 month later...

man, i have the WPN511 rev 02 that has the same chipset as your wifi card, but its PCMIA and i can't find anywhere that some one has gotten it working. I have tried the 10.4.5 kext like you did, but still to no avail.


do you or anyone have any other suggestions?

Link to comment
Share on other sites

  • 1 year later...

Download OS X Update 10.4.5

Extract /System/Library/Extensions/80211Family.kext from the download and put it into the exact came folder, from root of course.


cant you post it in a zipfile....do we really need to down it ourselfs...:blink:


do you know if it matters if you have te v1 or the v2 cause ive got the v2


and im going to use either 10.4.7 tiger...or leopard if this packard hell can handle it




intel pentium 4 2.8 GHz


160 GB HDD (7200 rpm)


Chipset: Intel 865

Sound: 3D Sound

ATI Radeon 9600 128MB TV Out

6x USB 2.0


Link to comment
Share on other sites

  • 3 months later...

hey guz..


i also have a wg311v1..

and tried to extract the iofamily kext from 10.4.5 but i dont find it.. i searched in all folders but omg dont see a kext file with that name

can u upload it or send it to my email?

i tried also the 10.4.8 and here i found it.. but this kext didnt worked :/


i would be very happy hearing from u



thanks man...

i need mac os for work.. because windows sucks :-))

Link to comment
Share on other sites


  • Create New...