Jump to content
Sign in to follow this  
Followers 0
Fabio1971

Informazioni Hardware (PCI e Periferiche)

1 post in this topic

Recommended Posts

Ho notato che su Lion EvOTools ( programma per Informazioni Hardware ) non funzioni sembrerebbe " classi non gestite " in Lion

 

lspci6.png

 

Così cercando ho trovato questo strumento Lspci Port by EvOSX86

Un ringraziamento al Team EvOSX86 per questa utility

 

Lspci cosa è ?

Questo strumento serve per ottenere informazioni delle PCI e di tutte le periferiche Hardware

 

Piccola Guida :

Per prima cosa Installiamo Lspci tramite .pkg :

 

lspci.png

 

Selezioniamo dove installarlo :

 

lspci1.png

 

Inserite la vostra password :

 

lspci2.png

 

Attendete che esegua l'installazione :

 

lspci3.png

 

 

Ok installazione completata :

 

lspci4.png

 

Riavviare

 

A questo punto aprite il Terminale e digitate : lspci

 

lspci5.png

 

Questo è il rapporto delle nostre Periferiche sul Computer

 

Il Programma è possibile scaricarlo :

Link ----> http://www.osx86.net...do=file&id=1643

 

 

Fabio71

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
       
       
          Populating System Information - PCI via config.plist using Hackintool
       
       
       

       
       
      CREDITS
       
      Hackintool @headkaze
      Clover Configurator Mackie100
      LSPCI
       
       
       
       
      A quick guide on how to add device information into System Information - PCI with config.plist and Hackintool using Clover Configurator.  
       
      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
       
       
       
      DOWNLOAD
       
      Hackintool PlistEdit Pro Clover Configurator  
       
       
       
      DOWNLOAD SAMPLE FILES
       
      config.plist ( includes Hackintool pcidevices.plist properties export  ) pcidevices.plist configArbitraryAndProperties.plist( previous config.plist using Arbitrary & Properties without use of Hackintool )  
       
       
       
      SYSTEM INFORMATION - PCI
       
      To my knowledge, there are a few different ways to populate the System Information PCI with device information:
       
      Those are:
       
      DSDT  SSDT Devices Arbitrary  ( config.plist ) Devices Properties ( config.plist ) Devices Arbitrary & Properties ( config.plist )  
      Initially,  my approach at populating System Information PCI was to add devices to Arbitrary & Properties. That approach required using other tools, some such as lspci or IOREgistryExplorer to obtain device addresses and paths, so involved some work. 
       
      Then 
       
      On the 23/04/2019 @headkaze released Hackintool v2.3.4 
       
      Hackintool now exports a file named pcidevices.plist, that file contains all the information needed to populate System Information PCI
       
      The easy, better method used to populate System Information PCI is by using Hackintool, see DEVICES - PROPERTIES - HACKINTOOL.
       
      I have documented inside DEVICES - ARBITRARY and DEVICES - PROPERTIES information on how to populate System Information PCI without using Hackintool for the sake of knowing other methods. 

       
       
       
       
      DEVICES - ARBITRARY
       
       
       
      DEVICES - PROPERTIES
       
       
       
       
       
      DEVICES - PROPERTIES - HACKINTOOL
       
       
      Run Hackintool, PCI tab and Update PCIIDs  

       
       
      Export PCI info  

       
       
       
      HOW TO SAVE pcidevices.plist Properties TO CONFIG.PLIST
       
       
      Download and install
       
      PlistEditPro  
      Right click and open pcidevices.plist with PlistEdit Pro  

       
       
      Mount EFI partition and drag and drop config.plist onto desktop. Right click, open with PlistEdit Pro  

       
       
      Place both PlistEdit Pro windows side by side:  

       
       
      Next, click Properties, copy. (pcidevices.plist)  

       
       
      Then, click on Devices (config.plist) so that it is highlighted and Paste As Child and Save.  
       
       
       
      Verify Properties has been added correctly to Devices inside config.plist using Clover Configurator or PlistEdit Pro  

       

       
       
      Place config.plist back inside EFI/Clover  

       
       
      Done!  
       
       
       
       
      Optionally you can make edits to Devices model string information, so "Cannon Lake PCH cVAs" in my config.plist has been renamed to " Realtek ALC1120-VB " 
       
       
      Open pcidevices.plist with Clover Configurator.
       

       
       


       
       
       
      Example of optional renames done with config.plist for Aorus Z390 Pro
       
      Before:
       

       
       
      After:
       
       

       
       
      Save renames and then add Devices / Properties to your config.plist.
       
       
      No need to rename device_type Bridge model name. 
       


       
       
       
      THANKS TO @headkaze  & @Hervé
       
      AND ALSO @steve3d for his post!
       
      config.plist
    • By valueimagery
      Okay So I have two PCIe controller cards, both 3rd party, unbranded from eBay.
       
      1st runs off the Marvell 88SE92xx chipset.  4 Internal Ports.
      https://www.ebay.com.au/itm/PCI-E-PCI-Express-to-SATA3-0-4Port-SATA-III-6G-Expansion-Controller-Card-Adapter/264029216955?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649
       
      2nd runs off the ASMedia ASM1061 chipset. 2 Internal/ 2 External Ports (selectable by jumpers)
      https://www.ebay.com.au/itm/PCI-E-To-SATA3-PCI-E-SATA3-0-6Gb-s-the-SSD-Asmedia-Chip-Expansion-Card-ASM1061/191572577652?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649
       
      The hack is running stable no issues on 10.4.2 with an i7 8700k ASUS Maximus X Code as iMac 18,3
       
      However, I wanted to add eSATA ports for some older drive enclosures I own, and some extra internal SATA ports as I've used all the SATA ports on the Motherboard.
      The 1st Marvell actually works OOB in Mac OSX.  No kexts needed.  Speeds seem good (350R/400W on an SSD 80R/W on a 5400 HDD)
       
      However, a few things don't seem perfect.
      1) the AHCI version is 1.0.  I imagine this could and should be a newer version? 1.2 or 1.31? If it should be updated, is this something only able to be flashed from a Windows OS?
      2) It can't be used as a boot option.  the Maximus doesn't recognise it as a startup option.  Is this a possible AHCI version firmware issue?  Is booting ever possible from these controllers? 
      3) TRIM was disabled in system profile. I know it automatically worked OOB for my NVME2 drives connected to the motherboard,  But to enable Trim on an SSD 860 EVO I needed to submit the terminal command:
      sudo trimforce enable
       
      Now the second ASMedia controller I haven't been able to get to work.  I've switched the jumpers (not sure which position is the 1,2,3) so I've made it so that one internal and one external will operate to test the card.
       
      System profiler sees the card like all the others as a "Generic AHCI Controller" with AHCI version 1.20 supported.
      However, I cannot get any drive to be recognised in the eSATA ports.  I haven't tested the internal ports as I don't need these.
       
      I've attempted using two kexts (attached) AHCI_3rdParty_eSATA.kext and AHCIPortInjector.kext
      When I use AHCIPortInjector.kext the SATA device is recognised in system profiler as an ASM1062.  However no drive works with this kext.  And reading the chip itself on the card it says ASM1061.  So not sure why it's preferring the 1062 entry over the 1061 since both are present in the kext.
       
      When I use AHCI_3rdParty_eSATA.kext that SATA device is not recognised at all in the system profiler.  It disappears.
       
      I'm not using a custom DSDT for this motherboard and I've attached my config.plist if anyone has some insight on either cards.
       
      Cheers,
      Shark
       
       
       
       
      config-NOSN.plist
      AHCI_3rdParty_eSATA.kext.zip
      AHCIPortInjector.kext.zip
    • By Lilith
      Hi,
      i have a little old mobo with socket 1156 no Sata 3 - biostar tpower i55 and i Was wondering if i had some chance to install a new nvme memory like Intel 760p.
      Due lack of support by my mobo i found a Pci Express card lycom dt-120 to expand my connectivity.
      After some researches i understood that i need a ‘bios support for the boot from nvme disk’. I want some of these nvme memory to install high Sierra and get a killer desktop.
      I think that i haven’t obviously a native bios support cause my mobo is pretty old, so i can’t get an nvme disk and install properly high Sierra hoping that boot?
      Or should i catch anyway? I Guess that same problem is for w10? 
      Thanks, Gabriele.
    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
      AppleIntel8255x.kext.zip
    • By ITzTravelInTime
      I have started this thread to discuss about old and very cheap ethernet cards working in the latest macOS releases, cards who just uses old ethernet controllers or are new and cheap cards with old ethernet controllers, this thread is just to discuss about such cards and also to have a list in the first post with reported working cards with drivers linked.
      To contribute you have to report which card of this kind is working for you and which driver or method you followed to get it wo work and also which issues you have, and then it will be added in the list.
      I start reporting cards which worked for me, yours will be added in the future:
      intel 8255X based cards:
                just works using the AppleIntel8255X kext (look in the attachments) and seems to be stable with no issues
       
      And also there are some cards i am curious to see if can work with mac, so i leave this part at the end of the post, do you know if it's possible to get realtek pci (not pci express) ethernet cards working in the latest mac os? i have a few of them and i have difficulties fining drivers for mac, having a driver for the latest mac wil help me in creating also a youtube video with the cheapest hackintosh compatible ethernet cards
       
      AppleIntel8255x.kext.zip
×