Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

[RISOLTO] EDID scheda grafica!

5 posts in this topic

Recommended Posts

Ciao a tutti,


stavo seguendo questa guida per far funzionare la mia scheda grafica (ati mobility radeon HD 5470). Sono sicuro che funzioni in quanto ho trovato

video su youtube di un tizio che è riuscito a farla funzionare tramite quella guida (soluzione C). Tra l'altro quest'ultimo ha il mio stesso notebook e stesso hardware :)


Sul mio notebook è installato iAtkos l2 (lion 10.7.2).


Vorrei sapere se qualcuno mi può spiegare la guida passo per passo (in particolare mi servirebbe capire i punti 4-5-6 della soluzione A)


Ringrazio anticipatamente tutti quelli che mi potranno dare una mano :)


Dopo un po' sono riuscito a capire la guida e far funzionare la scheda:


Andare in /System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/ e sostituire il file DisplayProductID-717 con questo modificato


Aggiungere questo a org.chameleon.Boot.plist situato in /Extra (in alternativa si può utilizzare Chameleon Wizard):




<key>Graphics Mode</key>





Riavviare e se tutto è andato bene la scheda funzionerà!!!

Share this post

Link to post
Share on other sites

guarda dentro la cartella extra di lion in chamelon.boot.plist.

sicuramente ci sono delle stringhe da eliminare per quanto riguarda la scheda grafica!lascia solo graphichs enabler yes!

Share this post

Link to post
Share on other sites

Ciao, grazie per aver risposto comunque questo è quello che ho dentro chamelon.boot.plist.


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">


<key>Boot Graphics</key>




<key>Kernel Flags</key>

<string>busratio=16 PCIRootUID=1</string>



<key>Quiet Boot</key>











Cosa devo togliere?


Share this post

Link to post
Share on other sites

Innanzi tutto ti ringrazio per avermi risposto però seguendo ciò che hai detto non cambia nulla :( ...cmq avrei delle domande da porti:

1) Seguendo un tuo guida ho visto che accenni a dei kext per la batteria...me li potresti mandare (claudioverardo@gmail.com). Risolto

2) Sempre nella tua guida...sei riuscito a far funzionare la scheda di rete lan (broadcom 57780) Risolto

2) Sempre nella tua guida...sei riuscito a far funzionare la scheda di rete lan (broadcom 57780) Risolto

3) Ritornando alla scheda grafica, non essendo un campione in inglese, potresti spiegarmi questa guida (a parole tue)...te ne sarei molto grato :) :) :)


Per vedere come ho risolto andare qui


4) Mi sono accorto che il lettore dvd quando avvio il computer funziona poi dopo un po' che lo uso non funziona più. Sapresti dirmi il perke? Il modello del lettore è: Slimtype DVD A DS8A4SH.


Ti ringrazio anticipatamente

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By maleorderbride
      Happy New Year all!
      I am attempting to install Sierra 10.12.6 on a rather odd computer, a Microsoft Surface Studio. It is essentially a laptop with a 4.5K screen strapped on. I have the install done, but the internal (or external? I don't know how it is connected) display and the video card are not matching up once I enable the Web drivers.
      I've attached two sets of files: one without Web drivers being enabled, and a second with Web drivers. Also attached are the dumped ACPI files in origin, as well as the EDID information from Windows with and without the monitor driver being installed, IOregs, complete Clover folders, and various other items. Let me know if you need something else.
      Without web drivers enabled the built-in display works, but of course has no acceleration. It allows me to select between two valid resolutions (full 4.5K and 2.25K).
      With web drivers enabled, I get a black screen (NvidiaFixup, plus manual editing of AGDP already done). I can remote in and I see the card as not recognized, and no valid display.
      I've flailed about a bit and manually added some device properties, EDID, as well as NVCAP, loaded a different ROM, but all have met with no success. 
      Anyone have any ideas on what to try? 
    • By hornpipe2
      I have a Mac Mini 2006 (upgraded) with Intel GMA950 graphics, running MLPostFactor 10.8.5.  It is connected to an ASUS VS197 LCD panel using DVI-D.  This is natively a 1366x768 panel that is recognized and works fine.
      However, the other choices for resolution are 4:3 800x600 and 1024x768, and then the oddballs 832x624 and 1360x768.  None of these are useful as a low-resolution widescreen for gaming or watching DVD content.  Specifically I want to get access to 848x480 or 854x480, and also 1024x576.  SwitchResX makes these choices available, but it doesn't work with a "full screen" game, presumably because the game directly queries OSX Display to get a list of valid resolutions and SwitchResX is bypassing that system instead.
      So the solution is obvious: buy a new computer pull the monitor's EDID data, hack it to enable new resolutions, and then tell OSX to use this custom EDID instead of the one retrieved from the monitor.
      Following the steps of the EDID injection guide, here is where I am:
      * Retrieve EDID, DisplayVendorID etc from ioreg.
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 F1 * Use an EDID editor to enable new 848x477 and 1024x576 resolutions.  (Verify with an online EDID tool, and compare to the previous version)
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 4B C0 4B CA 4B CF 61 C0 61 CA 61 CF 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 47 * Create a new subfolder and plist within /System/Library/Overrides/Display/ containing the new EDID string and monitor name.
      * Reboot.
      Now the problems begin.  Even though the plist file is being read (which I know because the Monitor Name has changed in Displays), the custom EDID is not being used.  When I dig into IORegExplorer I am able to come up with AAPL00,EDID string and it is the unmodified one read from the monitor.  I even tried a plug-and-unplug while OSX is running, and also tried to reset the SMC and NVRAM, but no dice.
      Do I need to start digging into DSDT hacking?  Is the Intel driver pulling down EDID during boot and I need to override it somewhere else?  What am I missing here?
    • By Aurelius Vito
      Hey there, I want to ask about a problem in my hackintosh. The screen of my hackintosh is weird. The color of the screen is very weird as you can see in the picture. In the picture is my laptop.
      But it's very weird, because the problem is only in my laptop. In my second monitor, which is connected to my laptop with HDMI cable, the colors are normal. The second picture is for comparison

      Please give me some advice. Thanks for your help
    • By maccerj
      Good day, after searching endlessly through forums and trying various ways I now need your help.
      My issue is that I need to output sound over my macbook airs mini displayport, the setup looks like this:
      Macbook -> mini DP -> mini DP / hdmi adapter -> hdmi switch (with toslink extractor) -> Optoma hd 20
      The toslink is connected to a separate DAC.
      Since the edid from the Optoma is telling the macbbook that sound is not supported I want to override this.
      So far I have dumped the projectors EDID with Darwin Dumper, then modified the dump with AWEDIDEditor, the modified output file is a bin-file.
      How do I use this file to override the old EDID? 
      Looking forward hearing from you.
    • By cvsg
      Hello folks!
      I've been working on this issue for a few weeks so I guess it's time to ask for your help...    
      My Context
      I've got an very strange glitch on my laptop built-in display.
      GLITCH VIDEO: https://docs.google.com/file/d/0B9u_U2zduVk1MzhXVWh6TkdBWm8/view
      I believe it's not an issue on my graphic card settings since I've got full graphics in a external monitor plugged in my HDMI port. 
      So I guessed that the EDID of built-in monitor is not being grabbed correctly. Even with EDID issues having a different behaviour, I tried overriding the display EDID with EDID grabbed from windows. Also tried FixEDID with no luck.
      One thing to note is that DarwinDumper output some warnings that may help:
      EDID block does NOT conform to EDID 1.3! Missing name descriptor Missing monitor ranges Detailed block string not properly terminated  
      My Questions
      For those with more experience, this really looks like an EDID issue? If not, what else can fix this? An IMEI DSDT Patch?! My Specs
      Lenovo B490 - i5-3320m - H77M - HD 4000 OS X 10.10.1 Video Ports: Real Ports: 1 LVDS, 1 HDMI, 1 VGA(still disabled) and this model has no MiniDP port Using 0x01660003 1 LVDS, 1 HDMI, 2 DP My config.plist is attached EDID grabbed with DarwinDumper is attached IOReg is attached Specification of the built-in LCD: N140BGE-L22  
      Update #1
      My conclusion so far is that this monitor has a broken EDID EEPROM. I just need to know how can I build my own EDID based on the monitor specifications...
      Update #2
      I've also tried to create a EDID from scratch with this very nice tool:
      The attached override was under path `/S/L/Displays/Overrides/DisplayVendorID-dae/DisplayProductID-1470`. However it was not loaded (the display name doesn't changed) and I don't know why. I've checked the file permissions and it was identical to the others overrides.
      Update #3
      So, it's probably not an EDID issue, since the built-in display works properly when QE/CI isn't enabled.
      Please help...
      DarwinDumper EDID.txt