Jump to content

Problems with GA-X58A-UD5 and two HD-Drives


2 posts in this topic

Recommended Posts

Hallo guys!

I have following problem.


My Config is:

i7 960

GA-X58A-UD5 Rev.2.0 FD

4GB Ram

Gainward GTX 480

2 Harddrives WD


I installed Mac OS X Snow Leopard Retail via [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Legacy on first hard drive. All worked until I installed Windows 7 on the second HDD.

Now I get always after boot "Please hold down the Power button.." and so on. The OS Crashes, but no grey or blue screen.

After I connect the SATA Cable from Windows HDD to the Mac OS X HDD and reboot all works! After next boot I get again the same error. Then I have to reconnect sata cables again to get this work. Oh and if I let both sata cables in then Mac OS got each boot the error. Only if I disconnect the Windows SATA Cable I can boot Mac OS.


Can someone help?


Thank you!

Link to comment
Share on other sites

  • 4 weeks later...

install stata port 1 osx .. sata port 0 windows.. whenever u working with bootsector or installing .. unplug windows sata.


i boot from 2 hard disks with Windows first in port 0 then osx in port 1 .. i use easybcd 2 in windows to add a linux entry grub2

then i install linux in windows drive partitioned (max 4 primary) 2 for windows 2 for linux.. ext4 and swap . swap can be about 8gb

then i boot windows(shows linux boot menu, choose windows7) and write mbr of windows7 (in easybcd..in Deployment ) and boots with 7 menu and linux in list.

the linux lets me pick osx i added custom to grub2

with a special entry for osx with these included (not exactly as shown)


set root hd1

insmod hfsplus



what this is doing is

boots from port0 windows bootmenu. and it has linux in menu.. i choose that and in linux menu it shows osx i added custom.. done


by the way i built a friend his x58a-ud3r and we disabled usb3 in bios

Link to comment
Share on other sites


  • Create New...