Jump to content

Asus X52jc laptop install issues


strutzz
 Share

2 posts in this topic

Recommended Posts

I have a Asus x52jc laptop with the following config:

 

CPU: DualCore Intel Core i3 370M

Motherboard Chipset: South Bridge: Intel Ibex Peak-M HM5; North Bridge: Intel Ironlake-M IMC

System Memory: 4GB (DDR3 SDRAM) 1066

BIOS Type: AMI (10/30/09) ( ver. 206)

 

 

Display: Intel® HD Graphics and

nVIDIA GeForce 310M ( dual video)

 

Audio Adapter: Conexant Cx20585 @ Intel Ibex Peak PCH

IDE Controller: Intel® 5 Series/3400 Series Chipset Family 2 port Serial ATA Storage Controller - 3B2D

Disk Drive: WDC WD3200BEVT-80A0RT0 ATA Device (298 GB, IDE)

 

Network Adapter: Atheros AR9285 Wireless Network Adapter

JMicron JMC250 PCI Express Gigabit Ethernet Adapter

 

HID: ELAN PS/2 Port Smart-Pad

ASUS US keyboard

 

 

 

Install attempts for OSX in historical order :

 

10.6 retail cd directly ( failed)

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] + 10.6 retail cd ( failed , tried -x -v , installer works, kernel panic on first start)

iATKOS L2 installer works, tried a combinations of kexts with various results but no functional system ( not even a desktop screen)

 

procedure :

In bios : sata mode: ahci, video adapter : compatible ( only intel HD graphics ) and WIN7/VISTA ( both adapters active, controlled by OS)

all peripherals disabled ( except an usb mouse and the keyboard)

 

The BIOS is a bit tricky . In versions above 206 there are fewer options and the option that allows you to select the if only the intel or both VGA's are available is missing . I had to do a downgrade of the bios back to 206 using Aflash utility in the bios.

 

 

Still no working system, EDIT:(fixed)

EDIT:

Installed 10.6.3 using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to start iAtkos_S3_v2.

If you leave the configs as they are it will install and work BUT:

-if you want to boot it dose not even get to loading screen, it just restarts after loading a few files

-you need to constantly boot using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

-do NOT install SleepEnabler ! Kernel Panic, (tried to remove it using a live ubuntu distro but the mac file system is read only so I reinstalled)

-with atheros kext it sees the wireless adapter bun cannot see or connect to any networks.

-no LAN whatsoever

-display adapter is seen as generic Intel , only 1024x768x32 available

-the trackpad does not work even with voodoo ps2 .

-sound is functional but the default device are headphones.

 

I'm planing to do an update, probably to 10.6.5 or maybe to 10.7.

 

The most important thing right now is to get an Internet connection going so I don't have to switch to ubuntu live cd every time

 

Has anyone had success and how did you succeed?

Do you have any advice ?

 

 

 

 

Thank you !

Edited by strutzz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...