Jump to content

RTL8139D Only loads when it wants?


4 posts in this topic

Recommended Posts

I look around and see some guys running realtek cards just fine. For the life of me, i cannot. I'm runnin an IBM ThinkCentre A5, C2D, 2.8Ghz, 4GB ram, Nvidia 210 and Iatkos L2.


I will say, paiinless install. Everything working (Except the useless Marvell 88e8057)


I threw a RealTek RTL8139D..seemed a worthy candidate, ive seen some success and plenty of kexts listed for it. I tried several, including lnx2macs (even though its not officially supported) Most kexts would recognize the card, but always said no matter what, cable unplugged.


So i tried this little guy




Restart, Bam WORKS! Awesome!


Restart again. Cable unplugged. Ok Restart. Oh Hai. It works. hmm..


Ok Shut down. Reboot, KERNEL PANIC. Restart. Cable unplugged. restart..Kernel panic.


So sometimes ill get it to where it WILL work, only 50% of the time. Otherwise, its kernel panic 50% of time. How is this possible? I'll literally check system prefs/safari, and reboot. I'm changing NOTHING!


The only other cards laying around i have are a LinkSYS LNE100TX, which yielded the same thing, card detected but no cable connected. Some acnient Kingston KNE something or other..never really worked in OSX. and lastly a 3Com9xxx, which worked fantastic in my dual g5 when i broke a pin on the built in ethernet, but i havent tried in lion yet. I recall trying it on SL before and getting the same shotty - whenever it wants - routine.


I've done repair permissions countless times.


Thanks in advance guys. Im really stumped!

Link to comment
Share on other sites

Alright, maybe this will help,


I found an Intel Pro VE laying around, threw it in...and same thing. Cable unplugged...reboot..kernel panic.


The kernel panic is the same as the Realtek, and it says "Kernel Extension to Backtrace" lists com.apple.driver.AppleACPIPLatform(1.4)

dependency: com.apple.iokit.IOACPIFamily, com.apple.iokit.IOPCIFamily(9.9.9, com.apple.iokit.IOAudioFamily(1.8), com.apple.kext.OSvKernDSPLib(1.3)


So im guess what, a PCI error here? Upon next boot, it boots up fine, just can't detect a cable plugged into the network card. Grrr!


Thanks guys.

Link to comment
Share on other sites

Well i see people are reading it, so I'll provide a POSITIVE update. I don't want to jump the gun but i think i've figured it out.


I tried the intel Pro VE as mentioned, more kernel panics. Got fed up. Reinstalled. Immediate KP with the Intel. It was blaming the video driver, which last time i checked was natively supported. Whatever.


Threw the realtek back in. Installed the kexts. Same song and dance. So this time, on a working boot (But without internet) i deleted the realtek from Networking Preferences as an interface. For whatever reason, OSX isn't updating it. At all.


Reboot with a -f, bam its back working!


So i FIGURED maybe its a -f at every boot (can't be right?) so i let the next 2 boots slide with no options other than verbose so i could see if its atleast finding the card. So far so good! I'm downloading updates as we speak. Hopefully that does it. I'd like to retire my ailing PowerMacG5 Dual 1.8Ghz. Man we had some good times lol. But, i got in 2005, everything has been replaced atleast twice lol. Hey, MATLAB/Maple, 3D net renders, and 32 tracks in logic will abuse any system.


EDIT: KP'd after update of iTunes and Safari. Another -f, all is well....-f huh..How many Engineers does it take to load a kext? One, just takes 3 pulling out hair!


Why so many -f's???

Link to comment
Share on other sites


  • Create New...