Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
cncjerry

Sony Laptop - almost there - still need DVD

Recommended Posts

So I installed leo 10.5.6 and it won't boot from the hard drive. I get the still waiting for root... error. If I boot from the DVD with rd=disk0s1 it will all come up but no audio, wireless, etc. I don't know much about drivers on OSX but I get the impression this has something to do with kernel extensions. I moved the install disk image over to a partition and can boot from there having also changed the boot file to automatically use the rd=disk0s1 so my machine no longer needs the DVD. Again, no extensions so no Audio, USB audio, wireless, etc. So I assume (tell me I'm wrong) that the problem is something in the extensions directory that was installed on the boot disk. I moved the extensions directory over to the install image partition and I get the same error. So I assume there is something in the kernel extensions on the boot drive that is overriding the hard disk driver??? The bios on the laptop does't have an option for SATA AHCI, etc and I've seen all those posts. I tried installing USB audio interfaces over on the install image partition (that boots) and it fails looking for other drivers.

 

So is there a way to figure this out by maybe trimming the extensions on the boot drive or by adding some to the install image? All I want is 10.5.6 or something compatible with iWork so the kids can use pages, numbers, etc without hogging my iMac. This works but now I am greedy and I would also like USB audio for recording so I don't have to lug the iMac around.

 

This is installed on a Sony van-fs660 laptop.

 

Thanks.

 

jerry

Share this post


Link to post
Share on other sites
Advertisement

SO I take back some of the above. It looks like it loads the extensions from the drive I installed on when using the rd=disk0s1 at boot. So is the install disk kernel (the one that runs during install) different from the kernel that it puts down on the boot disk? Something is different because it runs and says it is 10.5.6 when I boot from either the install DVD or my image of the DVD but gives me the still waiting for root... when booting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×