Jump to content

Overclocked CPU. Now can't boot from hard disk, only CD.

2 posts in this topic

Recommended Posts

So my Fermi upgrade has taken on a hell of it's own with my Hackintosh install. I was already having trouble with the 460GTX in 10.6 but when I overclocked the CPU (as it was bottlenecking the card) 10.6 will no longer boot. It will usually fail early in or towards the end of the boot (DSMOS has arrived). No KP, just a reboot.


If I boot from the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD I can get to the desktop just fine. But I want to be able to boot from the hard disk. I'm wondering if it might be some DSDT voodoo as the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disc doesn't use one, while the hard disk installation does. I didn't update the DSDT after the overclock.


I tried to do a Lion install (as it might be a better move with Fermi) and while it installed fine (using this method, with my old DSDT) it again won't boot from the hard disk. In that case it fails right at the start (mig_table_max_disp 73, the next line if booting from the install media is for NullCPUPowerManagement).


So I'm at a bit of a loss now. Why can I boot fine from the install/bootdisk media but not from the hard disk? And how can I fix this? I'm not going to undo the overclock. OS X has to work with it or go bye bye.






Adding NullCPUPowerManagement.kext fixed the booting issue. But after a while I got a KP from GF100HAL. I had a modified AGPM kext handling the state switching but I guess that's not enough. Gonna try a Lion install tomorrow.

Link to comment
Share on other sites

The Lion upgrade went well (would have preferred an "archive and install" option but I'm not seeing any nasty side-effects from installing over SL). No KP's and the 460 is state switching fine.


The only remaining issue is restarting. I had this with SL too and again it started happening after the overclock. Maybe every second or third time it will hang at the end of a restart (when it should power back up). Again, this doesn't happen when using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or my Lion install stick. I've tried EvoReboot but it didn't make any difference. OSXRestart stopped Lion from booting. And OpenHaltRestart is pretty old now so I didnt even try that. The chameleon fix always worked until now.


Update: Seems it's my phone. When it's connected via USB it interferes with the restart. Didn't do this before. Must be some USB voodoo.

Link to comment
Share on other sites


  • Create New...