Jump to content

[GUIDE] 10.6.8 AMD with some tweaks for possible problems [Like freezing]


1 post in this topic

Recommended Posts



First of all, sorry for possible mistakes with my english =/ I'm from Brazil.


--- Some introduction


I just had a one week quest in making OSX work on my AMD build:


AMD Phenom II X4 970

Asus m4a87td-usb3

HD 6950 2GB (no QE/CI, so I bough a Zotac Geforce 210 1GB DDR3)

2x 4GB Corsair 1333mhz


When I first tried 10.6.3 -> 10.6.8 with my ATI card, I was able to dual monitor and 1080p resolution using instructions from http://www.tonymacx86.com/viewtopic.php?t=34929&p=255919


But without video acceleration I wasn't able to watch youtube videos, quicktime videos... And the system become really slow (because of the 1080p resolution forcing the graphics)


Then I bought the Zotac video card... When I swap the cards, wow, still dual monitors and now QE/CI, OOB (out of box).. Later I discovered that the ATY_INIT (Native packages for 6970 from netkas) was doing this magic for my nvidia card.


I was really happy, but minutes later... Graphics Glitches, freezes and hell. I spent 4 days trying to solve that.. AGPM editing, some other kexts editing, switching kexts versions, reading a lot of forums posts... and nothing.


Then I gave up and tried to make my 8GBs work with legacy kernel from nawcom... Cause if I didn't use maxmem=4096 as boot flag, all my programs crashed.


That's when my graphics started working perfectly.. The problem was, somehow, with nawcom's kernel. I simply downloaded Andy's kernel (AnV) for 10.6.8, the R8_V2, and for the first boot all my problems have gone.


8GB working without maxmem flag, since then no graphics problem.


With my quest I learned some things and I'll try to help you with my experience.


--- Let's do the job


1) Install your retail 10.6.3 using the nawcom's boot modcd.

My flags for the install: arch=i386 -force64 busratio=20 -v

Busratio depends on your cpu

After selecting in which disk to install, click customize and select the kexts for your configuration..

For me:

Unchecked: Print support, additional languages, GraphicsEnabler.

Checked: kext for JMicron.

Some defaults I don't remember now, but other things were checked and unchecked, if someone take a print of the screen here I'll help more.


2) Boot with the nawcom's modcd with the same flags from install


3) Install 10.6.8 update, do not reboot, click in the apple from top bar, "force quit" -> installer


4) Download Andy's kernel for 10.6.8 R8_V2 and place in your root folder.


5) Install the latest chameleon 2.1 build (1730 for me), edit your extra/com.boot.Apple.plist

Edit the Kernel part with Andy's kernel name, probably you should rename it before move to root folder in the previous step.


6) Use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] from tony's and install some kexts, change your system definitions (MacPro5,1 for me cause others tested doesn't allow AGPM for load)

I remember marking a lot of kexts in there.. VoodooHDA for audio, FakeSMC, EvOreboot, NullCPU... etc..

Remember of updating your system cache and permissions with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] too.


7) Probably you will have your system working after reboot now, if not, you might need to install or uninstall some kexts.

I would suggest to boot with the flags I've mentioned plus -f one if the first boot go wrong.


8) Now, depending on which graphics card you use, the procedures can be very different...


*) You may try simply add GraphicsEnabler=Yes to your flags.. I don't know if it will work for dual monitor support.


For me... I downloaded the Native 6970 package from netkas, extracted (not installed), searched for ATY_init.kext and installed with Kext Wizard.

Then, I removed the GraphicsEnabler=Yes from my kexts and I have now fully working acceleration with dual monitor support.


You can improve your experience by editing AppleGraphicsPowerManagement.kext and IOPlatformPluginFamily.kext, thats what I did before in my quest, it made the glitches to happen less often, but only Andy's kernel made it go away for more than a day now and going (I think it solved my problem for complete, but with only a day I cant put my hands in the fire for it)


Always be aware that the sections to edit must match with the system definition you choose in the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]'s step.


I will refer the posts when I learned how to do the AGPM part, for the IOPl... I really don't remember where I got, but I have the file to MacPro5,1




Link to comment
Share on other sites


  • Create New...