Jump to content

32 Bit Apps on 10.6.8 Legacy Kernel (AMD)


1 post in this topic

Recommended Posts

All the information I can find on this seems to tell me I'm onto a lost cause, but thought I'd check here to see if there's anything I've missed. Using Nawcom's boot cd I've installed OS X 10.6 from a retail disk onto my AMD system, and have updated to 10.6.8 using, again, Nawcom's 10.6.8 legacy kernel and all my hardware, including wireless is working perfectly. However I've run into the problem that when trying to run any natively 32 bit app it will crash on start up (things like Angry Birds from the app store, Minecraft, OSX86 tools) However, I did notice OSX86 tools worked under 10.6.(0?) originally. I've tried removing the -force64 command from the boot.plist and running with the options arch=i386 and limiting the ram to 4GB but nothing seems to prevent these apps from crashing on start up. So my question is, is there any way to get these applications to run on my computer under OS X? Or should I have built an Intel based machine if I really wanted to run OS X well?



AMD Phenom II X4 810 (2.61Ghz)

8GB 1333Mhz DDR3 RAM

Saphire 512MB ATI Radeon HD 4850

Gigabyte M68MT-S2P Rev 3 Motherboard

Atheros AR9285 Wireless PCI Card

  • Like 1
Link to comment
Share on other sites


  • Create New...