Jump to content
InsanelyMac Forum
Sign in to follow this  
ftjarah

Palit GTS 450 1gb

Recommended Posts

Using PCI-Root-UID value: 0

nVidia GeForce GTS 450 1024MB NVc3 [10de:0dc4] :: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)

ERROR: dcbtable_version is 0x5

ERROR: nVidia ROM Patching Failed!

 

Happy New Year everyone!!!!

Help anyone pls....

got this message every time i boot Im new here i don't know what seems to be the problem.If I use dvi port I get a Black Screen after the Apple logo.Im using vga now

Lion 10.7.2

Many Thanks in Advance!!!!!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By beta992
      This is my installation guide for OS X 10.8 Mountain Lion.
      I will try to improve my guide all the time. If anyone has a suggestion, I will add it.

      Warning: I'm not responsible for any damage or problems to your system, lost of data and any other issues.
      Be sure to have a backup of important parts of your system! (BIOS-rom(s), drivers, files, etc.)
      I have tested most HW-parts on temperatures, (fault/warning) messages, etc. and believed this setup is safe to use. However their could be parts on your setup that don't work (properly) for you.

      Last Updated: 20/06/2013

      My system specs:
      ASUS P8H67-M Pro (Rev 3.0/B3) motherboard (BIOS 3806)
      Intel i5-2400 @ 2.4Ghz (stock)
      Kingston DDR3-1333 RAM 8GB
      Samsung 830 SSD
      EVGA GeForce 450 GTS (1GB)
      1TB HDD Samsung HD103SJ
       
      Working Status:
      OS X ML 10.8.4 UEFI-mode
      Audio: Working (AppleHDA)
      Ethernet: Working
      Speedstep: Working
      USB (2.0): Working
      EVGA GeForce 450 GTS: Working, using latest NV Drivers
      USB 3.0: Not working - There are solutions (see post below) available but yet tested myself.
      Sleep: Not working properly, Clover-bug(?)
      (P)ATA: Not used

      OS X Installation Steps

      Requirements
      - A running Macintosh/Hackintosh 10.6, 10.7 or 10.8 (VMware) Machine.
      - An OS X ML 10.8 Installation (App) from the Apple Store
      - An empty hard drive
      - An empty 7.5GB> USB-stick/drive (Installation Media)
      - An empty 256MB> USB-stick/drive (Clover)
      - A lot of patience
      - The following needed packages:
      Kernel & System Caches updater
      Realtek Driver
      HWSensors
      DSDT Editor

      Creating a bootable OS X Install Media
      First follow the steps in this (great) guide.
      Remember you will need to use the latest available OS X ML install media, otherwise you will not able to boot without using the safe mode (-x).
       
      Creating a bootable Clover (UEFI) USB-stick
      1. Download the latest Clover zip
      2. Open Disk Utility and plugin the USB-sick that you want to use for Clover.
      3. Format the USB-stick as follow:

      4. Exit Disk Utility
      5. Unzip Clover_v*.zip and run the Clover_v*.pkg file
      6. Choose Clover USB-stick as Installation Target and select the following Installation options:

      7. Open the created Clover USB-stick
      8. Delete the files BOOTIA32.efi & CLOVERIA32.efi inside the BOOT and CLOVER directories.
      9. Replace config.plist with the following content (it will enable TRIM-support):
      <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>SystemParameters</key> <dict> <key>prev-lang:kbd</key> <string>en:0</string> <key>LegacyBoot</key> <string>PBR</string> <key>boot-args</key> <string>-v -x npci=0x2000 slide=0 darkwake=0 WithKexts</string> <key>InjectSystemID</key> <true/> </dict> <key>SMBIOS</key> <dict> <key>ProductName</key> <string>MacPro3,1</string> </dict> <key>KernelAndKextPatches</key> <array> <string>AsusAICPUPM</string> <true/> <string>AppleRTC</string> <true/> <string>KextsToPatch</string> <dict> <key>0</key> <dict> <key>Find</key> <data>QVBQTEUgU1NE</data> <key>Name</key> <string>IOAHCIBlockStorage</string> <key>Replace</key> <data>AAAAAAAAAAAA</data> </dict> </dict> </array> <key>GUI</key> <dict> <key>Theme</key> <string>metal</string> <key>Mouse</key> <dict> <key>Enabled</key> <false/> </dict> </dict> <key>RtVariables</key> <dict> <key>LogEveryBoot</key> <false/> </dict> <key>Graphics</key> <dict> <key>PatchVBios</key> <true/> <key>GraphicsInjector</key> <true/> </dict> <key>PCI</key> <dict> <key>HDAInjection</key> <string>Detect</string> <key>USBInjection</key> <true/> <key>InjectClockID</key> <true/> <key>USBFixOwnership</key> <true/> <key>LpcTune</key> <true/> </dict> <key>ACPI</key> <dict> <key>ResetValue</key> <string>0x06</string> <key>EnableC4</key> <true/> <key>EnableC6</key> <true/> <key>GeneratePStates</key> <false/> <key>C3Latency</key> <string>0x3E7</string> <key>EnableISS</key> <true/> <key>DropDMAR</key> <true/> <key>DropBGRT</key> <true/> <key>EnableC2</key> <true/> <key>DsdtName</key> <string>DSDT.aml</string> <key>PluginType</key> <string>0</string> <key>ResetAddress</key> <string>0xCF9</string> <key>PLimitDict</key> <string>0</string> <key>UnderVoltStep</key> <string>0</string> <key>DoubleFirstState</key> <false/> <key>DropOemSSDT</key> <true/> <key>GenerateCStates</key> <false/> </dict> </dict> </plist> 10. Place the kext FakeSMC.kext (From HWSensors) and NullCPUPowerManagement.kext inside the Clover USB kexts/10.8 folder.
      You have now created a bootable Clover (UEFI) USB!

      OS X Installation
      BIOS Settings:
      - Disabled USB 3.0 Controller (also legacy-mode)
      - Disabled PATA/Serial/LPT-ports
      - Disabled EPU Power Saving
      - Enable (no auto!) all available CPU State Reporting (C1E, C3, C6, etc.)

      1. Boot in the target system with both the OS X Installation Media and the Clover USB-stick plugged, hit F8-key for BIOS-Menu, choose UEFI: *Clover USB Drive Name*
      Select Mac OS X Base System (or whatever you could your OS X Installation medium) and hit Enter.

      Your system should be booted in a few minutes and show you the Installation Welcome screen.
      Select your language and open up Disk Utility.
      Select the target drive, click Partition-tab and select GPT-schema under Options.
      Make one or more partitions (what your desire) and click on Apply.
      Exit Disk Utility and follow the rest of the OS X Installation.

      After installation, try to boot the new created OS X-partition with the Clover-USB.

      If this all worked, congratulations! You just installed OS X!

      OS X Extra's
      DSDT
      It is recommended to create your own DSDT.aml file.
      There are two ways to get your DSDT: Inside OS X or with a Live (Ubuntu) Linux Installation USB-stick (recommended).
      See the following howto for Ubuntu (It's recommended to also boot the USB in UEFI-mode).

      When you have your DSDT.dsl file open it inside OS X with DSDT Editor.
      Apply Fix.txt (Menu > Patch > Open), choose IASL and click on Compile.

      To fix the following warnings:
      ResourceTag Larger than Field (Tag: 64 bits, Field 32 bits), change CreateDWordField to CreateQWordField in that line.

      Not all control paths return a value (_HID):
      Method (_HID, 0, NotSerialized) // _HID: Hardware ID { If (TCMF) {} Else { Return (0x0201D824) } } Return (Zero) // add this Compile again and save the generated DSDT-file as DSDT.aml on your desktop (IASL > Save AML As)
       
      Note: I added my latest patched DSDT.dsl that includes many other fixes like nVidia injection (No more GE=Yes), RTC fix, ALC892 (HDEF) edit, etc.
      Patch IntelCPUPM
      There are two ways to get AppleIntelCPUPowerManagement to work (needed for speedstep).
      One way is to patch it with this script or by patching your BIOS. Clover includes already a patch for AppleCPUPM, so if you are going to use Clover as your default bootloader this should not be needed anymore.

      I have patched my BIOS so I never have to worry about IntelCPUPM. Please keep in mind patching is risky, so please be warned!

      HWSensors (FakeSMC)
      Run HWSensors.pkg and install it on the OS X Installation drive. You can select all plugins btw.

      Realtek (Ethernet)
      See instructions here

      Clover Bootloader
      If everything is working, you can install Clover as your default bootloader. Just run the Clover setup again, select the OS X partition and the following Installation Options:


      - To install Clover as bootable-option (needed for ASUS-boards) format an USB-stick inside Windows with a FAT32-filesystem
      - Download this Shell.efi file and place it into the root of the USB-stick as Shellx64.efi
      - Reboot your system, and enter the BIOS-settings screen
      - Go to Advanced Settings > Exit > Launch EFI-shell from filesystem
      - The EFI-shell should now automatically load.
      - Run the following commands from the EFI-shell (# ... # are just comments):
      > map fs* #choose the correct disk where OS X is installed# > fs1: #for me it's fs1# > cd \EFI\CLOVER #change to the \EFI\CLOVER directory on the EFI-partition, if you can't cd, you have the wrong fs*:# > bcfg boot dump #list current boot-menu settings# > bcfg boot add 0 CLOVERX64.efi "OS X" #add Clover as a boot-option# > bcfg boot dump #list the changed made to the boot settings# > reset #restart system# That's it, you can now boot into Clover by selecting OS X in the BIOS-menu without the USB-stick.

      I recommend to change config.plist on the EFI-partition, these are my (working) settings:
      <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>KernelAndKextPatches</key> <dict> <key>Debug</key> <false/> <key>KernelCpu</key> <false/> <key>AsusAICPUPM</key> <true/> <key>AppleRTC</key> <true/> <key>KextsToPatch</key> <array> <dict> <key>Name</key> <string>AppleAHCIPort</string> <key>Comment</key> <string>External icons patch</string> <key>Find</key> <data>RXh0ZXJuYWw=</data> <key>Replace</key> <data>SW50ZXJuYWw=</data> </dict> <dict> <key>Name</key> <string>AppleTyMCEDriver</string> <key>Comment</key> <string>AppleTyMCEDriver patch</string> <key>Find</key> <data>cgoATWFjUHJvNCwxAE1hY1BybzUsMQBY</data> <key>Replace</key> <data>cgoAAAAAAAAAAAAAAAAAAAAAAAAAAABY</data> </dict> <dict> <key>Name</key> <string>IOAHCIBlockStorage</string> <key>Comment</key> <string>TRIM enable patch</string> <key>Find</key> <data>QVBQTEUgU1NE</data> <key>Replace</key> <data>AAAAAAAAAAAA</data> </dict> </array> </dict> <key>ACPI</key> <dict> <key>DsdtName</key> <string>DSDT.aml</string> <key>DropOemSSDT</key> <true/> <key>GenerateCStates</key> <true/> <key>GeneratePStates</key> <true/> <key>DropAPIC</key> <false/> <key>DropMCFG</key> <true/> <key>DropHPET</key> <false/> <key>DropECDT</key> <false/> <key>DropDMAR</key> <true/> <key>DropBGRT</key> <true/> <key>ResetAddress</key> <string>0xCF9</string> <key>ResetValue</key> <string>0x06</string> </dict> <key>SMBIOS</key> <dict> <key>ProductName</key> <string>MacPro4,1</string> </dict> <key>RtVariables</key> <dict> <key>MountEFI</key> <true/> <key>LogLineCount</key> <integer>3000</integer> <key>LogEveryBoot</key> <false/> </dict> <key>GUI</key> <dict> <key>Theme</key> <string>bluemac</string> <key>Timeout</key> <integer>2</integer> <key>DefaultBootVolume</key> <string>Macintosh HD</string> <key>DebugLog</key> <false/> <key>Mouse</key> <dict> <key>Enabled</key> <false/> <key>Speed</key> <integer>0</integer> </dict> <key>Volumes</key> <dict> <key>Legacy</key> <false/> </dict> <key>HideEntries</key> <dict> <key>OSXInstall</key> <false/> <key>Recovery</key> <false/> <key>Duplicate</key> <false/> <key>WindowsEFI</key> <false/> <key>Grub</key> <false/> <key>Gentoo</key> <false/> <key>Ubuntu</key> <false/> <key>OpticalUEFI</key> <false/> <key>InternalUEFI</key> <true/> <key>ExternalUEFI</key> <false/> </dict> </dict> <key>PCI</key> <dict> <key>LpcTune</key> <true/> <key>HDAInjection</key> <string>892</string> <key>USBInjection</key> <true/> <key>InjectClockID</key> <true/> <key>USBFixOwnership</key> <true/> </dict> <key>SystemParameters</key> <dict> <key>boot-args</key> <string>-v npci=0x2000 slide=0 nvda_drv=1 WithKexts</string> <key>prev-lang:kbd</key> <string>nl:0</string> <key>InjectSystemID</key> <true/> <key>LegacyBoot</key> <string>PBR</string> </dict> <key>Graphics</key> <dict> <key>GraphicsInjector</key> <false/> <key>PatchVBios</key> <true/> </dict> </dict> </plist> Fix_beta990.txt
      DSDT.dsl.zip
      config.plist.zip
      AppleHDA.kext.zip
    • By zaledar
      Hi,
       
      System randomly freezes and console is full of channel timeout. My graphic card is a GeForce GTS 450 2048 MB.
       
      My system freeze more when I use Itunes, Iphoto and always when the screensaver is running. I can just move the mouse but all the system is frozen.
       
      When the system freeze this log appears :
      2012-10-28 12:19:18 +0100 kernel[0]: NVDA(OpenGL): Channel timeout!
      2012-10-28 12:19:38 +0100 kernel[0]: NVDA(OpenGL): Channel timeout!
      2012-10-28 12:19:58 +0100 kernel[0]: NVDA(OpenGL): Channel timeout!
       
      I just installed Nvidia driver :
      http://www.nvidia.co...f02-driver.html
      to solve problem of "Blue Screen" after changing resolution ,and graphicals bugs.
       
      During game, for example diablo3, all others apps closed, I have no random freeze.
       
      Anyone any suggestions for a solution?
    • By beta992
      Please read the new and updated guide here!
       
      Thanks!






    • By MelloAndroid5123
      Hello everyone, I'm here to ask if anyone knows how to get hardware acceleration working on an EVGA nVIDIA GeForce GTS 450 1024 GB. I've tried the tonymacx86 nVIDIA update, an EFI string, and the official nVIDIA CUDA driver. I'm running Mac OS X Snow Leopard 10.6.5 but I can upgrade to any version. I'm only on 10.6.5 because of the tonymacx86 update. I'm pretty sure I don't have hardware acceleration because I can't change my screen resolution, and certain animations like clicking the Application folder are slugish. I have an AMD Phenom II X4 @ 3.2 GHz, and 8 Gigabytes of RAM. I'm really hoping this can be fixed as it's the only thing not working Thanks in advance
    • By Teddie
      Hello!
       
      I've a little problem with my graphic card.
       
      1. I installed Lion X.7.0 with ######
      => Diablo 3 works with a very good fps / no OpenCL (LuxMark)
      2. I installed Lion X.7.3 (Boot with ######-USB-Stick)
      => Diablo 3 works with a very good fps / no OpenCL
      3. I installed ###### (show Attachment)
      => Diablo 3 works very lousy (probably is the card in 2D-Mode?) / no OpenCL
      4. I installed the current nVidia-Driver
      => Diablo 3 works very lousy / no OpenCL
      5. I installed the FERMI OpenCL patch
      => Diablo 3 works very lousy / OpenCL works, but very lousy
       
      Sorry, for my english but I learn still in addition.
       
      I hope anybody can help me.
      Ohne Titel.tiff
×