Jump to content

Acer Aspire 5920 troubleshooting help, SL 10.6.7.

1 post in this topic

Recommended Posts

Hello everyone. I am new to the forum as a poster, but not new to the site by any means. Prior to discovering OSx86, I had probably less than 10 minutes time spent on a Mac in my life and it was mostly surfing the web on friends'. I do a lot with audio and video and wanted to see what OS X was all about since people always scoff at me for using Windows for those things. I dove into research mode and have already spent, literally, the past week and a half straight when I'm not at work working on this. I've been getting about 2-3 hours sleep a night because I can't stop trying to get the install right, that's just how I am. LOL.


Anyways, I didn't want you guys to think I got lazy and decided to make a PLEASE HELP ME! post right off the bat. I'm finally posting on here because I've exhausted all options I've found, or because my inexperience in the Mac world is causing me to overlook or miss something. I don't ever have a problem I can't fix/solve on a PC running Windows, so this is a new feeling of joy/frustration for me. ;)


So here's my scenario, laptop being used is spec'd as follows according to CPU-z & Windows Device Manager:

Acer Aspire 5920-6914 (NOT the 5920G w/nVidia graphics)

BIOS: v1.3813 (most current available)

HDD: WD Scorpion Black 500GB 7200RPM Advanced Format (Split into 2 partitions, 300GB for Vista & 200GB for OS X)

CPU: Intel Core 2 Duo T8300 2.4GHz 800MHz FSB "Penryn"

Memory: 3GB DDR2 333MHz

Chipset: Intel GM965 (rev C0)

Southbridge: 82801HBM (ICH8-ME) (rev B1)

Video: Mobile Intel® 965 GMA X3100 with 256 MB of GDDR3 VRAM 1280x800 (Full QE/CI) [8086:2A02 Rev 003]

Audio: Intel HDA (Listed in Windows as Realtek HDA) [10EC:0888 Rev 1001]

Wi-Fi: Intel 4965AGN [8086:4229 Rev 61]

Lan: Broadcom Netlink Gigabit Ethernet [14E4:1693 Rev 2]


I don't care about the camera functioning, I won't use it.


When I first dove into exploring this, I opted to go for the iDeneb Leopard 10.5.5 install. Install after re-install completing sucessfully with various combos of options and kernels checked off, I'd wind up with a black screen and a mouse pointer stuck in the top left of the screen and a second pointer I could move around but the screen stayed black. I eventualy realized this was being caused by my checking off of the "X3100" video drivers install. Long story short, installing the iDeneb 10.5.5 with ONLY AppleAzaliaAudio, ICH-x Fix, Powermanagement fix and running the Vanilla Kernel was my ticket to happiness. Installing in this fashion led me to full video support with all resolutions listed, working headphone out and onboard speakers and volume knob (that's all I care about), and the ACPI battery functioned perfectly. Sleep, restart and shutdown all also functioned perfectly. I couldn't seem to find a resolution for either the wired or wireless internet (unless something's changed and there's a solution now) so I gave up on trying and planned to snag a new card that was compatible with both Windows and OS X.


So you're thinking...well, that doens't sound like he has a problem...


Well, then I said OK, that was Vanilla 10.5.5 with just a few small fixes...Let's go Snow Leopard as most programs I want to use require it anyways. So I installed Retail Snow Leopard 10.6.3 using the USB method. It installs and boots perfectly, using the Chameleon RC2 bootloader on the USB. But now, I only have 1024x768 listed for resolution, the video card is not being supported. I have no sound. Sleep doesn't work. The battery display and reading doesn't work, lists battery as 0% and won't let me check off "show battery on toolbar". I have tried EVERYTHING I can find to fix all of these issues and have had ZERO success. So here's what I've tried, all of which DID NOT SOLVE THE PROBLEMS.


Battery: VoodooBattery.kext, changing my SMproductname to MacBookPro5,1, copying over the Powermanagement.bundle from the iDeneb install, DSDT auto patcher, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].


Video: tried boot in 32 bit, various kexts from people's success posts with Aspire 5920's, google'd kexts, kexts + DSDT from osx86.net, DSDT auto patcher, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. I do not want to use a force res string, I want the card to actually be functioning properly.


Audio: copy and install AppleAzaliaAudio.kext from iDeneb install, various AppleHDA kexts, VoodooHDA, various Realtek ALC888 kexts, DSDT auto patcher, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. NOTE: The VoodooHDA kext gave me everything EXCEPT internal speakers which out of all things is the main thing I want. I really only care about the internal speakers and headphone out.


Sleep: This I JUST noticed wasn't working in Snow Leopard for me right before I came back to Windows to type this out. I'd like for the computer to do like it does in Windows and Sleep if I close the lid.


I was able to successfuly update from 10.6.3 to 10.6.7 using the updates directly from Apple's site. I never have any boot freezes or issues until I start going in and swapping kexts and messing with things. I know there are plenty of people with this exact computer that have done this successfully, so it's becomming more and more frustrating that I can't figure out what I'm missing here. As it stands right now, I've got a totally bone-stock 10.6.7 install ready to go. I will be forever grateful if someone can just give me a simple step by step to fix this. Again, all I want to fix is sleep, the battery, video and audio (onboard speakers and headphone out) (and either wired lan or wifi if there IS a fix for that now, but I don't want to compromise system stability).


I hope I have provided everything you will need but let me know if you need any more info. Thank you tremendously in advance.



Link to comment
Share on other sites


  • Create New...