Jump to content

New Laptop - hope to install Mac OS X, but...


5 posts in this topic

Recommended Posts

Hi! I have recently got an HP Pavillion g6-1b71he. I am hoping to install Mac OS X Lion, but I am having a few issues:

  1. Any time I try to boot from any boot-132-based bootloader (i.e. Chameleon), or try to install from a distro (i.e. Hazard, iDeneb, etc.) for that matter, the computer reboots before it even finishes loading to a verboose boot.
  2. I created an [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] UEFI disk (NOT the one from tonymacx86, but the UEFI bootloader that was discussed when installing some beta versions of Lion), and it boots to the GUI. I can't boot from a DVD, but...
  3. I have downloaded a .vmdk file of Lion for VMware, used a Windows software called Starwind V2V converter to convert it to a .img, and restored the resulting image using TransMac to a USB flash drive. And yes, I added FakeSMC.kext to /System/Library/Extensions. I also added DP1's mach_kernel as it first could not find mach_kernel on the restored .vmdk. Now, when I attempt to boot from that using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], it loads into the verboose boot, but I get this Kernel Panic. In case you can't read it, it says: Unable to find driver for this platform: \"ACPI\".



This is a replacement for my dead Toshiba laptop, which was AMD, so Lion was a no-go. The only reason that I bought this laptop was because it was compatible with Lion, and now there are more obstacles than just this mere kernel panic.


I was planning on cloning Windows from my other Toshiba over here. But that won't be happening for quite some time, but it turns out that the version of Windows installed on this laptop is MBR formatted with 4 Primary Partitions preloaded. I have no clue if there is a second slot for a hard drive on this laptop. It's my understanding that GPT can circumvent the limit of 4 primary partitions.


Now, the problem is most Windows disk cloning software that has support for GPT is commercial or shareware. The only thing I want to buy is Lion from the Mac App Store eventually. Even some of them will restore the MBR to the GPT disk... only after converting it back to MBR, which defeats the purpose.


I have 2 ideas, one more likely possible than the other.


Plan A:

  1. Create an image of Windows using a disk cloning program.
  2. Download Lion from the Mac App Store.
  3. Restore InstallESD.dmg to a 5GB .vmdk.
  4. Use Starwind V2V converter and TransMac, respectively, to restore the image to an 8GB flash drive. (.vmdk-->.img-->restore to flash drive).
  5. Boot into [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], and use that to boot into restored InstallESD.dmg.
  6. Re-partition the hard drive to GPT, with one restore partition and one to install Mac OS X on.
  7. Install Mac OS X.
  8. Reboot into [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], and choose the installed partition.
  9. Do some post-install things.
  10. Use the Disk cloning software to restore Windows.
  11. Use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] whenever I want to boot into OS X. Or, back as a part of post-install steps, reformat and create an XPC USB disk, install it to the UEFI partition, and replace the efi foler with the one from rEFIt. This way, I can run OS X or Windows. Details of this process can be found here: http://www.insanelym...howtopic=265528


Plan B (Not sure if this would work):

  1. Do Steps 1-3 above, but this time, use VMware to install Lion to a .vmdk.
  2. Do the same post-install things as described in step 9 and 11 above.
  3. Use Starwind V2V converter to convert the affected .vmdk to a .img at the root of my C:\ Drive.
  4. Use, test, and configure a linux bootloader like Burg, Grub4dos, etc. to mount and boot from the resulting .img.


I don't know if plan B would work because the more I read about booting from the image file, the less likely it seems without modifying the OS. Bye-bye vanilla install!


Here is where you can find detailed specs of this laptop: http://h10025.www1.h...product=5128920


Someone said, but I couldn't confirm, that the model of the Intel HD Graphics Card is 3000. The same person also said that it was an Atheros AR9285 wifi card, but I wound up with a ralink card (more specifically, it's the Ralink RT5390 802.11b/g/n WiFi Adapter).


Now my questions:

  1. Would plan B even work?
  2. If not, any disk cloning software you could recommend to do Plan A? (Remember, I prefer free.)
  3. Any ideas for how I can get Chameleon to boot on my laptop? (Just to warn you, my BIOS options are extremely limited.)

Please help me ASAP! Thanks in advanced!


Link to comment
Share on other sites

  • 5 months later...

i've the same pc did you solved the problem

Actually, I did! Feel really silly with what the problem was when I found out. I ended up using the Nawcom ModCD method to install Snow Leopard. I've tried Lion, but I didn't really see a need to keep it as the only version of iMovie I had laying around was a PowerPC version (and as you probably know, Rosetta doesn't work on Lion. I've read about a custom kernel that can use Snow Leopard's Rosetta Package and run PowerPC software, but with Lion supporting my CPU, I didn't want to wait for people to patch kernels. That's why I switched to this PC, my previous one was an AMD.)

Anyway, as to how I booted, it turns out it was a busratio problem! ;) So, before booting, you need to type the following boot flags:

cpus=1 busratio=18 -v


Do not, and I repeat, DO NOT type mach_kernel, as Snow Leopard's vanilla kernel does not support the Core i3 until version 10.6.4, and the PC will reboot if you do.

If you want to install Lion, go right ahead. But I'll let you know that I was stuck in a "Welcome!" loop, and the Apple Setup Assistant didn't detect my keyboard on Lion. I forget how I got around the loop. After endless Google Searches, I figured out that the account I created was being created as a standard user and not an adminstrator, so I figured out how to make a user an adminstrator in single user mode (but I first had to make it a group called adminstrator with the right permissions.) If you want to go and install Lion, you should do the searches using that information. If you still need help, I'd be willing to help you.


However, if your a complete newbie, I'd stick with Snow Leopard only for simplicity. I'll be able to help you either way.


And I am still looking for a solution regarding the graphics card (The Infamous Intel HD Graphics with the ids 8086:0046). I'm getting close to finding one, but for now, I have a dual boot setup with Windows 7 and Retail Snow Leopard on MBR thanks to the ModCD. I hope this helps!

Link to comment
Share on other sites

-thank you for the reply

iWin32 it was a very helpful push i was a abandening the case but your help, i'm sure to achieve the installation.

- for now i don't have snow image i'm downloading it, like you said i think it is simple to install snow,but until the download finishes , i will make some testes with MODCD and iATKOSL2 and flags or Niresh distribution .

it all what i've for now until i download dmg images for snow and Lion.

did you have the option to change SATA to AHCI or it is flags role in your laptop.

Link to comment
Share on other sites

Hi iwin32,

i've tested iAKaTOSL2,snow LeoPard but nothing i get this messages errors

"ACPI table not found DSDR.aml"

"no DSDT found using 0 as uid value

i wonder if you have made some change in your bios as you my hp bios is very limited just date boot order... is it your case for bios.

Link to comment
Share on other sites


  • Create New...