Jump to content
Sign in to follow this  
askiba

Graphics messy if not in safe mode...

3 posts in this topic

Recommended Posts

Hello,

 

I have been trying to get OSX to work on my Toshiba and I find it hard to back down from this challenge with limited resources - DVD burner is broken, and I only have a 4gb USB stick.

 

I acquired a VMware image after trying several different ones to finally get one that worked, which is version 10.4.7, converted it to raw with qemu-img and DD'd it to the partiton.

 

So when I booted it, it was very fast to get to the GUI but 70% of the screen is black and most text is missing and everything appears like blue squares. I was able to get around this by getting into safe mode.

 

I have a intel 945, but Mac OS identifies it as a Intel GMA 950. I tried removing the GMA 950 kext and deleted the kext cache and repaired the permissions, then I rebooted but it still had the same issue, so I am not sure which kext is causing this, or why in safemode it works. Can anyone help me? :)

Share this post


Link to post
Share on other sites
Advertisement

Hi, thanks for the reply,

I fixed it with a patch called GMA900-Fix by Diabolik or something, forgot the exact name. Then I also had to remove all of the GMA950 kexts and leave the Intel915 kext there. Interesting what different combinations work for different people!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×