Jump to content

A few problems with my HTPC (Zotac Zbox HD-ID33) - 10.7.2


12 posts in this topic

Recommended Posts

Hey guys!


I've got a few problems on my HTPC. Zotac Zbox HD-ID33



NVidia ION2 G 210 [NVa8] 0a60 GT200 [GeForce G210] - 512 MB


Realtek Ethernet RTL8111

Sound HDA ALC888

Intel Atom D525 1,8 GHz

Intel AHCI Chipsatz NM10 ExpressP

Atheros AR9285 (doesn't work, but it's not necessary)

iAtkos L2 with mach_atom Kernel

NVEnabler - QE/CI is on

16 GB SSD with TRIM Support



  • 1) No iCloud Support

I've done everything I could find online to solve this problem. I created with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 4.1.0 a MacMini 5,1 identification and with Champlist's Serial Generator a serial. I added built-in Ethernet and PCIRootUID entries in org.chameleon.*.plist. Chameleon 2.1 1708 is installed (edit: now 1706). Any further ideas?


Error Message: This Apple ID is valid but is not an iCloud account.

  • 2) 1080p playback is unwatchable (mostly in Plex)

My graphics card works, with QE/CI. Video acceleration is working - 720p/24p looks extremely nice - but 1080p doesn't work for me, except in Movist - there I can play back 1080p but this program doesn't support 24p playback.

  • 3) No 5.1 Sound, Passthrough doesn't work

​ In Plex, 5.1 surround sound works, but for example in Movist I can't turn on (Current audio out device does not support S/PDIF). I tried several howtos - nothing works. In Audio MIDI Setup i can't select direct output. The tricks with creating an Aggregate Device or a Multi-Output doesn't work for me either. I set diverse "attemptDTSpassthrough" and AC3 settings - perian is installed.

  • 4) No jumbo packages

I can't use jumbo packages with my ethernet card. Dunno why. The card works "flawlessly". But the max value is MTU 1500. I need at least 7000. It worked on Linux and Windows with this HTPC.

Networksetup says:

Valid MTU Range: 1280-1500



So, that are a few of my actual Problems ;)


I hope, someone could help me.


Best regards,



P.S. English is not my native language - pls don't be mad with me :)

Link to comment
Share on other sites

I have this driver installed. :(


I used the Chameleon Wizard - There were some missing information in my smbios.plist. I added a pre made smbios (macmini 5,1), but there a still some missing fields. For example:

Week of manufacture and unique number. I can create random values, but they aren't saved. UUID and all of the advanced values are empty. What should I put in there?


Chameleon says (on boot up):

VESA v3.0 14MB (NVIDIA) - Maybe that could be a mistake.

Link to comment
Share on other sites

Other thing, is it possible to activate an overscan function for boot process? There's such a big black border (ya I know, this is cosmetic :))








Now i configured my HTPC as a MacPro 3,1 and updated with Chameleon Wizard my smbios.plist - still no iCloud support with the same error message.

Link to comment
Share on other sites



So, now I'm a bit confused. I found a System Info Tool, and this shows me my hardware. And this differs from that hardware I thought it should be in my HTPC.


NVidia G218 instead of G210, maybe that's the problem of the 1080p playback?


Ralink RT2860 Network Adapter? Is that my WLAN card?


RTL-8110SC instead of a RTL-8111 - Causes this the missing jumbo package support?

Should I try this: http://www.chipdrivers.com/chipset/network-adapter/realtek/rtl8110sc/apple-mac-os-x-intel-based/ ?


nVidia and Intel Audio Controller. nVidia, HDMI Sound - does this work!? That would be great :D



Link to comment
Share on other sites


  • Create New...