Jump to content

ESXi & Lion: Applets in Safari work, but not in Firefox or Google Chrome

2 posts in this topic

Recommended Posts



I'm fairly new to virtualizing Macs, but I was able to follow the instructions here on the forums and have been able to get multiple VMs spun up for Snow Leopard and Lion on ESXi 5.0. Who-hoo!


I'm trying to test a java applet on these VMs, and have found that Firefox and Chrome won't display them, and it looks to be a display issue re: virtualization. Other than attempting to display java applets, the browsers seem to work fine. I'm getting the same results whether I use Snow Leopard or Lion. Interestingly, Firefox 3.6 seems to work, it's just Firefox > 3.6 that doesn't work, and Google Chrome doesn't work.


For Firefox, the place where the applet should be appears blank, and with Chrome, it's 'transparent' --- I can see through to the window or desktop background behind it.


Looking at the system log when the browser runs and tries to display the applet, I see a similar set of messages whether I'm running Firefox or Chrome. Here's the sample of messages from running Chrome:


Dec 6 14:16:36 lexqevm2-140 Google Chrome Helper EH[444]: Process manager already initialized -- can't fully enable headless mode.

Dec 6 14:16:36 lexqevm2-140 [0x0-0x42042].com.google.Chrome[436]: 2011-12-06 14:16:36.619 Google Chrome Helper EH[444:b03] Process manager already initialized -- can't fully enable headless mode.

Dec 6 14:16:36 lexqevm2-140 [0x0-0x42042].com.google.Chrome[436]: [436:1547:2978955312725:ERROR:accelerated_plugin_view_mac.mm(48)] NSOpenGLPixelFormat initWithAttributes failed

Dec 6 14:16:36 lexqevm2-140 Google Chrome[436]: invalid pixel format

Dec 6 14:16:36 lexqevm2-140 Google Chrome[436]: invalid context

Dec 6 14:16:36 lexqevm2-140 [0x0-0x42042].com.google.Chrome[436]: [436:1547:2978959759445:ERROR:accelerated_plugin_view_mac.mm(53)] NSOpenGLContext initWithFormat failed

Dec 6 14:16:36 lexqevm2-140 [0x0-0x42042].com.google.Chrome[436]: [436:1547:2978959777198:ERROR:accelerated_plugin_view_mac.mm(62)] CGLContextObj failed

Dec 6 14:16:36 lexqevm2-140 [0x0-0x42042].com.google.Chrome[436]: [436:1547:2978959786539:ERROR:accelerated_plugin_view_mac.mm(66)] CGLPixelFormatObj failed


Given that java applets DO work in Safari on the same VM, and that the non-java-applet portions of Firefox and Chrome work, I'm hoping this is something that can be configured/fixed to work.


Any ideas?


I found a number of options in Firefox (about:config) and Chrome that seemed to apply to graphics an graphics acceleration, but tweaking them didn't help. Not sure if a solution here would revolve around getting the display adapter in use for the VM to be more accommodating to what the browser is trying to do re: displaying the applet, or if we need to instruct the browser/java plug in not to try and use native mac h/w graphics, or if it's something else entirely.


I've tried Zenith's SVGA II driver as well --- no luck. :(


Remember, this is ESXi not Workstation/Fusion. And it's not a simple situation of loading Java in Lion and selecting "enable plugins for browsers" -- I'm way beyond that.


At this point I'd love to hear confirmation that other people are seeing the same thing --- is anyone else there running Lion on ESXi and if so have you tried Google Chrome or Firefox 8, with a webpage that displays a java applet? I'm betting you'll find it works in the latest Safari, but won't work in Google Chrome or FF8.


Thanks in advance for any help!

Link to comment
Share on other sites

While I am beginning to doubt that there is an easy solution to this, I'd love to hear that others are seeing the same problem. If anyone else has Lion or Snow Leopard clients running on ESXi, could you try and bring up Firefox 8 or Google Chrome, and bring up a page with a java applet?


Bonus: you can make it a game. :) Search for "missile command java applet" and you'll find a page that brings up missile command in an applet. Bet it works for you in Safari (and maybe Firefox 3.6), but not Firefox 8 or Google Chrome.

Link to comment
Share on other sites


  • Create New...