Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
KrazyKiwi

Asus GTX 560 (NON TI!) Support on Lion

50 posts in this topic

Recommended Posts

Ok so I just put together a new pc. It has an ASUS Maximus IV GENE-Z. Ive got a Core i7 2600K, 2x4 GB of Corsair Vengeance ram, and an ASUS GTX 560 non TI (idk what to actually call it). Ive modded the NVDAGF100Hal kext and the modified GeForceGLDriver bundle. I boot up and I get native resolutions but all I see is the background of the login screen and it flickers back and forth from the spinning loading feel (no apple logo). And when I boot verbose it does the same thing but with the verbose black screen with some occasional lines of code. When I boot into safe mode I get native res as well and I can actually log in but I don't get QE, CI, or Open GL.

 

Any help would be greatly appreciated... ;)

Share this post


Link to post
Share on other sites

Did you edited the NVDAGF100Hal with the device ID of your card?? Make sure you're using the right id or it won't work.

 

The GeforceGLbundle is for OpenCL only.

 

Cheers!

Share this post


Link to post
Share on other sites

Ok so I've managed to get native resolution on my screen and it is detecting all of the graphics card memory. But it still says it is an unknown card and the 2d acceleration is extremely poor. 3d is fine but I'm getting choppy animations with beam sync disabled and quartz 2d extreme enabled. Is this a driver issue or just an issue with lion in general? The 2d animations are more choppy then they were on my 7500LE on my 1080 screen

Share this post


Link to post
Share on other sites

Ok I solved all of my problems by myself :D

For anyone else with an ASUS GTX 560 non ti, this is what I did.

1. Update to latest version of lion (10.7.2)

2. Download this kext package- http://www.osx86.net/downloads.php?do=file&id=1801

3. Install all kexts and bundles in the zip file (Kext Utility)

4. Reboot

Extra steps

5. You might need to add npci=0x2000 to your kernel flags and/or add <key>PCIRootUID</key> <string>1</string> to the boot.plist

 

6. If you want to get the most performance out of your card, delete the AppleGraphicsPowerManagement kext and run the kext utility again. (I would recommend you do this as the 2D performance is poor with the power management on)

 

Thats it...

Hopefully this helps someone

Share this post


Link to post
Share on other sites

Good day,

 

I know it has been a few months but thought to ask you how things are going with you and if you have updated to 10.7.4 yet?

 

I brought the EVGA GTX 560 (non-ti) and will try your suggestions.

 

Cheers

 

- I running

 

DSDT ###### setup

SMBIOS Macpro 3,1 (but will try Macpro 4,1)

Share this post


Link to post
Share on other sites

Hi.

Im still running 10.7.2 because I don't want to mess anything up, but I'm sure it works with 10.7.4. Just update first then install the files. Disregard step 6 though, it might help reduce lag but the easiest way is to put your display to sleep then wake it up again. For some reason this fixes all the lag, at least for me. I put the display to sleep option in the top right hot corner so whenever I reboot the computer, I just quickly put the display to sleep and wake it up again.

One thing I did notice with my card is that fading animations slow down the graphics a lot. So the fading animation the volume makes every time you change it causes the 3D performance to be really jerky for a second. Not really annoying unless you have a chat program that has messages pop up and fade out, then it becomes a problem.

If you have any other questions, feel free to ask.

Share this post


Link to post
Share on other sites

Do you have an edited AppleGraphicsPowerManagement.kext for the GTX 560 on ML you can attach here?

 

I deleted the AppleGraphicsPowerManagement.kext because it served no purpose. If your graphics card is running with full resolution and Quartz Extreme, then your all set.

I don't know if this method works on Mountain Lion, but if you need any help just ask.

Share this post


Link to post
Share on other sites

Ok. Have you already tried installing the kexts I provided in Post #4? If you haven't then backup your NVDAGF100Hal and GeForceGLDriver.bundle and install GeForceGLDriver.bundle and NVDAGF100Hal.kext. If that doesn't work then send me your backed up .kext and .bundle and ill modify them for you.

Share this post


Link to post
Share on other sites

Ok. Have you already tried installing the kexts I provided in Post #4? If you haven't then backup your NVDAGF100Hal and GeForceGLDriver.bundle and install GeForceGLDriver.bundle and NVDAGF100Hal.kext. If that doesn't work then send me your backed up .kext and .bundle and ill modify them for you.

thanks. i tried installing them, but actually got a KP

http://d.pr/f/Vb1u

Share this post


Link to post
Share on other sites

Ok, im going to put these lines in NVDAGF100Hal.kext

0x0dc010de&0xffc0ffff

0x0f0010de&0xffc0ffff

0x104010de&0xffc0ffff

0x120110de&0xffc0ffff

0x108610de&0xffc0ffff

 

The bolded letters is the device ID plus the last three characters of the vendor ID. Go to About This Mac and go to the graphics/displays section and tell me if any of these bolded lines is the same as the device ID plus the last three characters of the vendor ID. Or just send me a screenshot of your About Mac Graphics/Displays window.

Share this post


Link to post
Share on other sites

It looks like your graphics card has been properly identified already. A quick way to check if you already have the correct drivers is if you can use itunes cover flow

 

If the power management kext isnt causing any problems, then don't bother removing it, your Bios should do most of the GPU control anyways, you won't burn out your card by removing the kext but I would keep it there anyways.

 

Also, is everything in /Extra, including org.chameleon.Boot.plist fine the way I have it?

 

Yup it looks just like mine

Share this post


Link to post
Share on other sites

Hmmm, I guess it's something in my /Extra folder thats holding it back performance-wise, or that games just wont play well on OS X. I get 60FPS on Guild Wars 2 on Windows 8, but 7 FPS on OS X. Or maybe my CPU isnt being used properly on OS X. I dunno.

Share this post


Link to post
Share on other sites

Hmmm, I guess it's something in my /Extra folder thats holding it back performance-wise, or that games just wont play well on OS X. I get 60FPS on Guild Wars 2 on Windows 8, but 7 FPS on OS X. Or maybe my CPU isnt being used properly on OS X. I dunno.

 

Well, I didn't see your cards model number in the NVDA kext so I added your device to the kext, try it and tell me if it fixes anything

http://d.pr/f/9PGi

Share this post


Link to post
Share on other sites

I cant compare Guild Wars 2 on my PC but if you download Cinebench http://www.maxon.net/products/cinebench/overview.html I can see if the problem is your graphics card or if its just OSX itself

 

k, will do. also gonna remove the power management kext anyway

Ok, I couldn't find any differences in the GeForceGLDriver.bundle so I didn't modify it, but if the kext still doesn't work I recommend installing the modified GeForce bundle from post #4. The kext was most likely giving you the kernel panic so installing the bundle shouldn't give you one.

Share this post


Link to post
Share on other sites

Got a KP, but I guess that's because I remove the power management kext?

Possibly, was there a certain kext in the kernel panic code? There is usually only one, and it was probably the NVDAGF100HAL kext

Share this post


Link to post
Share on other sites

According to some users the GTX 560 non-TI works out of the box on ML. But you need to install the NvidiaCL Enabler.

You need to register for an account and download iMultiBeast ML. It has alot of cool tweaks and drivers but for now just install the OpenCL Enabler.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×