Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
acidos77

boot0: error

7 posts in this topic

Recommended Posts

I've installed 10.6.6i Hazard, then upgraded to 10.6.8. Above updated nvidia drivers from official nvidia website.

 

Hardware:

Mobo: P5Q3 Deluxe

Video: MSI GeForece 9600GT

CPU: QuadCore Q9400

Mem: 4Gb

 

I have chameleon installed, however, all I see is

boot0: test

boot0: test

boot0: error

 

I have WD20EARX HDD and according my google efforts, this HDD has some Advanced Format Technology, which will make sector 4096 bytes instead of 512. I'm not sure if this is related or not... I have tried to make it active using fdisk.

t8q7tf.png

 

My Partition scheme is MBR and I am sure it is possible to have OS X on MBR (not necessarily GUID partitioned).

So now the only way I boot my OS X is from Hazard DVD.

Share this post


Link to post
Share on other sites

Unfortunately Chameleon still has issues with "advanced format" 4k sector hard drives.

 

Install Chameleon to any old USB flash drive and use that to boot OS X. Just keep it plugged in and use your BIOS boot selector to boot from it when you want to run OS X. This way you don't have to whip out your DVD all the time. The install procedure is the same as when installing to a regular hard drive.

Share this post


Link to post
Share on other sites

Thanks Gringo, I was about to pull all my hair out.

Meanwhile, is there any other bootloader able to handle my "advanced format" hdd?

Is there any Chameleon discussions about fixing it?

Share this post


Link to post
Share on other sites

I don't know anything about other boot loaders, I have never tried anything else but Chameleon.

 

The Chameleon developers are aware of the 4k sector "advanced format" drive issues. I don't know if anyone is specifically working on it though.

 

In the meantime just install Chameleon to another hard drive drive or a flash drive and it'll work fine.

 

/EDIT- I found something, try installing boot1h like this:

 

dd if=boot1h of=/dev/rdiskXsX bs=4096

 

Look for a post by me over at the VoodooProjects forum and follow the link in my sig to my manual install guide to see the rest.

Share this post


Link to post
Share on other sites

Hi,

 

I faced the same issue.

The solution is to unmount the partition and then execute dd command :

 

1) copy boot1h to another partition or a USB thumb.

2) unmount partion rdiskxSz ( umount /Volumes/Name)

3) move to new boot1h location

4) dd if=boot1h of=/dev/rdiskxSz

 

 

Regards,

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×