Jump to content
InsanelyMac Forum
Sign in to follow this  
AmigoHD

[solved]ASUS P8Z86V-Pro -> Kernel panic (Unable to find driver for this platform: \"ACPI...)

Recommended Posts

When I try to load the OS X Lion Installer on my USB Stick (tried several Bootloaders, löike Chameleon old and new, chimera) I only get a kernel panic like this:

 

panic(cpu 0 caller 0xffffff8000548fde): "Unable to find driver for this platform: \"ACPI\".\n"@/SourceCache/xnu/xnu-1504.14.2/iokit/Kernel/IOPlatformExpert.cpp

 

I tried to use a matching DSDT file for my Board/Bios version, still same error.

Tried different SATA ports, just 2 GB RAM, and all kind of BIOS settings.

 

I can't get OS X Lion to boot the installer.

 

Config:

ASUS P8Z68V-Pro with latest Bios (already tried the stock one)

8 GB RAM

Just a single SSD drive connected

AHCI mode

 

USB3 and other settings disabled. Still I get the kernel panic.

Tried all kind of chameleon settings (like bus, pci etc.).

 

Anyone have inputs or tips I could use to get a working OS X Lion Install?

Share this post


Link to post
Share on other sites
Advertisement

  1. Start with only 4GB of RAM installed
  2. Disable speed step turbo in the BIOS (no other changes made to the BIOS other than drive boot order)
  3. Boot from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Legacy
  4. Put in Mac OSX CD (Wait a few seconds, press F5, select and boot from Mac OSX)
  5. Install with minimal options (to save on install time if things don't work, I omitted X11 and some other things)
  6. Reboot w/ [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Legacy
  7. Install 10.6.7 Combo Update (don't restart)
  8. Install Bridge Helper (don't restart)
  9. Install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] options highlighted in Gordo's post with a couple modifications:
  10. Use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] instead of a custom DSDT.
  11. Choose hnak's AppleIntelE1000e Ethernet instead of the one Gordo74 has selected
  12. Shut down
  13. Install other 4 GB of ram (8 GB total)
  14. Close up case
  15. Reboot and reenable speed step turbo
  16. Install other stuff (X11, XCode, etc.)

Courtesy Betelgeuse from tonymac

 

 

Super!!! All the best with DSDT ;)

Share this post


Link to post
Share on other sites

I got it to work already. Made a mistake at extraxt the Lion.app to usb stick.

all is working nice now, with speed step etc.

 

the only thing is i can't compile my own extracted DSDT file. i get a lot of compiling errors, either in os x or windows.

 

will have a look with the dsdt people over in the DSDT threads.

thx anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×