Jump to content

OSX 10.4 installed but not booting

1 post in this topic

Recommended Posts

Hi there,

I'm having a problem with OSX 10.4 on my HP Pavilion dv1154 (Centrino 1.7).

I have SUSE Linux 10.0 as primary OS, and Windows Server 2003 Enterprise (m0d FlyAkite) as second OS. I want to install Mac OSX too.

I have the bootable installation CD for OSX, and I have a live CD of GPartEd in case of emergency.


I created the HFS+ partition (code AF) using fdisk under SUSE's rescue mode.

My partition list is then like as follows:


/dev/hda1 Extended

/dev/hda5 Linux Swap

/dev/hda2 Linux

/dev/hda3 Windows

/dev/hda4 OSX (fdisk reports Unknown)


I used the OSX installer disc to install the OS, first reformatting the hda4 partition to HFS+. The installation went fine, but I wasn't able to boot OSX.

I tried to add a /dev/hda4 entry into lilo.conf, but when I run lilo I get the following error:

Fatal: first sector of /dev/hda4 doesn't have a valid boot signature


I tried the chain0 trick under Windows (so I would first select Windows from lilo then OSX from Win loader), but I get the chain error.

I tried to make hda4 bootable with fdisk but the problem remains.

What can I do without formatting Linux?

Link to comment
Share on other sites


  • Create New...