Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

10.6.8 on lenovo y560 0646-54U

14 posts in this topic

Recommended Posts

last updated: 2011-10-06 12:00 HST; Reasons: 1) updated instructions for WebCAM and USB printer(s) not working; 2) added link to Komano's EDID guide

Inspired by Tanja's request, I decided to open up a new topic for this specific y560 I set up as a h'tosh for a befriended couple, owing to the fact that there is a multitude of sub-models which make one guide not work for the other y560. Noted differences are:

  • WiFi cards (can easily be solved by swapping with a compatible card)
  • Graphics cards (only the 5370M, or the 5370M + a 2nd Intel grfx card. This tut offers 3 different solutions for y560s with one 5370M grfx chip)
  • LCD monitors (can be solved with different kext sets + potentially EDID injection)

This is a tut in progress - I will shift as much info from the links provided over in here asap. I just decided to get started knowing it will not be perfect right away - mods please bear with me.

The specific model this tut is mainly (but not exclusively) referring to is the 0646-54U here from NewEgg.. Here's the exact product configuration right from it's lenovo page. A bit more info incl. hardware IDs:

  • ATI Mobility Radeon HD 5730 (DEV ID 68C0 VEN ID 1002, SubSys 392717AA)
  • WLAN Atheros AR9285 802.11 B/G/N (DEV ID 002B, VEN ID 168C)
  • Sound Realtek (DEV ID 0272, VEN ID 10EC)

PLEASE compare with your specs so you know IN ADVANCE which components differ.


Sound, Wifi, Ethernet, Trackpad incl. 2 finger scrolling, Graphics with full resolution switching + QE/CI (hardware accelleration), optical drive, USB, Webcam, Battery Monitor. Via DSDT mod: function keys, native AppleIntelCPUPowermanagement, CPU C&P states if run as MacBookPro 6.1 (and a few more gimmicks)

This is totally not a Vanilla Laptop (apart from being able to use vanilla mach_kernel), it needs modded kexts for pretty much everything (apart from Webcam, which only requires a roll-back). Also feel free to use AnV's latest 10.6.8 legacy kernel - it runs well with this Laptop. If it runs better than vanilla mach_kernel is up to the people with Geekbench etc. to measure ..

Graphics on the 0646-54U also relies on a kext from Lion. Since Lion kexts were made for 64 bit I have experienced graphical glitches in 32 bit mode (the screen kinda "fizzes" ). Therefore I highly recommend 64 bit (which makes more sense anyway if you run more than 3GB RAM).

The trickiest proved to be the different LCD screens lenovo deployed in the y560 series. Some of them don't provide their available resolutions the way OS X requires it. Windows and Linux have a kind of query for that which Apple has not included in OS X. You should first try to get up 'n running as far as possible accdg.to vlad.s guide which also includes how to get the base install accomplished (which I will intentionally NOT cover here - there's already dozens of tuts out there for that purpose). He was using ##### 3.4: only MB 3.4 has the ATI drivers he mentions. Everything he mentions there works for the 0646-54U, apart from graphics (more below). The Atheros AR9285 802.11 B/G/N (DEV ID 002B, VEN ID 168C) is fully OS X compatible. Check in Windows if that's the one you have.

I compiled and uploaded a package which is much better organized than what vlad.s offered, via Mirrorcreator and Mirrorstack. To download choose the filehoster that works best for you. Install kexts with janek202's magical Kext Wizard. Again, my package should be considered not-final because it does not (yet) contain the chapter about graphics incl. EDID injection. That follows below.


If your y560 model differs from the 0646-54U, FIRST try vlad.s' approach WITHOUT EDID. I still suggest you download my recompile of his package (from above link) incl. the Chameleon bootloader with Azimutz' additions - he was so kind to add this specific y560's 5730m card's info to the official Chameleon trunk on 2011-08-29 20:53:39 - therefore the boot (2.1 r1472) is also much more current than checcco's personal (non-trunk) compile you might stumble across. The reason is that, if you rather have vlad.s' y560 graphics setup in your y560, you will get along WITHOUT a kext from Lion, which will spare you from KPs (kernel panics) each time OS X tries to deactivate the 5730 M (shutdown, restart, sleep), whereas - with only SL kexts in SL - your chances for smooth shutdowns and restarts are much higher ... More on the KPs below under "ERRORS AND POSSIBLE SOLUTIONS".

If you can't get res + QE/CI to work via vlad.s' guide (mind: a boot-loader with Kabyl's ATI framebuffer personality code is MANDATORY), it most likely means that EDID injection is required. Before applying any more kexts I think this should be the next step. The best guide for EDID retrieval and injection I have found is Komano's. If your y560 is also equipped with the LGD LP156WH3-TLQ1 HD G LED1 NB LCD, skip most steps and simply apply the content of attached 'lenovo y560 0646-54U DisplayVendorID-756e6b6e.zip' accdg. to the ReadMe in there. I recommend you use the Chameleon boot from my package, then reboot to see if it provided you with res switching + QE/CI.

If not, it's time for another grfx kext package. First try artur-pt's Ati Mobility Radeon HD 5xxx package. Dr. Jackson reported here that these kexts worked on his 06465CU (they are NOT sufficient on the 0646-54U). Reboot.

If still not QE/CI, try fayens' package compile for the Mobility HD5470 (scroll down a bit --> Main_pack.zip, 6.78MB). I CONFIRM THIS WORKING ON THE 0646-54U's Mobility 5370! As mentioned before, non-destructive KPs on shutdown/ restart/ sleep. Respective kext additions for that matter do NOT help ... Therefore DISABLE sleep in sys prefs.


It natively works with stock Apple kexts. Test by simply opening Photo Booth: after a few secs the tiny white LED for the cam should ignite, and you should see your gorgeous hackintosher's visage on your y560's screen ^^. BUT: after the complementary 10.6.8 update it suddenly STOPPED working (at least in Photo Booth). rossiluis22 (thanks for feed-back!) confirmed my assumption that - as little as I know about webcam stuff - they tend to be routed through the internal USB bus, so just rolling back the IOUSBFamily.kext by applying the IOUSBFamily.kext from the package to S/L/E restores WebCAM (and also USB printer) functionality! (I had backed up all my 10.6.8 kexts right after the regular 10.6.8 update and re-applied the entire kext backup from 10.6.8 from BEFORE the compl. update --> restart, it also worked again - sledge-hammer method .. ;))


  • at the beginning of booting, you get "Error - ATI card posted, reading VBIOS from Legacy Space": it means that you need to apply the correct bootloader (recommended Azimutz' from within my package).
  • KPs (kernel panics) on shutdown, restart, sleep: that's unavoidable for now, but nothing "destructive" (no data will have gotten lost and no file system damage can occur) since these KPs occur AFTER the line "It is now safe to turn off your Computer" (or similar). This must be a problem of the Snow Leo kernel not being able to completely unload the Lion ATISupport.kext, respectively some kext(s) the support kext loads and cannot unload because of the kernel/ kext OS version difference, so these KPs occur each time OS X tries to deactivate the 5730 M. Nothing at all to worry about, just a bit annoying.
  • Q: "My USB printer does not work, even though I have the latest driver for it straight from the model's page on the manufacturer's web-site installed!" --> A: "Apply IOUSBFamily.kext from the package to S/L/E (with Kext Wizard or similar)"

OK it seems that's it for now. I'll probably fine-tune this guide and would also enjoy feedback incl. hints towards improvement or additions.

Good luck,


- kexts: vlad.s --> http://www.hackint0sh.org/f181/263607.htm (your specific y560 might require graphics kexts different from the ones in ##### 3.4 vlad.s uses)

- boot: Chameleon 2.1svn r1472 (Azimutz added this specific y560's 5730m card info to the official Chameleon trunk on 2011-08-29 20:53:39 --> http://forge.voodooprojects.org/p/chameleo...rce/commit/1472)

- DSDT: MaLd0n --> http://goo.gl/aIJ5p / http://goo.gl/aIJ5p
applied patches:
ADD Notify (\_SB.PWRB, 0x02) in _L METHODS


Lion compatibility looks pretty good. I had no time to test it myself on the y560 0646-54U, which is now "on-the-road" together with my friends = out of reach for a couple of months. However vlad.s wrote to me that he "managed to get a full working Lion with QE/CI", only with graphics problems "when waking up/ coming out of stand-by such as distorted colors". That's a step further than SL :) (at least on his revision of the y560...)


Share this post

Link to post
Share on other sites



First time and after many trys, I see 1366x768 resolution (I think im used to this streced thing over the trys... I have to get used to the real one ;-) ) and transperency... Sound is working!!!




Will make further tests and use MacOSX, now its useable....


Will post more results later here...


Thank you!

Share this post

Link to post
Share on other sites

great, and thanks for the feedback - so the guide's worth it ;)


Do you know which exact model you have? Would you be so kind and post the link you bought it from? And if possible the link to the model's product configuration page @ http://consumersupport.lenovo.com?

Share this post

Link to post
Share on other sites

This was helpful but I haven't quite got there yet.


I got Snow Leopard installed and updated, everything working (except wifi), but I have tried everything in this list and still running into problems with the ATI 5730: the system crashes/fail to boot if the GraphicsEnabler=Yes.


On bootup the specific error it reports in -v mode is 'ATI card POSTed, reading VBIOS from legacy space'


Right now I would be happy just to see the screen at 1366x768 even without the Q/E etc. When GraphicsEnabler=No the max is 1024x768.

Share this post

Link to post
Share on other sites

Hi, first thanx for the tutorial, i already installed osx 10.6.8 on my lenovo y560 0646-CS20 , it working fine but i'm getting trouble with the printers it doesn´t recognize the printer ( doesn't appears in the printers menu) i don't know if you can help me about that. and if you can post the kexts for the webcam


P.S: The printer model is HP PSC 1315



Sorry about my english. i'm from venezuela

Share this post

Link to post
Share on other sites

@ combo9: wrong bootloader, and/or wrong fb personality in your boot.plist


@ rossiluis22

re. printer: wrong thread (honestly) - go to hp.com and see if there IS a driver for Mac OS X 10.6.x at all for that model ...

re. webcam: like I wrote I don't know - try applying the IOUSBFamily.kext from my package (based on vlad.s') to S/L/E.

Share this post

Link to post
Share on other sites
thanks! my lenovo y560 it is working fine! all usb, sound, wifi, camera, mouse
you stated before you have the 0646-CS20 model. Did your web-cam stop working after applying all updates in 10.6.8, and if so, did you restore it other than with a complete kext restore like I did? I'd like to know which exact kext(s) is required (if it's really the IOUSB, or not, or more) ..

Share this post

Link to post
Share on other sites

I just applied the IOUSBFamily.kext from the package (based on vlad.s') to S/L/E. and it works for the printer trouble and for the webcam. because when i updated to 10.6.8 my webcam did not work

Share this post

Link to post
Share on other sites

Hi. Merry Christmas!


I managed to install Lion 10.7.2 but I have the strangest issue. I get a Kernel Panic whenever I start stressing the HDD like multiple downloads, watching a HD movie and so on. Does anyone out there have this kind of problems like I do? Or an answer?

Share this post

Link to post
Share on other sites

ah, hackint0sh grandmaster vlad.s' 1st posting .. now you're not an insanely-virgin anymore ;)


I never installed Lion on my friends' y560. If I were you I'd back up all XTs then apply all XTs you backed up from the prior 10.7.1 (or 0) install.


Also you could try run a Lion legacy kernel.


Keeps us posted :)

Share this post

Link to post
Share on other sites

I'm happy to see that Vlad.s tutorial was expanded upon. Got everything but graphics(basic, no QE/CI and had started EDID injection) following his guide many months ago but have since erased that partition. I'm excited to try again with the new guide, especially since this is my exact model number, but the package is down at all the links on the multiupload site. Any chance anyone could repost it?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.