Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
Weishauptus

Low CPU performance with Native Speedstepping

Recommended Posts

Hey guys,

 

after tinkering for ages with my DSDT and overall setup,

i think i have gotten native speedstepping to work (judging by the temperatures).

 

however, my cinebench scores are far lower than within windows, which did not

use to be the case. (osx scores used to exceed windows scores).

it might correlate with a hardware change, a new radeon 5850, but it think

its more of a speedstep issue. I am really lost here, perhaps someone can

point me in the right direction?

 

ah and cpu-x by the way, is reporting 3ghz all the time (max speed of my q6600).

mobo: ga-ep45-ds3

 

send_me.zip

Share this post


Link to post
Share on other sites
Advertisement

your smbios.plist has wrong info

dmi.bios.date: 02/29/08
 dmi.bios.vendor: Apple Inc.
 dmi.bios.version: MP31.88Z.006C.B05.0802291410
 dmi.board.asset.tag: Base Board Asset Tag#
 dmi.board.name: Mac-F42C88C8
 dmi.board.vendor: Apple Inc.
 dmi.board.version: Proto1
 dmi.chassis.asset.tag: Asset Tag#
 dmi.chassis.type: 2
 dmi.chassis.vendor: Apple Inc.
 dmi.chassis.version: Mac-F42C88C8
 dmi.modalias: dmi:bvnAppleInc.:bvrMP31.88Z.006C.B05.0802291410:bd02/29/08:svnAppleInc.:pnMacPro3,1:pvr1.0:rvnAppleInc.:rnMac-F42C88C8:rvrProto1:cvnAppleInc.:ct2:cvrMac-F42C88C8:
 dmi.product.name: MacPro3,1
 dmi.product.version: 1.0
 dmi.sys.vendor: Apple Inc.

not sure if this could be an issue but this Mac-F42C88C8 doesnt belong to MP31.88Z.00C1.B00.080209154

 

and it sees this in the ioreg

Gigabyte Technology Co. so i bet stuff is wrong or mising in smbios.plist.

 

in bios disable Lpt com1,2 uneeded stuff. u can remove from dsdt with help.

 

oohh wow u using old outdated stuff.

es_osx86_EvOreboot lol..chameleon2 rc5 has RestartFix

Share this post


Link to post
Share on other sites

hey LatinMcG,

 

thanks for checking out my stuff.

Yeah I dont really remember but i think i had a lot of KPs without evoreboot, not sure though and I will definitely test it ^^

LPT/COM and alike are already disabled in the BIOS, anything else i can do to edit them out of the DSDT? Do you know if the restartfix is also included in the bootfile by Kabyl? And what exactly can I do to match the chassis version to the alias as you proposed?

 

My knowledge of hackintoshes was on the steep decline as i bought the 5850 radeon without any option to really use it, so i took a far too long break from all that stuff, not backing up my DSDTs from earlier builds.

 

Funny enough, the Speedstep issue does not seem to be one: As I already mentioned the temps were rather fine and corresponded to what i had seen in Windows - Cinebench seemed to be off. I tried rendering using the regular cinema 4D and meassured the time taken to render specific example scenes and compared them to my results within windows... lo and behold: the results are exactly the same. Ergo, my system is performing more or less as it should, yaaay :( of course OpenGL performance is terrible but i guess that can't really be helped for now (QE/CI are enabled).

Share this post


Link to post
Share on other sites

rc5 has restart fix from any branch.

im not sure if ati can be part of issue.. also have u tried getting a fresh untouched dsdt and using auto-patcher ? bios version ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×