Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
me & me

[RISOLTO] Installazione Lion su HPdv6790el

12 posts in this topic

Recommended Posts

ciao,

è la prima volta che posto , non vorrei fare errori

ho un HP pavilion dv6790el (hardware in firma ) con installato snow leopard 10.6.8 ( iAtkos s3) , con HD partizionato in MBR . vorrei installare lino , ma richiede partizioni GUID , volevo allora esporvi una possibile soluzione che mi è venuta in mente , per sapere se secondo voi , più esperti di me , andava o c'era qualche intoppo che ignoro : premetto che ho l'app di lion e ho già provato a cambiare OSinstall per installare su MBR , ma mi dice che l'applicazione è danneggiata , volendo ho anche un HD esterno formattato in GUID , ma stranamente all'avvio non lo rileva . dovrei aver detto tutto , quindi se :

-partendo con il disco di iAtkos formatto il mio HD in guid con due partizioni

-installo snow leopard su una dellle due

-all'avvio aggiorno chameleon ad RC5 per lion

-avvio l'app di lion

-installo lion sulla partizione vuota

-riavvio

seguendo questi passaggi potrei far partire lion , o serve qualche altra modifica pre installazione ?

 

ho questo dubbio che mi affligge , voi dite che va o devo aspettare che esca una distro di Lion ?

 

ciao e grazie in anticipo

Share this post


Link to post
Share on other sites

Ti stai complicando di brutto la vita. Installare Lion dal file .app non è possibile su di un hackintosh

 

Le modifiche per installarlo su MBR funzionano benissimo (io ad esempio lo uso sul mio notebook in MBR)

 

Segui la guida che c'è nella mia firma, è spiegato come modificarle Lion per installarlo su MBR

Share this post


Link to post
Share on other sites
Ti stai complicando di brutto la vita. Installare Lion dal file .app non è possibile su di un hackintosh

 

Le modifiche per installarlo su MBR funzionano benissimo (io ad esempio lo uso sul mio notebook in MBR)

 

Segui la guida che c'è nella mia firma, è spiegato come modificarle Lion per installarlo su MBR

 

io ho usato la tua guida solo che quando avvio l'app da USB mi dice che è danneggiata ( falso perchè modificando l'OSinstall al file ESD , non ricordo bene il nome , funzionava e mi lasciava anche installare su GUID , mentre l'app senza modifiche mi dava l'errore "impossibile installare su questo computer") . poi come scritto nel mio primo post , all'avvio non mi riconosce USB alcuna , quindi per me sarebbe inutile preparare un Lion bootable da USB. servirebbe invece da dischetto.

mi sapresti dire come preparare un disco avviabile del setup di lion ? ci ho provato ma ho avuto un KP.

comunque il mio procedimento sarebbe corretto o avrò un KP anche lì ?

 

grazie comunque per la risposta ;)

Share this post


Link to post
Share on other sites

L'errore di installer danneggiato lo da anche in Snow Leopard quando si applica in maniera errata la modifica per installare su MBR. Se puoi sostituisci OSInstall col terminale, ridurrai le probabilità di incappare in quell'errore.

 

ciao!

Share this post


Link to post
Share on other sites
L'errore di installer danneggiato lo da anche in Snow Leopard quando si applica in maniera errata la modifica per installare su MBR. Se puoi sostituisci OSInstall col terminale, ridurrai le probabilità di incappare in quell'errore.

 

ciao!

 

qual'è il comando che devo mettere per copiarlo ? non sono molto esperto di terminale :(

 

grazie :D

Share this post


Link to post
Share on other sites

ok ho appurato che il procedimento da me elencato nel primo post non è corretto . ora ho segiuto diverse guide ma all'avvio rimango sempre bloccato a [ PCI Configuration begin ] e poi , aspettando anche molto tempo , non va più avanti . ho provato con le varie kernel flag che lo fixano ma nulla .

se c'è qualcuno che può aiutarmi , per piacere .... :D

Share this post


Link to post
Share on other sites

Problema discusso centinaia di volte, bastava una ricerca. Devi solo sostituire i 2 kext AppleACPIPlatform e IOPCIFamily di snow 10.6.7

Share this post


Link to post
Share on other sites
Problema discusso centinaia di volte, bastava una ricerca. Devi solo sostituire i 2 kext AppleACPIPlatform e IOPCIFamily di snow 10.6.7

 

si lo so , è che il problema me lo ha dato dopo che avevo iniziato il thread , prima non sapevo che il problema si sarebbe presentato . quindi , devo sostituire quei due kexts di lion con quelli di snow 10.6.7 . ora provo :withstupid:

 

[EDIT]ora all'avvio mi dà all'infinito l'errore err=0x0012 kBluetoothHCIErrorInvalidHCICommandParameters , c'è una scritta più lunga ma credo che l'errore sia in sostanza questo , ho provato a cancellare i kext riguardanti il bluetooth , ho provato a sostituirli con quelli di snow ma in quel caso mi si ferma a DSMos has arrived , che fare ?

Share this post


Link to post
Share on other sites

Ora devi solo ricostruire la cache. Lo puoi fare dal dvd di installazione, o dalla usb se hai installato da usb

kextcache -v 1 -a i386 -a x86_64 -m /Volumes/TUO_HDD_OSX/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext  /Volumes/TUO_HDD_OSX/System/Library/Extensions

Share this post


Link to post
Share on other sites
Ora devi solo ricostruire la cache. Lo puoi fare dal dvd di installazione, o dalla usb se hai installato da usb

kextcache -v 1 -a i386 -a x86_64 -m /Volumes/TUO_HDD_OSX/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext  /Volumes/TUO_HDD_OSX/System/Library/Extensions

 

allora ho installato lion e ora parte regolarmente !! grazie fiox89 sei un mito!!!

ora però un'ultima cosa , siccome ho acquistato di recente un sony vaio vpccw1 (l'hardware è nella firma , se si è aggiornata) e ci ho installato in dual boot lion e snow leopard , ma non sono riuscito a trovare nè kexts scheda video , nè ethernet , nè wi-fi nientemeno . sono io che non ci capisco tanto su kext.com o proprio non ci sono ?? inoltre nè su lion , nè su snow mi funziona "informazioni su questo mac " se ci clicco mi fa un logout, c'è un fix anche per questo ?

Share this post


Link to post
Share on other sites

Sono contento che abbia funzionanto, però per il resto delle domande siamo OT.

Perfeziona prima un hack, poi se hai domane inerenti l'altro laptop, apri un topic apposta

 

Ciao

 

p.s. metti risolto al topic

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×