Jump to content
Kafluke

Dell Precision 670 -=Solved=-

36 posts in this topic

Recommended Posts

I have been at this for days. I know that this system can run a one of these OSX86 distros and run it well. I just keep having problems getting the dang thing to work. The only distro I can get to work is iDeneb 1.3 and I think that is pretty old.

 

I've tried many many more and every time they finish installing I get a boot loop.

 

What I'd like to be able to do is install the retail disc I have of snow leopard. I don't know if that's possible though. I don't understand the difference between chameleon boot and boot-123.

 

When I finished a good install of iDeneb 1.3 the network card didn't work and someone told me that an updated version of iDeneb has the drivers for my network card. I can't get 1.5 or 1.6 lite to work though. They all just get stuck in a boot loop.

 

If there is anyone that has had success with these dual xeon dell precision 670 systems and ANY recent distro or build of OSX86 please share with me the details of a proper install so I can get going on this thing. Thanks

 

-Kafluke

 

I found nawcom and booted with that. All default settings. It worked perfectly with my retail store bought copy of Snow Leopard!

Share this post


Link to post
Share on other sites
Advertisement
I found nawcom and booted with that. All default settings. It worked perfectly with my retail store bought copy of Snow Leopard!

 

Now if I could just figure out how to get the network card to work.

Share this post


Link to post
Share on other sites

And get some accellerated graphics action. I've seen snow leopard running on macs and they are much nicer looking than what I got going on (and its not just resolutions). I'm talking animated app tray at the bottom etc.

Share this post


Link to post
Share on other sites

Same here. I also gave that box a try last summer with Nawcom ModCD + Retail SL 10.6.3. Went straight in.

My specs are:

  • 2 single-core 64bit Xeon 3.8GHz (Irwindale)
  • Intel E7525 chipset (ICH5)
  • 320Go SATA + 160GO SCSI + 40Go IDE
  • Adaptec AIC-7901 Ultra320 integrated RAID SCSI controller (unsupported)
  • 4Go DDR2-400 ECC RAM
  • nVIDIA Quadro FX1400, dual DVI (with dual screen)
  • SoundMAX/AC'97 integrated audio
  • Intel Pro/1000 MT integrated Ethernet

 

Still a good Workstation and it does run well under SL albeit with unaccelerated graphics and no network capability. I guess, it's a simple matter of replacing the existing graphics card by a compatible/supported model and adding a compatible Wireless USB/PCI adapter.

Share this post


Link to post
Share on other sites

'never updated this old thread after my hardware update many moons ago...
 
I had replaced my original Nawcom's ModCD installation with a myHack installation and made up a bootpack. It's been running 10.6.8 pretty well. I eventually replaced the unsupported Quadro FX1400 card with a supported GeForce 9800GT (a dual-DVI+HDTV Twintech model with 512Mo DDR3) obtained for pennies. Initially this required an enabler kext (NVEnabler64) to work OOB until I finally extracted the DSDT table to patch it and found out I had to set PCI root to 4 (an absolute must or DSDT injection remains ineffective). The alternative to that can be to set PCI root UID to 0 in the DSDT (at the beginning of Device (PCI0) section) so that default PCI root 0 can be used. Such a change is without adverse affects.
 
SpeedStep appears to be kind of working thanks to Kozlek's recent FakeSMC/HWMonitor package (although I only ever see 2 states at 2.8GHz and 3.8GHz, i.e. min and max). I guess, it's hard to get proper CPU power management on an AMD/legacy kernel. Built-in Ethernet finally got to work with an older 32bit-only AppleIntel8254XEthernet kext v1.1.2 (from Tiger?). Full details on this are available here. I also patched the DSDT to add some info about the Ethernet so that it's reported in System Profiler as per information found in attached IOReg file. A Tenda W522U (Ralink chip) 802.11n USB dongle gives me good wireless connectivity.

System can run in 32bit or 64bit kernel mode, but audio does not work in 64bit mode for some unknown reason. Calling on audio in 64bit kernel mode can actually make the system crash with some audio garbage noise. At some point, I did manage to get it stable in 64bit mode with npci set to 0x2000 or 0x3000 but then no sound ever came out although audio hardware was detected Ok and kexts loaded.

post-851564-0-17177500-1390405365_thumb.jpg

 

The only thing that probably still requires a DSDT patch to work is Sleep.
 

---------

EDIT - 15Jan2015 :

It's actually a bad idea to modify DSDT for Firewire as that proves to break Sleep! See posts below...

Share this post


Link to post
Share on other sites

Dear Hervé,

  1. Why you moved from Nawcom's ModCD method to myHack?
  2. Exactly, which kernel you're using?
  3. Could you write some basic guide for 670 myHack installation?

 

Thanks :)

 

Share this post


Link to post
Share on other sites

I'm using Nawcom's legacy 10.6.8 kernel, i.e. Darwin_10.8.0 (v2). Initially, I installed retail SL 10.6.3 with Nawcom's legacy 10.6.3 kernel (Darwin_10.3.0), then ran combo update 10.6.8 + replaced legacy kernel Darwin_10.3.0 by Darwin_10.8.0.

 

I switched to myHack because that is what we use and advocate at OSXLatitude across the board. myHack offers the ability to add new kexts or supersede vanilla kexts in a very easy and clever way that leaves /S/L/E folder totally unmodified. It also automatically repairs permissions and rebuilds kext cache. You can find a guide I made some time ago here.
 
In the case of your ModCD installation, once you replace the vanilla AppleIntel8254XEthernet kext by the older version, you have to manually repair permissions, then rebuild your cache for the change to be effective. To do that, open up a Terminal window and type:
sudo chmod -R 755 /System/Library/Extensions
sudo chown -R 0:0 /System/Library/Extensions
sudo touch /System/Library/Extensions
 
Then reboot.
 
The alternative is to remove the vanilla AppleIntel8254XEthernet plugin kext from the IONetworking kext in /S/L/E, then use a tool like Kext Wizard to install the older kext in /S/L/E and repair permissions + rebuild cache before you reboot.

post-851564-0-29001700-1388465207_thumb.jpg post-851564-0-67334800-1388465218_thumb.jpg

Share this post


Link to post
Share on other sites

I've combined boot option arch=i386 with -force64 in order to boot SL in 32bit kernel mode but be able to run some apps (HWMonitor, PlistEditorPro, etc.) in 64bit mode in user space. They would not run otherwise.

 

On the benchmarking side, the workstation rates decently for its age & specs:

post-851564-0-33847100-1388869245_thumb.jpg

 

Now if only there was a legacy Lion kernel that would support that machine, things would be even greater.

Share this post


Link to post
Share on other sites

Following DSDT patching detailed here + use of SleepEnabler to enable Sleep & Wake functionalities, here are revised bootpacks, IOReg output and final DSDT table:
WS670_Bootpack_SL10.6.3.zip WS670_IOReg(v2.0b1).ioreg.zip Patched_dsdt.aml.zip

And here are the changes to apply to the 10.6.3 pack for a 10.6.8 installation + my own (tuned) final setup:
WS670_Bootpack_SL10.6.8.zip WS670_final_10.6.8_setup_with_GeForce9800GT.zip

 

That Precision 670 is now 100% functional under Snow Leopard 10.6.8:thumbsup_anim:

Share this post


Link to post
Share on other sites

A behaviour change with recent Chameleon trunk versions (post r2290) highlighted a small defect in the boot plist settings provided in above pack and the kernel handling. I have set boot option UseKernelCache to Yes and refer specifically to the legacy kernel, not to standard/vanilla mach kernel.
 
This leads to the generation of an incorrect kernel cache as, by default, cache is built with vanilla mach_kernel. Leaving such kernel unchanged at root level therefore leads to a kernel cache that is incompatible with legacy kernel and which causes a system reset/boot loop when loaded, unless the cache is built with option -K <legacy kernel filename> (or -kernel ...). This was not an issue up to Chameleon r229x because these versions would ignore kernel cache when non-standard mach kernels were used. I've come to realise this changed with post-r229x Chameleon trunk versions and kernel cache will be loaded whatever the kernel.
 
To fix this, proceed as follows:

  • at HDD root level, rename mach_kernel file to something else such as mach_kernel_bak (or remove entirely)
  • at HDD root level, rename legacy kernel Darwin_10.8.0 (or whatever name the legacy kernel bears) to mach_kernel
  • using Chameleon Wizard, uncheck Kernel case in the boot plist or replace the named Darwin kernel by mach_kernel

The result is that kernel cache will no longer be built on original/vanilla mach kernel but actually on the now-renamed legacy kernel. Any cache refresh/rebuild made manually, through myHack or any other tool will subsequently be totally safe to load.

Share this post


Link to post
Share on other sites

Having upgraded to 2 x Paxville DP dual-core Xeon (those need the XC837 motherboard), I was able to install Lion with Bronya's 10.7 RC13 AMD kernel (vanilla kernel remaining unsupported). It doesn't like native CPU power management at the moment, but is totally stable with NullCPUPowerManagement though. Despite this, I'm still seeing some speed-stepping using Kozlek's FakeSMC. Can't get sleep to work properly under Lion for the moment (neither natively, nor with SleepEnabler).

 

post-851564-0-03219800-1392604883_thumb.jpg post-851564-0-24684200-1420141614_thumb.jpg

 

Apart from Sleep, everything working perfectly in 32bit mode (including LAN and audio). No LAN and buggy audio in 64bit mode.

Share this post


Link to post
Share on other sites

Keeping on the momentum, I turned my eyes to ML and got it installed with Bronya's 10.8 RC5 AMD kernel (vanilla ML kernel appeared unsupported too). 64bit kernel mode means no support for LAN, AC'97 audio is buggy (getting is bad hissing sound with every audio output) but getting full QE/CI. Still needing NullCPUPowerManagement kext. Sleep & wake working just fine natively.

 

post-851564-0-68824100-1392723621_thumb.jpg

post-851564-0-33826200-1392712409_thumb.jpg

 

Good omen for a potential success with Mavericks now!

Share this post


Link to post
Share on other sites

And looking pretty much Ok with Mavericks 10.9.1 using Bronya's 10.9 RC7 AMD kernel. Getting full QE/CI but noticed some tiny graphics corruption around names of Desktop items... 64bit AC'97 audio remains buggy as hell. NullCPUPowerManagement kext required as per previous Lion and ML installations. Sleep & wake working Ok natively as per ML.

 

post-851564-0-70534800-1392823923_thumb.jpg

 

Edit: I had 3 typos in my DSDT patch for the GeForce 9800GT; this prevented native graphics support and forced me to revert to NVEnabler64 to get graphics to load. Once typos were fixed, NVEnabler was no longer required and those little graphics defects on desktop disappeared.

Share this post


Link to post
Share on other sites

Thanks to Slice and ErmaC, Chameleon can now properly inject proper Xeon CPU information to the OS; the mod was provided in draft/temp r2378.
post-851564-0-65231400-1394642553_thumb.jpg

Share this post


Link to post
Share on other sites

Sticking with current official Chameleon versions (latest being r2377 at time of writing), an alternative is to add option SMoemcputype=1026 to the SMBios plist file:

[...]
        <key>SMoemcputype</key>
        <string>1026</string>
[...]

Share this post


Link to post
Share on other sites

Bronya's latest 10.9.2 RC5/RC6/RC6_fix kernels do allow to update/install 10.9.2 and 10.9.3, but I'm experiencing trouble with graphics acceleration with my nVidia cards (GeForce 9800GT and/or GeForce GT610). That's an issue I was not experiencing with previous Mavericks versions or previous OS X releases, so it's work in progress...

post-851564-0-26765700-1401485998_thumb.png

 

For Spakk:

Precision670_extracted_dsdt.aml.zip Precision670_extracted_dsdt.dsl.zip Precision670_IOReg.zip Precision670_SysProfiler.zip

 

IOReg dump taken with IORegistryExplorer v3.0.2 and raw DSDT extracted with Chameleon Wizard, having booted without any DSDT file.

 

Thank you!

Share this post


Link to post
Share on other sites

Following axmanA's research, graphics issues encountered since 10.9.2 are now sorted. The Precision 670 with GeForce 9800GT can now run 10.9.2/10.9.3/10.9.4 with Bronya's 10.9.2 RC5/RC6/RC6 fix/RC7 kernel with full (non-lagging) QE/CI if kexts IOPCIFamily + AppleACPIPlatform are replaced by versions from 10.9.1 or IOPCIFamily patched version from axmanA is used (I sticked to 1st option).
 
All running well, but there are small graphics defects like picture corruption when doing screen dumps, but that has been reported by other AMD kernel users too, so it's not specific to the Dell Precision 670 system. Other than that, everything looks perfect so far.  :thumbsup_anim:

 

post-851564-0-81584500-1404654687_thumb.jpg

post-851564-0-62278100-1404654719_thumb.jpg

 

10.9.1_IOPCIFamily.kext.zip 10.9.1_AppleACPIPlatform.kext.zip

 

Reverting to those 10.9.1 kexts also restores the ability to boot Mavericks on the Precision 670 off a USB external HDD. This was also lost from 10.9.2...

Share this post


Link to post
Share on other sites

Was running RC7, but experienced out the odd sudden system freeze when starting Skype. Reverted to RC6_fix (for old CPUs) and the freeze does not happen, so sticking to that. Need to recheck Sleep & Wake though...

Share this post


Link to post
Share on other sites

RC5 gives me occasional small graphics artefacts, so I dismissed that one.

RC6 and RC6_fix run Ok, but I cannot get screen to wake after sleep. Screen stays off for some reason.

RC7 runs Ok and properly wakes system from sleep. 

Share this post


Link to post
Share on other sites

Up to 10.9.5 now. This new update proved a bit problematic at the onset (it would not boot to OS X desktop) and subsequently required rolling back IOHIDFamily kext from 10.9.4 (v2.0.0 - 503.200.2) to complete startup. A better alternative is to rollback IOHIDFamily + Sandbox + System kexts from 10.9.1 as that also avoids all kernel symbols related error messages during startup and subsequent system problems.

 

Naturally, I kept the rollback to 10.9.1's AppleACPIPlatform + IOPCIFamily kexts to retain 9800GT graphics support.

 

Can run using same AMD kernels from Bronya, namely 10.9.2 RC7 (old) + 10.9.4 RC1/RC2 or BSA 10.9.5 kernel.

 

post-851564-0-65322600-1411220867_thumb.jpg

 

BSA_AMD_10.9.5.zip 10.9.4_IOHIDFamily.kext.zip 10.9.1_rollback.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×