Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Dell precision 690 DSDT help

10 posts in this topic

Recommended Posts

hi,i have successfully install iatkos s3 on my DELL i have use this dsdt





from here:



i have the same chipset and sata controller with T5400,without dsdt im getting still waitting for root device

but my problem is my vga :( its not working

if i boot with iatkos without dsdt,on verbose mode i can see my vga is recognised with nvenabler64,but cant install because no harddisk detection,with dsdt of t5400 no vga showing on verbose mode setup,and of course after setup :(


my vga is

NVIDIA Quadro FX 3450/4000 SDI

with nvcap



please help :/

Share this post

Link to post
Share on other sites

i do it,works pefect! BUT! if you place the DSDT with ACHI mode on bios works pefect! without enable SAS controller!

the problem its with my vga not with dsdt,i have install nvidia 8400gs MSI and works peftect with EFIStudio 1.0

Share this post

Link to post
Share on other sites

well I am trying to install from an original snow leopard version and I could see the sata drive only time I can't see it is when I tried iatkos s3 version 2. but I am still running into problems with the original version, cuase once I finish the installation everything since good, but I can't booth directly from the drive I have to keep using the legacy [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or Nawcom cd. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] won't work, so I need help or guide on how to install snow leopard on this system.

Share this post

Link to post
Share on other sites

a FINAL WORKING sollution for all of us!!!

just install the latest bios...

and download the iatkos l1 or l2

for graphics install it with efi

and for LAN you can find broadcom drivers from lan section

(if someone cant find them pm me..)the kext needs edit to add device id

for sound i have use voodooHDA but im using a creative audigy2 for audio card because the onboard have only line in/out not the mic is not working on the back(working perfect on the front mic-in)

NO DSDT needed,NO Kernel Needed

i can install updates like official on my machine...! i have install 10.7.2 via system update without any modification of kext! all works perfect!!!

except icloud/appstore/facetime :/ if someone have fix it pm me!!


when i fix icloud i will make a guide for the forum with all working kexts

Share this post

Link to post
Share on other sites

I have stable running 10.7.5 on my Dell Precision 690 with old BIOS A03.

So BIOS update is not mandatory...i think.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies