Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
pexta

[Risolto] Installare Radeonmonitor Plug-in per fakesmc.kext

11 posts in this topic

Recommended Posts

Salve a tutti! Ho scaricato da un forum (mi sa che non posso postare l'url) il plug-in Radeonmonitor.kext, l'ho inserito nella cartella Extra/Extensions, riparo i permessi... et voilà! Non vedo la temperatura della Gpu nè su IstatPro nè su Temperature Monitor! Ho sbagliato a posizionare il Kext? Considendo che sto usando il bootloader di Kabyl devo compilare in qualche modo l'info.plist del plug-in? . Questa è la versione del plug-in:RadeonMonitor.kext_rev495

 

Edit: Se può essere utile questo è cio che ho trovato nel kernel log:

Kext org.slice.RadeonMonitor - library kext org.netkas.FakeSMC not found.
 Jun 30 10:52:44 localhost kernel[0]: Can't load kext org.slice.RadeonMonitor - failed to resolve library dependencies.
 Jun 30 10:52:44 localhost kernel[0]: Kext org.slice.RadeonMonitor failed to load (0xdc00800e).
 Jun 30 10:52:44 localhost kernel[0]: Failed to load kext org.slice.RadeonMonitor (error 0xdc00800e).
 Jun 30 10:52:44 localhost kernel[0]: Couldn't alloc class "RadeonMonitor"

Grazie in anticipo

Share this post


Link to post
Share on other sites

Up

Edit: Ho provato diversi fakesmc.kext e diverse revisioni del fantomatico plugin Radeonmonitor.kext ma nei casi migliori non funziona, nei peggiori ottengo KernelPanic. Quindi vi posso solo dire che la forza bruta in questi casi non funziona! :(

 

Edit: questo è il Kernel Panic:

post-702427-1309681447_thumb.jpg

Share this post


Link to post
Share on other sites

Ho risolto installando contemporaneamente i plugin/kext: intelcpumonitor.kext, intelthermal.kext, radeonmonitor.kext e superiofamily.kext (oltre al fakesmc.kext ovviamente) tutto in Extra/Extensions. :D

 

Edit: Al secondo riavvio ho ottenuto di nuovo Kernel panic. Ho dovuto eliminare il plugin superiofamily.kext (non trovava alcun chip supportato) avviando con -s, quindi adesso visualizzo le temperature della Cpu e della Gpu. Niente temperature Northbridge e Ambiente (Al primo avvio c'erano, ma non posso affermare che erano affidabili), ma questa è un altra storia.

 

Share this post


Link to post
Share on other sites

Il superiofamily all'interno ha 4 plugins, con ogni probabilità uno di questi è quello adatto al tuo sistema, dai log forse puoi capire quale ti serve, ed eliminare gli altri 3 :P

Share this post


Link to post
Share on other sites
Il superiofamily all'interno ha 4 plugins, con ogni probabilità uno di questi è quello adatto al tuo sistema, dai log forse puoi capire quale ti serve, ed eliminare gli altri 3 ;)

 

Ciao fiox89 e grazie della risposta! Nel log ho trovato il messaggio: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13 (quindi immagino sia quello da eliminare) ma nessuna traccia degli altri due.

</b>Jul  6 01:34:15 localhost kernel[0]: ting
 Jul  6 01:34:15 localhost kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:15 localhost kernel[0]: AppleIntelCPUPowerManagementClient: ready
 Jul  6 01:34:15 localhost kernel[0]: Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/Hitachi HDT721010SLA360 Media/IOGUIDPartitionScheme/Snow Leopard@2
 Jul  6 01:34:15 localhost kernel[0]: BSD root: disk0s2, major 14, minor 2
 Jul  6 01:34:15 localhost kernel[0]: Kernel is LP64
 Jul  6 01:34:15 localhost kernel[0]: USBMSC Identifier (non-unique): 058F63646476 0x58f 0x6364 0x100
 Jul  6 01:34:18 localhost kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:18 localhost kernel[0]: Waiting for DSMOS...
 Jul  6 01:34:18 localhost kernel[0]: systemShutdown false
 Jul  6 01:34:19 localhost kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:22 Mac-Pro-di-Pexta kernel[0]: Previous Shutdown Cause: 3
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: DSMOS has arrived
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: AppleRTL8169Ethernet: Ethernet address 20:cf:30:4c:23:73
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: ** Device in slot: SLOT--1 **
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:25: --- last message repeated 1 time ---
 Jul  6 01:34:25 Mac-Pro-di-Pexta kernel[0]: AppleTyMCEDriver::start coreVIDPID = 0xffffffff Number of packages = 1 Number of cpus = 8 memory monitor trough MCA
 Jul  6 01:34:26 Mac-Pro-di-Pexta kernel[0]: F718x: Fintek: Found unsupported chip ID=0xa5 REVISION=0x13
 Jul  6 01:34:29: --- last message repeated 4 times ---
 Jul  6 01:34:29 Mac-Pro-di-Pexta kernel[0]: Sound assertion "0 != result" failed in AppleHDAWidget at line 3866 goto handler
 Jul  6 01:34:29 Mac-Pro-di-Pexta kernel[0]: Sound assertion "0 != widget->setUnsolicited ( true )" failed in AppleHDACodecGeneric at line 1153 goto handler
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check or Length Not Match.
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Length Check - msglength = 3152, expectingLength = 3152
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check - msg(0.0.0)@0xffffff80101c4030 atifb:(3.1.0)
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check or Length Not Match.
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Length Check - msglength = 3152, expectingLength = 3152
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check - msg(0.0.0)@0xffffff80101c1030 atifb:(3.1.0)
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check or Length Not Match.
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Length Check - msglength = 3152, expectingLength = 3152
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check - msg(0.0.0)@0xffffff80101c2030 atifb:(3.1.0)
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check or Length Not Match.
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Length Check - msglength = 3152, expectingLength = 3152
 Jul  6 01:34:50 Mac-Pro-di-Pexta kernel[0]: Message Version Check - msg(0.0.0)@0xffffff80101c3030 atifb:(3.1.0)
 Jul  6 02:14:17 Mac-Pro-di-Pexta kernel[0]: systemShutdown true
 Jul  6 02:14:18: --- last message repeated 1 time ---
 Jul  6 02:14:18 Mac-Pro-di-Pexta kernel[0]: Kext loading now disabled.
 Jul  6 02:14:18 Mac-Pro-di-Pexta kernel[0]: Kext unloading now disabled.
 Jul  6 02:14:18 Mac-Pro-di-Pexta kernel[0]: Kext autounloading now disabled.
 Jul  6 02:14:18 Mac-Pro-di-Pexta kernel[0]: Kernel requests now disabled.<b>

Share this post


Link to post
Share on other sites

Se dice unsupported chip non credo ci sia molto da fare, puoi provare a fare qualche ricerca ma se non carica correttamente nessuno dei 4 plugins..beh..ci saranno da fare delle modifiche al kext nella migliore delle ipotesi

Share this post


Link to post
Share on other sites
Se dice unsupported chip non credo ci sia molto da fare, puoi provare a fare qualche ricerca ma se non carica correttamente nessuno dei 4 plugins..beh..ci saranno da fare delle modifiche al kext nella migliore delle ipotesi

 

Anche se all'inizio mi visualizzava la temperatura del northbridge, ambiente e il voltaggio della Cpu?

Faccio qualche ricerca e ti faccio sapere

Share this post


Link to post
Share on other sites

Ho eliminato il F718x.kext plugin, riparato i permessi e il pc si avvia normalmente. ho di nuovo la temperatura del northbridge quella ambiente e il voltaggio della "CPU A". Il kernel lo sembra stranamente troppo breve:

[/b]Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: systemShutdown true
Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: systemShutdown true
Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: Kext loading now disabled.
Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: Kext unloading now disabled.
Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: Kext autounloading now disabled.
Jul  9 13:41:23 Mac-Pro-di-Pexta kernel[0]: Kernel requests now disabled.
Jul  9 13:42:01 localhost kernel[0]: Media/IOGUIDPartitionScheme/Snow Leopard@2
Jul  9 13:42:01 localhost kernel[0]: BSD root: disk0s2, major 14, minor 2
Jul  9 13:42:01 localhost kernel[0]: Kernel is LP64
Jul  9 13:42:01 localhost kernel[0]: USBMSC Identifier (non-unique): 058F63646476 0x58f 0x6364 0x100
Jul  9 13:42:04 localhost kernel[0]: Waiting for DSMOS...
Jul  9 13:42:04 localhost kernel[0]: systemShutdown false
Jul  9 13:42:07 localhost kernel[0]: Previous Shutdown Cause: 3
Jul  9 13:42:10 Mac-Pro-di-Pexta kernel[0]: DSMOS has arrived
Jul  9 13:42:10 Mac-Pro-di-Pexta kernel[0]: AppleRTL8169Ethernet: Ethernet address 20:cf:30:4c:23:73
Jul  9 13:42:10 Mac-Pro-di-Pexta kernel[0]: ** Device in slot: SLOT--1 **
Jul  9 13:42:11 Mac-Pro-di-Pexta kernel[0]: AppleTyMCEDriver::start coreVIDPID = 0xffffffff Number of packages = 1 Number of cpus = 8 memory monitor trough MCA
Jul  9 13:42:13 Mac-Pro-di-Pexta kernel[0]: 2.3.09 Little Snitch: connection deferred for:/usr/libexec/XProtectUpdater uid:0 to:17.250.248.105 :80
Jul  9 13:42:15: --- last message repeated 1 time ---
Jul  9 13:42:15 Mac-Pro-di-Pexta kernel[0]: Sound assertion "0 != result" failed in AppleHDAWidget at line 3866 goto handler
Jul  9 13:42:15 Mac-Pro-di-Pexta kernel[0]: Sound assertion "0 != widget->setUnsolicited ( true )" failed in AppleHDACodecGeneric at line 1153 goto handler
[b]

Share this post


Link to post
Share on other sites

Ps: oggi avevo la necessita di avviare il sistema a 32 bit e Kernel panic fù! Morale della favola: dopo varie prove sto utilizzando (dei 4 plug-in contenuti all'interno del superIOFamily.kext)i plug-n IT87x.kext e W836x.kext , con questi due mi funzionano le temperature per tutte le cpu, gpu diode, ambient, northbridge, disco rigido e voltaggio della CPU A; il tutto solo a 64 bit.

Salute! :)

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×