Jump to content

Compaq Presario V6301AU (AMD) SL Issues

1 post in this topic

Recommended Posts

Hey folks! I recently posted on here a month or so ago regarding issues on my Asus P5N-T Deluxe board for a Mac OS X install. Now I've decided to try another install, but this time on my Compaq Presario V6301AU (part of the V6000 series) notebook.


The specs for this machine are as follows:

* AMD Turion 64 x 2 1.86Ghz Mobile Processor

* Team Dark 2GB DDR2 800Mhz RAM

* NVIDIA GeForce Go 6150 On Board Graphics (Memory Shared with System) + NVIDIA nForce Chipset & LAN Controller

* Western Digital WD3200BEVT 320GB Hard Drive

* TSSTcorp TS-L632D CD/DVD Drive/Burner

* Broadcom BCM94321MC Wi-Fi Card (Dual Band 2.4 & 5 GHz)

* Synaptics Touchpad + On Board Keyboard


I've managed to install the OS through nawcom's ModUSB with the Snow Leopard image (retail 10.6.4, same disc) and despite a long install time, the install went well. The system is using the Legacy Kernel from nawcom (10.7), however I'm having a few major issues at the moment.


First issue is the onboard trackpad and keyboard. When I boot into the system, the trackpad and keyboard would not respond and the whole desktop would freeze, but applications would still open and prompts would appear but couldn't be closed. I've tried VoodooPS2Controller and the ApplePS2Controller kexts and I'm still having the issues. I've also noticed that the Caps Lock light would stay on when I used the VoodooPS2Controller kext.


Another issue is with the on board graphics and Wi-Fi. I know the GeForce GO 6150 doesn't support QE/QI due to the shared memory, but I've been trying to get the resolution working (stuck on 1024x768). I've tried the NVInjectGo kexts that I found on one of the posts here, but when I go and change the resolution, the system kernel panics and automatically reboots. Also the Wi-Fi card is also recognised as an AirPort card but can't find or connect to any networks.


I've searched everywhere on how to get or at least fix up the graphics, wi-fi and trackpad and keyboard working but to no avail. So has anyone had any experience in attempting or has installed Mac OS X on this notebook or any V6000 series model?

Link to comment
Share on other sites


  • Create New...