Jump to content
InsanelyMac Forum
zentili

Lion DP3 Installed on P5QL/EPU, HD4850 fully working

Recommended Posts

Hiv :thumbsdown_anim:

This forum helped me a lot since a long time with osx86 installing so i thought it's time to give something back.

After several days/nights of try i finally managed to make lion dp3 fully work on my system, that is:

 

Motherboard: Asus P5QL/EPU

CPU: Intel Core 2 Duo E8400 @ 3,00 Ghz

Graphics: ATI Sapphire HD4850

Ethernet: RTL8169xx

Audio: Integrated High Def

No other relevant information i think

 

So this is what i did:

 

Followed this guide http://www.insanelymac.com/forum/index.php?showtopic=256729 adapting it to install in SATA HD partitioned like this

Scheme: GUID of course

- Partition 1 HFS+ with working Snow Leopard and chameleon with kexts installed

- Partition 2 HFS+ empty for Lion

UPDATE: DSDT Patching done, all good :angry2:

One other thing i skipped from the above guide is the chameleon installation because it's already installed on the HD and made the installation usb boot from the already installed chameleon(RC5) without any flags (-v). The system installed, everything went fine and at that point i was able to boot into Lion.

 

Of course absolutely no graphics ootb, but i will treat that later.

No audio and that is simply fixed by installing VoodooHDA. (The package i used: http://code.google.com/p/voodoohda/downloa...p;can=2&q= )

Strangely, no network too (this card never gave me a problem under leopard and snow at avery update, it just worked all the time). I fixed it by replacing IONetworkingfamily.kext in /System/Library/Extensions with my Snow Leopard 10.6.7 one. *don't forget to ripair permissions/install kexts with kext utility or it will give you an error*. After reboot AppleRTL816xx ethernet kext was properly loaded and my network card get recognized. If anybody is having troubles and needs that kext just let me know and i'll post it, that just did the trick for me.

Finally, the interesting part.

Just like in Snow, my ATI HD4850 gave me no resolution-changing ad of course no QE/CI in Lion. Here the steps i did to make it work with full QE/CI support and a lot of resolutions, it's pretty simple:

-Added 0x94421002 device-id in /S/L/E/ATI4800controller.kext

-Installed the latest ATY_Init.kext from netkas ( http://www.kexts.com/view/1262-aty_init_lion_+_snow.html )

-Repaired permissions

-Rebooted

-After reboot: :o WOW QE/CI Enabled!

Unfortunately i have to use SwitchResX to get my monitor's native resolution (1360x768@60) because - dunno why - it's not listed in display preferences (any kind of resolution appears except from mine). This happens in snow too and if someone knows a better solution than switchresx i'd be very glad to get into that. Useless to say that i tried any sort of "Graphics Mode"= blablaxblabla in booting e com.apple.boot.plist without results. However, switchresx does his job and Lion on my PC is finally complete and 100% working.

 

UPDATE: The system was showing only one core, got this fixed by disabling MaxCPUID in BIOS!

 

Hope i've been clear enough, i'm not native-english hehe

..and hope this will help someone too, see you :)

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×