Jump to content

troubleshooting logicboard issues on a 1.83 GHz core 2 duo mac mini

2 posts in this topic

Recommended Posts

Greetings to all my fellow OSX86 Enthusiasts.


I'm posting this on this forum as I feel the members here are much smarter when it comes to being able to troubleshoot and fix hardware related issues.


I've recently acquired two "parts machine" Apple Intel Mac Mini systems off ebay. The first one has a definately motherboard (Logic board) issue, it won't power on beyond the fan turning on and the white led on the front lighting up, doesn't chime or display video. I'm in the process of getting a replacement logic board for that one, no sense in beating a dead horse.



for the second one, it has a pretty bizarre issue. when booting the system it only will successfully boot into OSX Snow Leopard if I hold down the shift key, same goes for booting it off my OSX Snow Leopard install DVD.


After zeroing out the hard drive on this system and then booting the snow leopard disk in safe mode I did a clean install and then attempted to boot Snow Leopard on the Mini with verbose output so I could see where it's stopping.


It stops almost immediately after DSMOS has arrived with no errors or indications as to what the problem is. I have let it sit like that for hours to see if it would eventually boot into the graphical portion of OSX but it never does.


Booting the system in Safe mode works but I don't have a working Airport or sound card, just regular Wired Ethernet.


Attempts to update result in a broken OSX install.


I've tried booting the unit without the Airport card installed to see if that might be causing the problems, same results, only boots in safe mode.


I took it to the Apple Genius Bar and after they examined it they quoted me $200 dollars to fix it, Which leads me to believe that it's probably a firmware issue as normally from what I've heard when Apple replaces a logic board it's usually $300 or $400 dollars and most apple customers normally opt for just buying a new mac system.


Is there any way for me to try forcing the system to reflash the EFI firmware with the current release of the Firmware from Apple. when I tried to run their updates for SMC and EFI on this unit it tells me that it doesn't need these updates.

Share this post

Link to post
Share on other sites

Dude, were on the same boat. I have a Core 2 Duo 15" MacBook Pro that hangs right after DSMOS has arrived. The thing that sucks about mine is that it does not even boot Safe Mode or any of the Retails disc. Just hangs at the same location with everything. I was able to get my hands on the Hardware Test Disc and it has checked out good. So I am still stumped :-/


Also, cant you download a Firmware Reset program for your Mac?



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.