Jump to content

Asus Eee Box EB1012P (Atom D510, Nvidia ION 2) hangs with install DVD

1 post in this topic

Recommended Posts

Hi everyone. I decided to try to install OS X using a retail 10.6 (10.6.0, if you will) install DVD on my Asus Eee Box EB1012P (specifications can be found here: http://www.asus.com/Eee/EeeBox_PC/EeeBox_P...#specifications--it has an Intel Atom D510 processor, Nvidia ION 2 graphics, etc) and haven't been able to get it to boot either the install DVD (or by installing OS X from my Macbook Pro using a USB to SATA adapter). Since I don't have an optical drive, I've been using a 32GB flash drive to try to install the OS. I have tried using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] (3.0.2), NetbookInstaller (0.8.5pre), and myHack 1.1 all with varying levels of failure.



Trying to boot the install DVD from the flash drive (using these instructions: http://howtohackintosh.wordpress.com/guide...allation-guide/) just leads to the OS X boot screen showing the Apple logo but no loading indicator (the spinning circle). There is no disk activity in the computer or on the flash drive at this point. I tried using the arguments PCIRootUID=1, then I tried PCIRootUID=1 -x, then I just tried -x (per this guide: http://tonymacx86.blogspot.com/2010/04/ibo...ac-os-x-on.html) and it all led to the same thing. I've let it sit at this screen, just to make sure, and it doesn't end up doing anything.


When trying to load the install DVD from the flash drive using NetbookInstaller it leads to a kernel panic. I tried the same thing using MyHack 1.1 and it also leads to a kernel panic.


I installed 10.6 by hooking up the Eee box's drive to my Macbook Pro using a USB to SATA adapter and tried to boot it (I installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] onto a flash drive and tried to use it to boot from the SATA drive post-install) and it just showed the apple logo with no loading indicator and no activity.



I couldn't get the installer to boot using -v through [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] (it just led to a black screen and never got to the boot screen) but when I ran MyHack using -v it gave me this:



I ran the installer with MyHack using -v cpus=1 and it gave me the same result. When I had kernel panics using the NetbookInstaller it spit out similar information ("Should have 2 Cores, but only found 1 for Die 0"@/SourceCache/xnu/xnu-1456.1.25/osfmk/i386/cpu_th")



I figured the cpus=1 argument would solve the issue but it didn't do a thing, so I'm not sure what's up. Anyone have any idea? I haven't seen anyone else with success stories using the EB1012P and I can't find any guidance as to how to make it work correctly (it would be a different story, getting the various hardware to function correctly, if I could actually get it to boot). I haven't seen anyone else with a D510 having this problem (with different computers), so I'm at a loss, especially since I haven't been around the OSx86 scene for a long time.


I've been using it hooked up through HDMI to a TV and using a USB keyboard and mouse, for what it's worth. I unplugged the HDMI cable and tried booting it (using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]) just in case the HDMI was causing problems, but it led to the same results as before (not sure how the other two would have fared without HDMI plugged in, but I doubt it would have been better) Also, I do have ACPI enabled in my BIOS, if that helps.


Any ideas, anyone? Thanks for any help :)

Link to comment
Share on other sites


  • Create New...