Jump to content

USB Mass Storage fix

1 post in this topic

Recommended Posts

I know this topic has been bashed to death but I thought I'd add the fix that worked for me.


Once at my desktop I had use of USB keyboard & mouse but trying to connect any USB drive would crash my system.



Step 1: Copying "IOUSBMassStorageClass.kext"

Open Finder /System/Library/Extensions

Copy "IOUSBMassStorageClass.kext"

Locate "IOUSBFamily.kext"

Right-click Select "Show Package Contents"

Find & Open "Plugins" folder

Paste "IOUSBMassStorageClass.kext"



Step 2: Repairing Permissions

Click "Spotlight"

Type in "Disk Utility"

Select the drive you're using

Click "Repair Permissions"

when completed reboot



Step 3: Download & Install updated IOUSBFamily.kext

Go to


Download the latest IOUSBFamily.kext for the version of OSx you're using

(sadly Apple requires free sign-up)

For 10.5.6 I chose "IOUSBFamily.kext" v3.2.7

Once downloaded dluble-click to open .dmg

double click on "IOUSBFamily-327.4.0.pkg and follow instructions

Allow it to reboot when required

Use "-f" switch when rebooting


Your Mileage may vary but this worked for me on an nForce2 and nForce3 system.




Ancient Gigabyte GA-K8NS

AMD 3000+

Even older Nvidia FX5600 256Mb


Install disc:

iDeneb v1.4 (10.5.6)

installed with (Customize Options)

* Audio: AC'97

* Chipset: all BUT appleNforceata & appleNforceata test

* AMD patch

* Kernel: Sleep kernel 9.2.0


* Wired: Forcedeth

* Wireless: Realtek RTL8187


* IOUSBFamily fix

* Seatbelt fix

* smbios old bios v1.0.1

* Video: NVInject 256



It won't boot yet due to a conflict with "NVDAResman.kext", so we'll rename it


After install boot using -s

at the prompt type

mount -vw /

(allows you to modify files)


cd /System/Library

rm Extensions.mkext

(removes kext cache)


cd Extensions

mv NVDAResman.kext NVDAResman.911

(renames the pesky NVDAResman.kext so it won't cause my system to hang at boot)

reboot now

This should leave at your desktop

Link to comment
Share on other sites


  • Create New...