Jump to content

HP zd7260us Laptop - Tried a few distros, seems like HDD Controller issues. Ideas?


CleverCoder
 Share

1 post in this topic

Recommended Posts

Good afternoon,

 

After beating on this laptop for a few days and trolling many forums, I've decided to broadcast my efforts to what seems to be a good audience. I've been trying to install an OSX distro on my slightly aged HP zd7260us Notebook computer. I have tried a few distros, including iATKOS S3 v2, Hazard 10.6.6i, Hazard 10.6.2, and even retail DVD.

 

The older Hazard distro and retail DVD seem to reboot during the early start phases. Some of the more interesting boot flags I have attempted are:

-x : Safe mode

-v : Verbose (obviously useful)

platform=ACPI|x86pc

cpus=1

maxmem=2048 (Turns out my machine only has 2 gig anyway, so this was a no-op)

 

The Hazard distro seems to let me get to the installer where I can select a disk. I just bought a new 160 GB Western Digital "Scorpio" drive for the experiement (makes it easy to just go back to boring Windows if all else fails). Initially the drive was unparitioned, but I could launch the Disk Utility to erase the disk. This is where the problems start to happen.

 

Observations:

- I can erase the disk and create partitions

- When I try to verify the disk, it will hang after an initial blip of the HDD light and do nothing. (I've let it sit)

- Even if I don't attempt a verify, I go back to the install screen and when I hit install (or configure first), the installing progress indicator appears, but then it just seems to do nothing. No drive activity and no progress.

 

I've also tried booting from another EFI boot disk and installing from an external HD as well as a USB disk. Same behavior. There is a random component to this as well. Other observations:

- Occasional hang right after the Broadcomm initialize line appears

 

Based on some of what I have read, it seems that there might be issues with HDD controller compatibility. It's an 82801EB Intel chip (ICH5) that I've seen drivers to correct SATA issues. This is an older ATA drive.

 

So, here's my specs:

 

Model: HP zd7260us

http://h10025.www1.hp.com/ewfrf/wc/product...lang=&cc=us

 

CPU: Intel P4 @ 2.8GHz HT

RAM: 2048 MB

Chipset: Intel i848/i865 – FSB:199 MHz

Northbridge: Intel i865P/PE/G/i848P rev. A2

Southbridge: Intel 82801EB (ICH5) rev. 02

NVIDIA GeForce FX Go5700

 

So... can this end well? I'm thinking that the trick might be to build a custom installer that has certain drivers that work with my hardware. I can also yank the network card out if it might help...

 

Any initial thoughts?

 

EDIT:

 

For what it's worth, I have enumerated the hardware with a copy of Ubuntu I was able to successfully install. Attached is the screenshot showing the device information. At this point, I'm just going to wait and try again another day. I would like to know if there are any red flags or others who have experienced an unresponsive hard drive.

 

Also, I switched out the hard drive to another, older 80 GB and the same thing happened. I also tried to install to the HD using an extenal USB drive adapter, with the same behavior. It seems controller or CPU related..

 

Cheers!

-Sean

post-795046-1305396618_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...