Jump to content

Flash problems on AMD 10.6.7


2 posts in this topic

Recommended Posts

My system details are below.


o 1 x MSI NF750-G55 AM3 NVIDIA nForce 750a SLI HDMI ATX AMD Motherboard

o 1 x EVGA 01G-P3-N959-TR GeForce 9500 GT 1GB 128-bit DDR2 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

o 1 x AMD Phenom II X4 955 Black Edition Deneb 3.2GHz Socket AM3 125W Quad-Core Processor HDZ955FBGMBOX

o 1 x G.SKILL Value Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600) Desktop Memory Model F3-10600CL9D-8GBNT

2 x SATA drives, one running windows 7, and Debian and OSX sharing the other.


I've gotten everything except on-board audio working smoothly using a retail install. All the kexts i tried for my Realtec ALC889 chipset have failed. Audio does work with a USB headset. However, when I try to play flash video all I ever get is a black box with no audio, and when I try to reinstall Adobe flash player, I get an error that says Install Adobe Flash Player quit unexpectedly. The full problem details are in the codebox below.


Process:         Adobe Flash Player Install Manager [789]
Path:            /Volumes/Flash Player 1/Install Adobe Flash Player.app/Contents/MacOS/Adobe Flash Player Install Manager
Identifier:      com.adobe.flashplayer.installmanager
Version:         ??? (???)
Code Type:       PPC (Translated)
Parent Process:  launchd [101]

Date/Time:       2011-04-21 01:14:28.008 -0500
OS Version:      Mac OS X 10.6.7 (10J869)
Report Version:  6

Interval Since Last Report:          9813 sec
Crashes Since Last Report:           1251
Per-App Crashes Since Last Report:   4
Anonymous UUID:                      A0EFC9A9-5A61-47C8-8F49-823731B1F589

Exception Codes: 0x0000000000000001, 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   dyld                          	0x8fe2b7af _sysenter_trap + 3
1   dyld                          	0x8fe2d5da mach_init + 47
2   dyld                          	0x8fe01766 dyldbootstrap::start(macho_header const*, int, char const**, long) + 448
3   dyld                          	0x8fe01057 _dyld_start + 39

Thread 0 crashed with X86 Thread State (32-bit):
 eax: 0xffffffe4  ebx: 0x8fe2d49c  ecx: 0xbffff9ac  edx: 0x8fe2dce2
 edi: 0x00000000  esi: 0x00000000  ebp: 0xbffff9f8  esp: 0xbffff9ac
  ss: 0x0000001f  efl: 0x00010282  eip: 0x8fe2b7af   cs: 0x00000017
  ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000000
 cr2: 0x8fe2b7ac

Binary Images:
0x8fe00000 - 0x8fe4162b  dyld 132.1 (???) <1C06ECD9-A2D7-BB10-AF50-0F2B598A7DEC> /usr/lib/dyld

Model: Macmini2,1, BootROM MM21.009A.B00, 4 processors, 3.2 GHz, 8 GB, SMC 1.30f3
Graphics: GeForce 9500 GT, GeForce 9500 GT, PCIe, 1024 MB
Memory Module: global_name
Network Service: Ethernet Adaptor (en0), Ethernet, en0
PCI Card: GeForce 9500 GT, Display, Slot-1
Serial ATA Device: TSSTcorp CDDVDW SH-S223C, 4.38 GB
Serial ATA Device: WDC WD5000AAKS-00A7B0, 465.76 GB
Serial ATA Device: WDC WD10EARS-00Z5B1, 931.51 GB
USB Device: Kensington Expert Mouse, 0x047d  (Kensington), 0x1020, 0x02100000
USB Device: C-Media USB Headphone Set, 0x0d8c  (C-MEDIA ELECTRONICS INC.), 0x000c, 0x04400000


Anybody know how I can fix my flash?

Link to comment
Share on other sites

I assume you are using a patched kernel cause I think it has something to do with this. I put my laptop HDD into my tower-PC for a test (it has an Intel CPU) to boot with mach_kernel. There it worked. But when I'm booting with legacy_kernel it doesnt. I think you have to try old flash player versions from Adobes archive

Link to comment
Share on other sites


  • Create New...