Jump to content

A8N-SLI (nForce...eww/waiting for root device)


1 post in this topic

Recommended Posts

So the final straw happened recently with my PC (xP just wasn't cutting it, I hated vista, and I'm not sold on 7 yet)



I decided to gather some intel, try a distro, and attempt to get some results.


Here's my setup

-MB: A8N-SLI (Asus)

-CPU: Athlon 64 3500+ (AMD) <---most likely causing the problem

-GPU: GeForce 6600GT (NVIDIA)


I am using the iPC Leopard Final 10.5.6 release.


Darwin boots and accepts my flags and proceeds to load the installation in verbose.

I reach a point where OSX is "still waiting for the root device"

I noted this and took to research.


Now, I saw several solutions, many of which seemed to contradict each other, none of which that worked. I have two IDE drives (optical) that I tried. One would not even boot the dvd. The other caused the "root device" error. One of the solutions that I have not tried is an external drive. I might be able to borrow an IDE-USB adapter from an IT friend of mine. Would this work? People seemed to be having more success with SATA drives as long as the BIOS was configured properly.


Also, I noted that other people are using the nForce chipset and are getting working installations. i think most of them were using the kalyway image. I believe I saw another one with a patched iATKOS image.


My true question is: Has anyone figured out a reliable fix for the nForce chipset?


Thank you in advance.

Link to comment
Share on other sites


  • Create New...