Jump to content

I cannot for the life of me get that damned 889a to function, Tried many many ways, still doesn't work!


1 post in this topic

Recommended Posts

(Moved here because I think I posted this in the wrong section) I know there are a lot of posts for sound but I honestly believe I have tried everything. I have a Gigabyte GA-790XT-UD4P coupled with an AMD Phenom II X4 945. With the retail install DVD, I installed it to my drives with osx86 ModUSB or whatever it's called, by Nawcom because it's the only one I got to boot on this board.


This is actually the second time I try reinstalling, to see if I can do something about it from the get-go.


So I proceeded with the install and deselected anything that had to do with audio so I could install it from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] later. The first thing I did was get my HD4780 to work with QE/CI so I could then focus on Audio, since everything else pretty much works.


I have only updated until 10.6.6 just in case it's more compatible (my first try was in 10.6.7). I kept the vanilla AppleHDA because my board has the 889a codec, which from what I gather exists in actual Macs, so it can be recognized without modifying it. I then proceeded to install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]'s ALC8xxHDA and the ALC885/889a enabler, WITHOUT the AppleHDA rollback.


Obivously the card now shows up in system profiler, but nothing is there in the Sound preference panel, so still no output.


On my previous install with the same Hardware but another Hard Drive in 10.6.7, I could only get sound with VoodooHDA and it would mix up all the ports, not to mention that it sounded like {censored} too and if I tried watching Flash videos on YouTube for example, the video would skip horribly.


I should also mention it's impossible for me to generate a correct DSDT because its missing a lot of entries, nor can I find a DSDT compiled by someone else. So I attempted this method too.


So all in all, I'm completely lost, could anyone give me a hand here? I'm sure there is someone really competent and well versed in this who could help me. I would be eternally grateful!

Link to comment
Share on other sites


  • Create New...