Jump to content

Brdcom 4306 not working on jas 10.5.4 coming up as Atheros?


1 post in this topic

Recommended Posts



I recently installed Jas 10.5.4 on a Dell Inspiron 8500 SSE2. I installed Jas 10.4.6 prior to this release and noticed my wireless card worked without issues. This release is showing a major struggle w/ making the wireless work. I have tried numerous attempts, but am still without wireless. Ethernet works perfect and is recognized properly. I have used osx86 tools to find out it is a broadcom bcm4306 card. I have tried the bcm_xx script update located on here and noticed that when running the script in terminal, it states that it cannot find the broadcom kext in the io80211 family kext. The script looks like it installs, but upon reboot there is no difference. In all of my attempts, I somehow found that it looks as though the OS is recognizing my card as an atheros card. I have tried multiple solutions including taking the io80211 kext from the 10.4.6 disc and replacing it in 10.5.4, but to no avail. I have read multiple threads, but nothing that seems to point to my theory that an atheros driver was somehow installed instead of a broadcom driver. maybe i am wrong, but I think that is my problem. I reinstalled the 10.5.4 release from scratch and made sure to only select the broadcom driver at custom install. Still no joy.... ANY HELP WOULD GREATLY BE APPRECIATED!!



Link to comment
Share on other sites


  • Create New...