Jump to content

OSX Leopard On An AMD system - my experiences...


7 posts in this topic

Recommended Posts

Hello folks!


This is my first post here after reading many helpful threads, so I though I'd join and share my experiences with my OSX installation. I installed "iPC OSx86 Leopard 10.5.6 Intel AMD SSE2 SSE3".


First up, here's the system I am running:


CPU: AMD Athlon 64 Dual Core 4200+, 2.20GHz

Motherboard: Gigabyte GA-MA770-S3P F2

Video Card: NVIDIA GeForce 8600GT 256MB

Display: 2 x AOC 193FW 19" LCD monitors.

Ram: 4 Gig

Sound Card: Emagic A62 (External USB1 Device), onboard disabled.

Hard Drives: OSX installed on a Samsung 500GB, various other drives for data storage.

Optical drves: ASUS and Pioneer DVD burners.




Of course, I had some issues, as this was the first time I have attempted an OSX86 installation. Here's some problems I came up against, and how I solved/got around them.


Hardware Configuration:


  • As I didn't want to play around with a multiple boot system, I installed a caddy system to swap Operating System drives (OSx86 and Win XP). I shut down, swap drives, and start up again.
  • The first problem involved AHCI settings. I had to enable this to get the installation disk to boot. My motherboard has a setting for SATA ports - 0 to 3, and another for 4 and 5, which both have to be set to ACHI, rather than IDE. I have to disable AHCI to boot in XP.
  • I usually use a PS/2 keyboard on my PC, but I had to swap to a USB keyboard to run OSx86, despite trying the PS/2 keyboard patch supplied with the iPC disk.

OSx86 Installation:


After a lot of trial and error, I finally have a list of items to tick in the Customize section of the install process. The following is a list of what I install:


Kernel: 9.5.0 Voodoo Kernel


Display Drivers: NVdarwin 256MB


Chipset Drivers: ALL


Fixes and Patches: Firewire mount fix, USB mount fix, Shutdown/Restart, SATA Drive Icon Fix (New).


Applications: Marvins AMD Utility, OSx86 Tools Utility, Universal OSx86 Installer, MKext Tool.


**** Note that I have not listed any Ethernet port drivers. More on that later. ****


This gets me most of the way to having my system running. A couple of restarts and things seem ok, and I can get started installing drivers for the network port and sound card.


Graphics Card and Video Displays: After a few (failed) attempts at installation, I settled on the NVdarwin 256MB driver for the video, as it came up with all the right data and had Quartz Extreme enabled. I had a lot of dramas getting the video card to set the resolution of the primary display to 1440x900. The secondary display worked without a problem, but not the primary. After a lot of searching and experimenting with 3rd party programs to force resolution changes, editing com.apple.Boot.plist (which had no effect), I found out that if all 15 pins of the VGA cable are not connected, the computer cannot communicate with the monitor to get it's info. I had my primary monitor running through a chap switch box, so I could switch the moniotr over to another PC. It turns out that the switch box is not connecting all the pins in the VGA cable. Once I eliminated the switch box, I had no problems getting the required resolution.


Network/Ethernet Port: The network port on this motherboard is a RealTek 8111c. After installing OSX86 using it's own Network drivers, the network port was called a RealTek R1000 in the list of devices installed. This is why I don't use the iPC installation to install the network drivers. I went to RealTek's website and downloaded the appropriate drivers, which worked perfectly. The system now picks up my home network, servers, and internet connection without a problem.


Audio Device Installation: This went without a problem, using the Mac device drivers on the CD supplied with the Emagic A62.




Other Issues And Some Fixes:


  • I tried to update OSX 10.5.6 to 10.5.8 using the Mac update. The system would not boot after that, so I had to reinstall. I have yet to figure out how to update, or if I really need to.
  • I use several NTFS drives in the PC (internal and external), which OSX could read just fine, but could not write to. After installing a 3rd party freeware program, I now have full read/write access to these drives.
  • I had my first "kernel panic" while downloading freeware using Safari. On two occasions, from two different sites, the system would have a panic at the end of the download. I don't know if this is a problem with Safari or not. I plan to try Mozilla Firefox and see how that goes.
  • There was one installation that would not shutdown properly. The "Shutdown/Restart" patch on the installation DVD fixed that on the next installation attempt.



My next mission (and it does not look promising) is to install a DigiDesign 001 system into the computer. I have it running fine on an old G4, but would love to get it running on the Hackintosh. From I have read so far, it has not been successfully done by anyone yet. I'll post up any progress I have with it, but don't expect greatness on this one!


After all this trial and error, I think I have a stable system on my hands! I hope this helps somebody. Any comments, suggestions or questions welcome, and I'll do my best with my limited knowledge to help out.

Link to comment
Share on other sites

Further to the above post, I have installed Mozilla Firefox v4, and it seems to be working fine, and I can download without a Kernel Panic.


The DigiDesign 001 card is another issue. I have installed it in the PC, but OSX does not recognize that it is even plugged into a PCI slot. To me, that kinda kills that idea of having the 001 running. I'll just have to stick with the Emagic external audio for the time being.


Also, I found that when my Hackintosh tries to go into sleep mode, it resets the whole computer. My fix for this was just to disable sleep mode.


I now have both of my operating system (OSX and Win XP) hard disks mounted in the PC. In the BIOS I have set the controller for the Win XP boot disk as Native IDE, along with one of the DVD Burners. The rest of the disks are now running on AHCI. When I turn on the computer, the default boot disk is Win XP, and to get it to boot into OSX, I use the F12 BIOS boot device menu. This way I did not have to play around with Boot Manager Partitions, something which I was never very good at.


When in OSX, I can read and write to every hard disk except the Win XP disk, which suits me just fine. And when in Win XP, I can't read or write to the OSX disk, so that is perfect.


All in all, I'm pretty happy with the way it turned out!

Link to comment
Share on other sites

:huh: 1st of all congrats for successful osx installation.

well i am using 10.5.2. i see that u r using usb k/b and not ps/2 since the patch didnt worked, well i am using ps/2 keyboard and all i have to do is after the desktop shows i just disconnect and then connect the k/b and thats all, it starts working.


and f12 issue is same here, with the same process as urs but i think that installing grub2 will give u some help to select ur os. well i have not tested yet but will try out soon.


and yes there is partition table format issues in os x and xp but i have not faced with win 7 and os x. from os x i can r/w the win 7 partition. and from win 7 since hfs is not recongnized by windows normally so the matter of r/w to mac is over. :)


i dont know digi1000 prob solution but did u google about this issue , sure u did and if not then do it. hopefully u get solution. i think u have to manually make mac detect the card. woudnt be a same prob with snow leopard i think since i saw that 10.6 recons every pci device and plays much more fast than prev distros.


take care

Link to comment
Share on other sites

i dont know digi1000 prob solution but did u google about this issue , sure u did and if not then do it. hopefully u get solution. i think u have to manually make mac detect the card. woudnt be a same prob with snow leopard i think since i saw that 10.6 recons every pci device and plays much more fast than prev distros.


Hi scorpdevil,


I will look into 10.6, and see if it ill recognize the pci card. I have s friend with 10.6 installed, so I might ask him very nicely! Thanks for the tip!



Link to comment
Share on other sites

welcome charvel


now i am having some prob installing 10.6 actually when i installed snow on vmware it went fine. but now when i am tryn to install in hdd then during boot after complete installation its showin kernel panic. i dont have digi cam so cant photo the error.


but something "apple acpi" error is shown and then it just freezes. the last line showing system uptime. the distro is leo hazard. i have posted this in hazard forum bt no reply for 2 weeks.

do u have any idea how to install snow in amd.


ok this is the panic error:




Link to comment
Share on other sites

Hi scorpdevil,


I'm afraid I can't help you on that one. I don't know anything about OSx86 except for what I have documented in this thread, as this is the first time I have installed OSx86 on any machine.


Good luck with solving your problem. I hope you get it resolved soon!

Link to comment
Share on other sites


  • Create New...